Apresentação

O que é o ACBrMonitor?

O ACBrMonitor é um programa executável desenvolvido usando os componentes do ACBr. A finalidade do ACBrMonitor é permitir que qualquer linguagem capaz de ler e criar arquivos TXT ou utilizar Sockets (TCP/IP) consiga usar todos os recursos dos componentes ACBr.

Como Funciona?

O ACBrMonitor após executado será minimizado para o SysTray da máquina (ao lado do relógio), e ficará aguardando comandos na sintaxe dos componentes ACBr . Você pode abrir o ACBrMonitor, clicando no ícone do SysTray.

Os comandos podem ser enviados para o ACBrMonitor por arquivo texto ou sockets, a sintaxe dos comandos é idêntica em ambos os casos. A resposta dos equipamentos de automação controlados pelo ACBrMonitor (Ex: ECF) será devolvida a Aplicação pelo ACBrMonitor também usando um arquivo texto de saída ou sockets, (conforme a configuração).

O Instalador do ACBrMonitor irá adiciona-lo na pasta de Inicialização do seu micro, portanto, sempre que o Sistema operacional for iniciado o ACBrMonitor entrará em execução.

Antes de iniciar o uso do ACBrMonitor, é necessário configura-lo corretamente, informando o método de monitoramento (TXT ou TCP). Também e necessário configurar os equipamentos de automação controlados pelo ACBrMonitor, informando o Modelo e a porta dos equipamentos. Na interface do ACBrMonitor é possível testar se a configuração do equipamento está correta...

Nota Importante da versão 0.9.0

A partir da versão 0.9.0, a comunicação por Sockets (TCP/IP) precisou ser modificada para permitir o suporte do Objeto BOLETO.

O Terminador de envio foi modificado de:

CR+LF

para

CR+LF+'.'+CR+LF ou #13+#10+#46+#13+#10

Created with the Personal Edition of HelpNDoc: Easily create iPhone documentation

Copyright © <2008..> by <ACBr - Automação Comercial Brasil>


Como usar o ACBrMonitor

Created with the Personal Edition of HelpNDoc: Easily create EBooks


Vantagens do ACBrMonitor

  • Multi-plataforma:
    O ACBrMonitor está disponível em Linux e Windows e na versão Gráfica e Console
  • Interoperabilidade:
    Praticamente qualquer linguagem pode interagir com o ACBrMonitor, através da troca de arquivos TXT ou Sokets (TCP/IP)
  • Acesso Remoto:
    Permite a comunicação remota com equipamentos de Automação. Útil para topologias de Terminal Remoto (ou terminal Burro). Ex: SSH, Telnet, WTS, etc
  • Programação Limpa e Clara:
    Uma vez que o seu programa esteja apto a interagir com o ACBrMonitor, ele poderá interagir com qualquer ECF ou equipamento suportado pelo ACBrMonitor
  • Fácil distribuição:
    Apenas 1 arquivo instalador, de simples aplicação

Created with the Personal Edition of HelpNDoc: Free Web Help generator


Licença

Este programa é software livre; você pode redistribuí-lo e/ou modificá-lo sob os termos da Licença Pública Geral GNU, conforme publicada pela Free Software Foundation; tanto a versão 2 da Licença como (a seu critério) qualquer versão mais nova.

Este programa é distribuído na expectativa de ser útil, mas SEM NENHUMA GARANTIA; nem mesmo a garantia implícita de COMERCIALIZAÇÃO OU DE ADEQUAÇÃO A QUALQUER PROPÓSITO EM PARTICULAR. Consulte a Licença Pública Geral GNU para obter mais detalhes. (Arquivo LICENCA.TXT ou LICENSE.TXT)

Se você deseja distribuir este programa em conjunto com uma Aplicação Comercial, ou ainda criar uma modificação desse Programa, por favor leia pelo menos a Introdução da licença abaixo,

Porque o projeto é OpenSource ? É realmente muito difícil fazer um projeto desse tamanho sozinho. Conseguir acesso a diversos equipamentos para testes, em diferentes sistemas operacionais e configurações de máquinas. Por isso acho que compartilhando minhas informações com a comunidade, também serei beneficiado... seja com sugestões, ajuda nos testes, e até mesmo com a colaboração de outros desenvolvedores. (DSA)

LICENÇA PÚBLICA GERAL GNU

Versão 2, junho de 1991

This is an unofficial translation of the GNU General Public License

into Brazilian Portuguese. It was not published by the Free Software

Foundation, and does not legally state the distribution terms for

software that uses the GNU GPL -- only the original English text of

the GNU GPL does that. However, we hope that this translation will

help Brazilian Portuguese speakers understand the GNU GPL better.

Esta é uma tradução não-oficial da Licença Pública Geral GNU ("GPL

GNU") para o português do Brasil. Ela não foi publicada pela Free

Software Foundation, e legalmente não afirma os termos de distribuição

de software que utiliza a GPL GNU -- apenas o texto original da GPL

GNU, em inglês, faz isso. Contudo, esperamos que esta tradução ajude

aos que utilizam o português do Brasil a entender melhor a GPL GNU.

Copyright (C) 1989, 1991 Free Software Foundation, Inc. 675 Mass Ave,

Cambridge, MA 02139, USA

A qualquer pessoa é permitido copiar e distribuir cópias desse

documento de licença, desde que sem qualquer alteração.

Introdução

As licenças de muitos software são desenvolvidas para restringir sua

liberdade de compartilhá-lo e mudá-lo. Contrária a isso, a Licença

Pública Geral GNU pretende garantir sua liberdade de compartilhar e

alterar software livres -- garantindo que o software será livre e

gratuito para os seus usuários. Esta Licença Pública Geral aplica-se à

maioria dos software da Free Software Foundation e a qualquer outro

programa cujo autor decida aplicá-la. (Alguns outros software da FSF

são cobertos pela Licença Pública Geral de Bibliotecas, no entanto.)

Você pode aplicá-la também aos seus programas.

Quando nos referimos a software livre, estamos nos referindo a

liberdade e não a preço. Nossa Licença Pública Geral foi desenvolvida

para garantir que você tenha a liberdade de distribuir cópias de

software livre (e cobrar por isso, se quiser); que você receba o

código-fonte ou tenha acesso a ele, se quiser; que você possa mudar o

software ou utilizar partes dele em novos programas livres e

gratuitos; e que você saiba que pode fazer tudo isso.

Para proteger seus direitos, precisamos fazer restrições que impeçam

a qualquer um negar estes direitos ou solicitar que você deles

abdique. Estas restrições traduzem-se em certas responsabilidades para

você, se você for distribuir cópias do software ou modificá-lo.

Por exemplo, se você distribuir cópias de um programa, gratuitamente

ou por alguma quantia, você tem que fornecer aos recebedores todos os

direitos que você possui. Você tem que garantir que eles também

recebam ou possam obter o código-fonte. E você tem que mostrar-lhes

estes termos para que eles possam conhecer seus direitos.

Nós protegemos seus direitos em dois passos: (1) com copyright do

software e (2) com a oferta desta licença, que lhe dá permissão legal

para copiar, distribuir e/ou modificar o software.

Além disso, tanto para a proteção do autor quanto a nossa,

gostaríamos de certificar-nos que todos entendam que não há qualquer

garantia nestes software livres. Se o software é modificado por alguém

mais e passado adiante, queremos que seus recebedores saibam que o que

eles obtiveram não é original, de forma que qualquer problema

introduzido por terceiros não interfira na reputação do autor

original.

Finalmente, qualquer programa é ameaçado constantemente por patentes

de software. Queremos evitar o perigo de que distribuidores de

software livre obtenham patentes individuais, o que tem o efeito de

tornar o programa proprietário. Para prevenir isso, deixamos claro que

qualquer patente tem que ser licenciada para uso livre e gratuito por

qualquer pessoa, ou então que nem necessite ser licenciada.

Os termos e condições precisas para cópia, distribuição e

modificação se encontram abaixo:

LICENÇA PÚBLICA GERAL GNU

TERMOS E CONDIÇÕES PARA CÓPIA, DISTRIBUIÇÃO E MODIFICAÇÃO

0. Esta licença se aplica a qualquer programa ou outro trabalho que

contenha um aviso colocado pelo detentor dos direitos autorais

informando que aquele pode ser distribuído sob as condições desta

Licença Pública Geral. O "Programa" abaixo refere-se a qualquer

programa ou trabalho, e "trabalho baseado no Programa" significa tanto

o Programa em si como quaisquer trabalhos derivados, de acordo com a

lei de direitos autorais: isto quer dizer um trabalho que contenha o

Programa ou parte dele, tanto originalmente ou com modificações, e/ou

tradução para outros idiomas. (Doravante o processo de tradução está

incluído sem limites no termo "modificação".) Cada licenciado é

mencionado como "você".

Atividades outras que a cópia, a distribuição e modificação não estão

cobertas por esta Licença; elas estão fora de seu escopo. O ato de

executar o Programa não é restringido e o resultado do Programa é

coberto apenas se seu conteúdo contenha trabalhos baseados no Programa

(independentemente de terem sido gerados pela execução do

Programa). Se isso é verdadeiro depende do que o programa faz.

1. Você pode copiar e distribuir cópias fiéis do código-fonte do

Programa da mesma forma que você o recebeu, usando qualquer meio,

deste que você conspícua e apropriadamente publique em cada cópia um

aviso de direitos autorais e uma declaração de inexistência de

garantias; mantenha intactas todos os avisos que se referem a esta

Licença e à ausência total de garantias; e forneça a outros

recebedores do Programa uma cópia desta Licença, junto com o Programa.

Você pode cobrar pelo ato físico de transferir uma cópia e pode,

opcionalmente, oferecer garantia em troca de pagamento.

2. Você pode modificar sua cópia ou cópias do Programa, ou qualquer

parte dele, assim gerando um trabalho baseado no Programa, e copiar e

distribuir essas modificações ou trabalhos sob os termos da seção 1

acima, desde que você também se enquadre em todas estas condições:

a) Você tem que fazer com que os arquivos modificados levem avisos

proeminentes afirmando que você alterou os arquivos, incluindo a

data de qualquer alteração.

b) Você tem que fazer com que quaisquer trabalhos que você

distribua ou publique, e que integralmente ou em partes contenham

ou sejam derivados do Programa ou de suas partes, sejam

licenciados, integralmente e sem custo algum para quaisquer

terceiros, sob os termos desta Licença.

c) Se qualquer programa modificado normalmente lê comandos

interativamente quando executados, você tem que fazer com que,

quando iniciado tal uso interativo da forma mais simples, seja

impresso ou mostrado um anúncio de que não há qualquer garantia

(ou então que você fornece a garantia) e que os usuários podem

redistribuir o programa sob estas condições, ainda informando os

usuários como consultar uma cópia desta Licença. (Exceção: se o

Programa em si é interativo mas normalmente não imprime estes

tipos de anúncios, seu trabalho baseado no Programa não precisa

imprimir um anúncio.)

Estas exigências aplicam-se ao trabalho modificado como um todo. Se

seções identificáveis de tal trabalho não são derivadas do Programa, e

podem ser razoavelmente consideradas trabalhos independentes e

separados por si só, então esta Licença, e seus termos, não se aplicam

a estas seções quando você distribui-las como trabalhos em

separado. Mas quando você distribuir as mesmas seções como parte de um

todo que é trabalho baseado no Programa, a distribuição como um todo

tem que se enquadrar nos termos desta Licença, cujas permissões para

outros licenciados se estendem ao todo, portanto também para cada e

toda parte independente de quem a escreveu.

Desta forma, esta seção não tem a intenção de reclamar direitos os

contestar seus direitos sobre o trabalho escrito completamente por

você; ao invés disso, a intenção é a de exercitar o direito de

controlar a distribuição de trabalhos, derivados ou coletivos,

baseados no Programa.

Adicionalmente, a mera adição ao Programa de outro trabalho não

baseado no Programa (ou de trabalho baseado no Programa) em um volume

de armazenamento ou meio de distribuição não faz o outro trabalho

parte do escopo desta Licença.

3. Você pode copiar e distribuir o Programa (ou trabalho baseado

nele, conforme descrito na Seção 2) em código-objeto ou em forma

executável sob os termos das Seções 1 e 2 acima, desde que você

faça um dos seguintes:

a) O acompanhe com o código-fonte completo e em forma acessível

por máquinas, que tem que ser distribuído sob os termos das Seções

1 e 2 acima e em meio normalmente utilizado para o intercâmbio de

software; ou,

b) O acompanhe com uma oferta escrita, válida por pelo menos três

anos, de fornecer a qualquer um, com um custo não superior ao

custo de distribuição física do material, uma cópia do

código-fonte completo e em forma acessível por máquinas, que tem

que ser distribuído sob os termos das Seções 1 e 2 acima e em meio

normalmente utilizado para o intercâmbio de software; ou,

c) O acompanhe com a informação que você recebeu em relação à

oferta de distribuição do código-fonte correspondente. (Esta

alternativa é permitida somente em distribuição não comerciais, e

apenas se você recebeu o programa em forma de código-objeto ou

executável, com oferta de acordo com a Subseção b acima.)

O código-fonte de um trabalho corresponde à forma de trabalho

preferida para se fazer modificações. Para um trabalho em forma

executável, o código-fonte completo significa todo o código-fonte de

todos os módulos que ele contém, mais quaisquer arquivos de definição

de "interface", mais os "scripts" utilizados para se controlar a

compilação e a instalação do executável. Contudo, como exceção

especial, o código-fonte distribuído não precisa incluir qualquer

componente normalmente distribuído (tanto em forma original quanto

binária) com os maiores componentes (o compilador, o "kernel" etc.) do

sistema operacional sob o qual o executável funciona, a menos que o

componente em si acompanhe o executável.

Se a distribuição do executável ou código-objeto é feita através da

oferta de acesso a cópias de algum lugar, então ofertar o acesso

equivalente a cópia, do mesmo lugar, do código-fonte equivale à

distribuição do código-fonte, mesmo que terceiros não sejam compelidos

a copiar o código-fonte com o código-objeto.

4. Você não pode copiar, modificar, sub-licenciar ou distribuir o

Programa, exceto de acordo com as condições expressas nesta

Licença. Qualquer outra tentativa de cópia, modificação,

sub-licenciamento ou distribuição do Programa não é valida, e

cancelará automaticamente os direitos que lhe foram fornecidos por

esta Licença. No entanto, terceiros que de você receberam cópias ou

direitos, fornecidos sob os termos desta Licença, não terão suas

licenças terminadas, desde que permaneçam em total concordância com

ela.

5. Você não é obrigado a aceitar esta Licença já que não a

assinou. No entanto, nada mais o dará permissão para modificar ou

distribuir o Programa ou trabalhos derivados deste. Estas ações são

proibidas por lei, caso você não aceite esta Licença. Desta forma, ao

modificar ou distribuir o Programa (ou qualquer trabalho derivado do

Programa), você estará indicando sua total aceitação desta Licença

para fazê-los, e todos os seus termos e condições para copiar,

distribuir ou modificar o Programa, ou trabalhos baseados nele.

6. Cada vez que você redistribuir o Programa (ou qualquer trabalho

baseado nele), os recebedores adquirirão automaticamente do

licenciador original uma licença para copiar, distribuir ou modificar

o Programa, sujeitos a estes termos e condições. Você não poderá impor

aos recebedores qualquer outra restrição ao exercício dos direitos

então adquiridos. Você não é responsável em garantir a concordância de

terceiros a esta Licença.

7. Se, em conseqüência de decisões judiciais ou alegações de

infringimento de patentes ou quaisquer outras razões (não limitadas a

assuntos relacionados a patentes), condições forem impostas a você

(por ordem judicial, acordos ou outras formas) e que contradigam as

condições desta Licença, elas não o livram das condições desta

Licença. Se você não puder distribuir de forma a satisfazer

simultaneamente suas obrigações para com esta Licença e para com as

outras obrigações pertinentes, então como conseqüência você não poderá

distribuir o Programa. Por exemplo, se uma licença de patente não

permitirá a redistribuição, livre de "royalties", do Programa, por

todos aqueles que receberem cópias direta ou indiretamente de você,

então a única forma de você satisfazer a ela e a esta Licença seria a

de desistir completamente de distribuir o Programa.

Se qualquer parte desta seção for considerada inválida ou não

aplicável em qualquer circunstância particular, o restante da seção se

aplica, e a seção como um todo se aplica em outras circunstâncias.

O propósito desta seção não é o de induzi-lo a infringir quaisquer

patentes ou reivindicação de direitos de propriedade outros, ou a

contestar a validade de quaisquer dessas reivindicações; esta seção

tem como único propósito proteger a integridade dos sistemas de

distribuição de software livres, o que é implementado pela prática de

licenças públicas. Várias pessoas têm contribuído generosamente e em

grande escala para os software distribuídos usando este sistema, na

certeza de que sua aplicação é feita de forma consistente; fica a

critério do autor/doador decidir se ele ou ela está disposto a

distribuir software utilizando outro sistema, e um licenciado não pode

impor qualquer escolha.

Esta seção destina-se a tornar bastante claro o que se acredita ser

conseqüência do restante desta Licença.

8. Se a distribuição e/ou uso do Programa são restringidos em certos

países por patentes ou direitos autorais, o detentor dos direitos

autorais original, e que colocou o Programa sob esta Licença, pode

incluir uma limitação geográfica de distribuição, excluindo aqueles

países de forma a tornar a distribuição permitida apenas naqueles ou

entre aqueles países então não excluídos. Nestes casos, esta Licença

incorpora a limitação como se a mesma constasse escrita nesta Licença.

9. A Free Software Foundation pode publicar versões revisadas e/ou

novas da Licença Pública Geral de tempos em tempos. Estas novas

versões serão similares em espírito à versão atual, mas podem diferir

em detalhes que resolvem novos problemas ou situações.

A cada versão é dada um número distinto. Se o Programa especifica um

número de versão específico desta Licença que se aplica a ele e a

"qualquer nova versão", você tem a opção de aceitar os termos e

condições daquela versão ou de qualquer outra versão publicada pela

Free Software Foundation. Se o programa não especifica um número de

versão desta Licença, você pode escolher qualquer versão já publicada

pela Free Software Foundation.

10. Se você pretende incorporar partes do Programa em outros

programas livres cujas condições de distribuição são diferentes,

escreva ao autor e solicite permissão. Para o software que a Free

Software Foundation detém direitos autorais, escreva à Free Software

Foundation; às vezes nós permitimos exceções a este caso. Nossa

decisão será guiada pelos dois objetivos de preservar a condição de

liberdade de todas as derivações do nosso software livre, e de

promover o compartilhamento e reutilização de software em aspectos

gerais.

AUSÊNCIA DE GARANTIAS

11. UMA VEZ QUE O PROGRAMA É LICENCIADO SEM ÔNUS, NÃO HÁ QUALQUER

GARANTIA PARA O PROGRAMA, NA EXTENSÃO PERMITIDA PELAS LEIS

APLICÁVEIS. EXCETO QUANDO EXPRESSADO DE FORMA ESCRITA, OS DETENTORES

DOS DIREITOS AUTORAIS E/OU TERCEIROS DISPONIBILIZAM O PROGRAMA "NO

ESTADO", SEM QUALQUER TIPO DE GARANTIAS, EXPRESSAS OU IMPLÍCITAS,

INCLUINDO, MAS NÃO LIMITADO A, AS GARANTIAS IMPLÍCITAS DE

COMERCIALIZAÇÃO E AS DE ADEQUAÇÃO A QUALQUER PROPÓSITO. O RISCO TOTAL

COM A QUALIDADE E DESEMPENHO DO PROGRAMA É SEU. SE O PROGRAMA SE

MOSTRAR DEFEITUOSO, VOCÊ ASSUME OS CUSTOS DE TODAS AS MANUTENÇÕES,

REPAROS E CORREÇÕES.

12. EM NENHUMA OCASIÃO, A MENOS QUE EXIGIDO PELAS LEIS APLICÁVEIS OU

ACORDO ESCRITO, OS DETENTORES DOS DIREITOS AUTORAIS, OU QUALQUER OUTRA

PARTE QUE POSSA MODIFICAR E/OU REDISTRIBUIR O PROGRAMA CONFORME

PERMITIDO ACIMA, SERÃO RESPONSABILIZADOS POR VOCÊ POR DANOS, INCLUINDO

QUALQUER DANO EM GERAL, ESPECIAL, ACIDENTAL OU CONSEQÜENTE,

RESULTANTES DO USO OU INCAPACIDADE DE USO DO PROGRAMA (INCLUINDO, MAS

NÃO LIMITADO A, A PERDA DE DADOS OU DADOS TORNADOS INCORRETOS, OU

PERDAS SOFRIDAS POR VOCÊ OU POR OUTRAS PARTES, OU FALHAS DO PROGRAMA

AO OPERAR COM QUALQUER OUTRO PROGRAMA), MESMO QUE TAL DETENTOR OU

PARTE TENHAM SIDO AVISADOS DA POSSIBILIDADE DE TAIS DANOS.

FIM DOS TERMOS E CONDIÇÕES

Como Aplicar Estes Termos aos Seus Novos Programas

Se você desenvolver um novo programa, e quer que ele seja utilizado

amplamente pelo público, a melhor forma de alcançar este objetivo é

torná-lo software livre que qualquer um pode redistribuir e alterar,

sob estes termos.

Para isso, anexe os seguintes avisos ao programa. É mais seguro

anexá-los logo no início de cada arquivo-fonte para reforçarem mais

efetivamente a inexistência de garantias; e cada arquivo deve possuir

pelo menos a linha de "copyright" e uma indicação de onde o texto

completo se encontra.

<uma linha que forneça o nome do programa e uma idéia do que ele faz.>

Copyright (C) <ano> <nome do autor>

Este programa é software livre; você pode redistribuí-lo e/ou

modificá-lo sob os termos da Licença Pública Geral GNU, conforme

publicada pela Free Software Foundation; tanto a versão 2 da

Licença como (a seu critério) qualquer versão mais nova.

Este programa é distribuído na expectativa de ser útil, mas SEM

QUALQUER GARANTIA; sem mesmo a garantia implícita de

COMERCIALIZAÇÃO ou de ADEQUAÇÃO A QUALQUER PROPÓSITO EM

PARTICULAR. Consulte a Licença Pública Geral GNU para obter mais

detalhes.

Você deve ter recebido uma cópia da Licença Pública Geral GNU

junto com este programa; se não, escreva para a Free Software

Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA

02111-1307, USA.

Inclua também informações sobre como contactá-lo eletronicamente e por

carta.

Se o programa é interativo, faça-o mostrar um aviso breve como este,

ao iniciar um modo interativo:

Gnomovision versão 69, Copyright (C) ano nome do autor

O Gnomovision não possui QUALQUER GARANTIA; para obter mais

detalhes digite `show w'. Ele é software livre e você está

convidado a redistribui-lo sob certas condições; digite `show c'

para obter detalhes.

Os comandos hipotéticos `show w' e `show c' devem mostrar as partes

apropriadas da Licença Pública Geral. Claro, os comandos que você usar

podem ser ativados de outra forma que `show w' e `show c'; eles podem

até ser cliques do mouse ou itens de um menu -- o que melhor se

adequar ao programa.

Você também deve obter do seu empregador (se você trabalha como

programador) ou escola, se houver, uma "declaração de ausência de

direitos autorais" sobre o programa, se necessário. Aqui está um

exemplo; altere os nomes:

Yoyodyne, Inc., aqui declara a ausência de quaisquer direitos

autorais sobre o programa `Gnomovision' (que executa interpretações

em compiladores) escrito por James Hacker.

<assinatura de Ty Coon>, 1o. de abril de 1989

Ty Con, Vice-presidente

Esta Licença Pública Geral não permite incorporar seu programa em

programas proprietários. Se seu programa é uma biblioteca de

sub-rotinas, você deve considerar mais útil permitir ligar aplicações

proprietárias com a biblioteca. Se isto é o que você deseja, use a

Licença Pública Geral de Bibliotecas GNU, ao invés desta Licença.

Created with the Personal Edition of HelpNDoc: Full-featured Help generator


Instalação

O ACBrMonitor possui Instalador automatizado para Windows e Linux...

Portanto, apenas inicie o instalador e leia as instruções na tela

Clique no botão Avançar

Selecione a opção "Eu aceito os termos do Contrato" em seguida clique no botão Avançar

Defina o caminho onde o será feito a instalação, ou deixe o caminho padrão (recomendado) e clique no botão Avançar

Selecione as opções a serem instaladas, ou deixe o padrão (recomendado) e clique no botão Avançar

Nome do grupo a ser criado no menu do Windows para ser feita a instalação, clique no botão Avançar

Opção para criar (selecionada) ou não (deselecionada) um atalho na área de trabalho do Windows, em seguida clique no botão Avançar

Clique no botão Instalar para iniciar a instalação

Instalação concluída, faça um bom uso do ACBrNFeMonitor, finalize clicando no botão Concluir

Notas do Instalador Linux

  • Para instalar / desinstalar o ACBrMonitor é necessário ter privilégios de Super Usuário (root)
  • Caso você não consiga executar o instalador, verifique se o Binário do Instalador está com os Flags de Execução e Leitura (rx)
  • O arquivo de auto-inicialização, será criado no diretório: /usr/share/autostart
  • Para garantir a comunicação com as portas seriais o instalador irá abrir o diretório /var/lock para todos os usuários (777)
  • Se desejar, configure manualmente as permissões para cada usuário que necessita usar o ACBrMonitor ou acessar as portas seriais:
    Exemplo: Para liberar a serial 1 para todos os usuários digite:
    chmod 777 /dev/ttyS0
    chmod 777 /var/lock

Created with the Personal Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


Compatibilidade

Acreditamos que o ACBrMonitor seja compatível com todas as versões de Windows e com a maioria das distribuições Linux.

O ACBrMonitor foi compilado usando:

  • Lazarus 0.9.29 e FPC 2.4.3 em Windows Seven
  • Lazarus 0.9.29 e FPC 2.4.3 em Linux Mandriva 2010 Spring

Created with the Personal Edition of HelpNDoc: Easily create iPhone documentation


Sintaxe dos Comandos ACBr

OBJETO.Comando [( param1 [,param2, param3, paramN...])]

Todos os comandos enviados para o ACBrMonitor podem ser maiúsculas ou minúsculas.

  • OBJETO são os objetos do ACBr, podendo ser: ACBr , ECF, CHQ , GAV , DIS , BAL , LCB , ETQ , CEP , IBGE , BOLETO , POSPRITER

  • Comando: Comandos reconhecido pelo Objeto

  • param1, param2, paramN: Parâmetros necessários para a execução de Comando. Os parâmetros podem ser do tipo:

      • Texto ou “String”: Para especificar "Strings" nos parâmetros use sempre aspas duplas (").

Notas: Para quebra de linha em "Strings" grandes, como a Observação no rodapé dos cupons, use o sinal Pipe (|)

Para especificar uma Aspas dentro da String, use 2 aspas.

Exemplos válidos:

"Projeto ACBr"

"DESCRICAO DO PRODUTO"

"LINHA1|LINHA2||LINHA4" (exemplo com quebra de linhas, (4 linhas))

"Cano de 8"" polegadas" (exemplo com aspas internas)

      • Numéricos: Para especificar "Numéricos" nos parâmetros, não use aspas.

Para separar as casas decimais use o ponto(.)

Não use separador de Milhar ou símbolo de moeda (R$).

Exemplos válidos:

10

10.23

0.123

1234.50

      • DataHora: Use o formato atual do Sistema Operacional ( Geralmente DD/MM/AA HH:MM:SS)

Alguns comandos do ACBrMonitor precisam apenas da Data, portanto a Hora pode ser omitida

Exemplos Válidos:

"14/08/06 18:05:20"

"14/08/2006 18:05"

"14/08/06"

      • Booleano: Utilize True para verdadeiro e False para falso

Exemplo:

IBGE.BuscarPorCodigo("3554003")

IBGE = Objeto

BuscarPorCodigo = Comando suportado pelo Objeto IBGE

"3554003" = Parâmetro, do Tipo String

Created with the Personal Edition of HelpNDoc: Produce electronic books easily


Histórico de Alterações

{******************************************************************************}

{ Projeto: ACBrMonitor }

{ Executavel que faz uso do conjunto de componentes ACBr para emissão de NFe }

{ }

{ Direitos Autorais Reservados (c) 2006 Daniel Simoes de Almeida }

{ }

{ Você pode obter a última versão desse arquivo na página do Projeto ACBr }

{ Componentes localizado em http://www.sourceforge.net/projects/acbr }

{ }

{ Este programa é software livre; você pode redistribuí-lo e/ou modificá-lo }

{ sob os termos da Licença Pública Geral GNU, conforme publicada pela Free }

{ Software Foundation; tanto a versão 2 da Licença como (a seu critério) }

{ qualquer versão mais nova. }

{ }

{ Este programa é distribuído na expectativa de ser útil, mas SEM NENHUMA }

{ GARANTIA; nem mesmo a garantia implícita de COMERCIALIZAÇÃO OU DE ADEQUAÇÃO A}

{ QUALQUER PROPÓSITO EM PARTICULAR. Consulte a Licença Pública Geral GNU para }

{ obter mais detalhes. (Arquivo LICENCA.TXT ou LICENSE.TXT) }

{ }

{ Você deve ter recebido uma cópia da Licença Pública Geral GNU junto com este}

{ programa; se não, escreva para a Free Software Foundation, Inc., 59 Temple }

{ Place, Suite 330, Boston, MA 02111-1307, USA. Você também pode obter uma }

{ copia da licença em: http://www.opensource.org/licenses/gpl-license.php }

{ }

{ Daniel Simões de Almeida - daniel@djsystem.com.br - www.djsystem.com.br }

{ Praça Anita Costa, 34 - Tatuí - SP - 18270-410 }

{ }

{******************************************************************************}

{******************************************************************************

|* ACBrMonitor

|*

|* PROPÓSITO: Registro de Alterações

******************************************************************************}

Para ver os comandos dispoíveis do ACBrMonitor acesse:

http://acbr.sourceforge.net/drupal/?q=node/40

Símbolo : Significado

[+] : Novo recurso

[*] : Recurso modificado/melhorado

[-] : Correção de Bug (assim esperamos)

25/02/2016

[+] Criado uma nova aba em DFe->Impressão de nome NFe, nela irá ter somente

configurações de NFe.

[*] Removido várias opções de configurações da aba DFe-Impressao->Geral e

realocada na nova aba DFe->Impressao->NFe.

[+] Adicionado componente para definir a quantidade de itens por páginas

coforme relato de erro no link :

http://www.projetoacbr.com.br/forum/topic/28308-propriedade-produtosporpagina-no-monitorplus/?do=findComment&comment=186590

(Isaque Pinheiro)

24/02/2016

[+] NFe.LerNFe não contemplava ler o CEST do xml

por: Juliomar Marchetti

21/02/2016

[+] Adicionado a opção para assinar os arquivos do Bloco X do Paf-ECF!

por: Juliomar Marchetti

18/02/2016

[+] Adicionada configuração para permitir configurar o TimeZone, para geração

dos XMLs: tzSistema (default), tzPCN, tzManual (por: DSA)

17/02/2016

[*] Ajuste em "SAT.EnviarCFe", para permitir o envio do XML que esteja na memória

carregado com "SAT.CarregarDadosVenda" (por: DSA)

[-] Ajustes na leitura dos campos Emit.cRegTrib, Emit.cRegTribISSQN e

Emit.indRatISSQN (por: Anfm)

12/02/2016

[+] Adicionada configuração para permitir a criação de XMLs com acentos

[-] Correção nas rotinas de geração de XML por INI, para usar "String"

(por: DSA)

11/02/2016

[*] Ajuste para que o método "SAT.EnviarCFe", não tente interpretar o XML

recebido (por: DSA)

28/018/2016

[*] Ajuste para que todos os Edits números da aba DFe/Impressão usem

TSpinEdit ou TFloatSpinEdit (por: DSA)

26/01/2016

[+] Adição da opção para selecionar o tamanho de papel no DACT

por: Juliomar Marchetti

25/01/2015

[-] Correção para evitar erro na obtenção do nome do destinatário no comando

BOLETO.EnviarEmail

[-] Ajustes para a correta exibição do Preview do DANFE, nos diversos comandos

que suportam a impressão do mesmo

[*] Remoção de Hints e Warnings de compilação

[*] Ajuste para tratar o campo "cMunFG" como Inteiro e não String (evitando

erros de conversão)

(por: DSA)

20/01/2015

[+] Impressão DANFE: Adicionado ajuste para Fonte do Endereço Emitente

http://www.projetoacbr.com.br/forum/index.php?showtopic=27521

18/01/2015

[-] Correções para o envio de Boletos por Email, fazendo uso de rotina interna

do componente ACBrBoleto (por: DSA)

17/01/2015

[-] Correção da gravação do parâmetro ACBrPosPrinter.EspacoEntreLinhas (por: DSA)

14/04/2015

[+] Impressão DANFE: Adicionado ajuste para Fonte da Razão Social e Altura Linha

Comum.

http://www.projetoacbr.com.br/forum/index.php?showtopic=27390

30/12/2015

[-] Correção para ler campos da sessão ISSQN000, mesmo quando vBC não for

informado (por: DSA)

24/12/2015

[*] Ajuste para não minimizar a aplicação, quando clicar no "Salvar" (por: DSA)

22/12/2015

[*] Modificado para usar o Boleto em Fortes Report

[*] Remoção de Hints e Warnings

(por: DSA)

18/12/2015

[*] Adicionada regra de exclusão para o Campo "Imprimir Valor Líquido do Produto"

quando "Imprimir Desconto em Porcentagem" está marcado

[*] Ajuste para melhor posicionamento do Formulário na tela, durante a primeira

exibição

[*] Ajuste para que todos os Pagecontrols fique na primeira página após a

inicialização

(por: DSA)

15/12/2015

[+] Adicionadas as tags do fundo de amparo a pobreza, pFCPUFDest e vFCPUFDest

por: regys.silveira

10/12/2015

[-] Acerto para salvar corretamente o CSC e IdCSC quando é enviado o comando SetXXX.

por: regys.silveira

9/12/2015

[-] acerto na geração de PDF por email quando o monitor está configurado como impressão EscPOS

por: regys.silveira

http://www.projetoacbr.com.br/forum/topic/26253-comando-que-envia-email-do-cupom-sat-cfe-pelo-acbrmonitor-plus/#comment-171069

04/12/2015

[-] Correção em ObterCodigoMunicipio, para não localizar Municípios com o nome

parcialmente igual

http://www.projetoacbr.com.br/forum/index.php?showtopic=26423

[*] Remoção de métodos repetidos

26/11/2015

[*] Adicionada substituição de variaveis no envio de email de eventos, assim

como é feito no envio da NF-e.

[+] Adicionado configuração para ACBrPosPrinter1.ConfigLogo.IgnorarLogo na aba

"PosPrinter" (por: DSA)

13/11/2015

[-] inclusão do CT-e na lista de objetos que recebem .ini

Antes ele lia somente a primeira linha do .ini do CT-e, causando erros

http://www.projetoacbr.com.br/forum/topic/25560-cte-erro-o-xml-informado-possui-cnpj-diferente-do-certificado-digital/#comment-168336

11/11/2015

[-] Tentativa de correção:

http://www.projetoacbr.com.br/forum/topic/25881-acbrmonitorplus-01111-em-escpos/

por: regys.silveira

23/10/2015

[+] Incluido comando para setar a propriedade incluirqrcodexmlnfce, facilitando

para quem usa o monitor automatizar essa configuração nos clientes.

por: regys.silveira.

22/10/2015

[+] Ao selecionar "Adicionar Tag de QRCode em Informações Suplementares" será validado

se os campos CSC e IDCSC estão preenchidos.

[+] Adicionado opção para configurar o timeout dos Webservices -

DFe - Geral - Timeout em segundos

[*] Alterado para salvar arquivos de NFe em Configuracoes.Arquivos.PathNFe ao invés de

usar o diretório Configuracoes.Arquivos.PathSalvar

[-] Corrigido para fazer a consulta de processamento do Lote apenas quando usar

o método assíncrono

[-] Corrigido para não gerar o arquivo nfe.ini quando usado o MenIniFile.

por: André Moraes

09/05/2015

-- ACBrMonitorPLUS --

[+] Adicionada Opção para configurar a geração da Tag de QRCode em NFCe

DFe -> WebServices -> NFCe -> "Adicionar Tag de QRCode em Informações Suplementares"

(por: DSA)

[-] acerto para remoção de propriedade que foi renomeada (ImprimirDetalhamentoEspecifico).

por: regys.silveira

07/05/2015

-- ACBrMonitorPLUS --

[+] Adicionada a opção para converter Entrada e Saida de TCP de e para ANSI (por: DSA)

06/05/2015

-- ACBrMonitorPLUS --

[+] Adicionada configuração de margens para o DANFCe, ficando assim separada

da configuração do DANFE normal.

[+] Adicionada configuração de timeout do webservice, existem alguns relatos

de timeout no plus, configurei para tentar diminuir isso.

por: regys.silveira

30/09/2015

-- ACBrMonitorPLUS --

[*] Melhorias no uso do parâmetro do Número de cópias de Imprimir -> Geral

[*] Assumindo valor default para "Ide.dEmi" com a Data e Hora atual

24/09/2015

-- ACBrMonitorPLUS --

[*] Unificado três campos com o nome da Software House para ficar somente um nome para tudo

sugestão do link

http://www.projetoacbr.com.br/forum/topic/24623-cadastro-software-house/?do=findComment&comment=159165

22/09/2015

-- ACBrMonitorPLUS --

[*] Unificada a maneira de configurar a Impressão de Descontos/Acréscimos para

DANFCe, em Fortes e EscPos

19/09/2015

-- CTE --

[+] Adicionado o suporte a CT-e. (Por: Rafael Dias)

-- MDFE --

[+] Adicionado o suporte a MDF-e. (Por: Rafael Dias)

17/09/2015

-- NFE --

[+] Implementado: NFe.ValidarNfeRegraNegocios(cArqXML), que efetua a validação

de todas as regras de negócio nas informações do XML, e retorna com

possíveis erros. (Por: Alberto Leal)

[*] Ajuste para melhor mensagem em NFe.EnviarEmail, quando não for encontrada

nenhuma Nota no XML informado

11/09/2015

[+] Implementação do comando: NFe.DistribuicaoDFe(cUF,cCNPJ,nUltNSU)

http://www.projetoacbr.com.br/forum/topic/24242-consultanfedest-x-distribuicaodfe/#comment-156693

10/09/2015

-- ACBrMonitorPLUS -- (por: DSA)

[-] Correção na gravação do valor configurado em: ACBrPosPrinter1.ConfigBarras.Altura

21/08/2015

-- NFE --

[-] Ajustes para que a Impressão de NFCe, respeite a impressora definida na aba

DANFE/NFCe

20/08/2015

-- SAT -- (por: DSA)

[-] Método "criarcfe" ou "criarenviarcfe". Correção na pasta para Salvar os XMLs

de envio.

[-] Correção para que a montagem do CFe respeite os valores Default informados

na configuração da aba SAT (ACBrSAT1.InicializaCFe)

18/08/2015

-- NFE --

[-] Correção para método "nfetotxt" (por: DSA)

-- SAT -- (por: jrs.santos)

[*] Ajuste para Retornar dados de Cupom ou Cupom Cancelado em

ConsultarNumeroSessao, e atribui-lo a ACBrSAT.CFe, ACBrSAT.CFeCanc

http://www.projetoacbr.com.br/forum/index.php?showtopic=23737

11/08/2015 (por: regys silveira)

[+] Adicionado a substituição de variáveis no assunto e corpo do email antes de enviar.

10/08/2015 (por: DSA)

[*] Adicionada configuração para ACBrBAL.Device.ParamsString

[-] Correção no nome para gravação do Arquivo em SAT.CriarCFe

09/08/2015 (por: DSA)

[-] Corrigida a rotina "DoSATUnit.GerarIniCFe" para respeitar os parâmetros

de Configuração definidos na Interface do ACBrMonitor

[*] Modificada a maneira de Salvar o arquivo em "SAT.criarcfe", para respeitar os

parâmetros de ACBrSAT e usar a nomenclatura definida na Especificação

Técnica

[*] Modificado método SAT.criarenviarcfe para NÃO gerar as Tags de

responsabilidade do SAT

28/09/2014

[+] Adicionada configuração para Impressora padrão na Aba Boleto

[+] Adicionado suporte ao componente ACBrSedex

Versão 0.10.9.1 16/09/14

[-] Correção para tratamento de arquivos de Entrada (ENT.TXT) com linhas em

branco no final do arquivo, ocasionando a não geração do arquivo SAI.TXT (por: DSA)

Versão 0.10.7.0 14/08/14

[*] Modificado mecanismo de criação do arquivo TXT para processar de forma

mais otimizada arquivos com lote de comandos (por: DSA)

Versão 0.9.26.1 01/08/13 (Por: DSA)

[+] Adicionado suporte para conversão do Arquivo de Entrada e Saida para ANSI

Versão 0.9.5 22/10/11 (Por: DSA)

[-] Corrigido Bug que desativava a comunicação TCP/IP ao clicar no botão Salvar ou Cancelar

[+] Adicionado método: pafmf_lmfc_impressao( DtInicial, DtFinal )

[+] Adicionado método: pafmf_lmfc_impressao( CRZInicial, CRZFinal )

[+] Adicionado método: pafmf_lmfs_impressao( DtInicial, DtFinal )

[+] Adicionado método: pafmf_lmfs_impressao( CRZInicial, CRZFinal )

[+] Adicionado método: pafmf_lmfc_espelho( DtInicial, DtFinal, NomeArquivo )

[+] Adicionado método: pafmf_lmfc_espelho( CRZInicial, CRZFinal, NomeArquivo )

[+] Adicionado método: pafmf_lmfs_espelho( DtInicial, DtFinal, NomeArquivo )

[+] Adicionado método: pafmf_lmfs_espelho( CRZInicial, CRZFinal, NomeArquivo )

[+] Adicionado método: pafmf_lmfc_cotepe1704( DtInicial, DtFinal, NomeArquivo )

[+] Adicionado método: pafmf_lmfc_cotepe1704( CRZInicial, CRZFinal, NomeArquivo )

[+] Adicionado método: pafmf_mfd_cotepe1704( DtInicial, DtFinal, NomeArquivo )

[+] Adicionado método: pafmf_mfd_cotepe1704( COOInicial, COOFinal, NomeArquivo )

[+] Adicionado método: pafmf_mfd_espelho( DtInicial, DtFinal, NomeArquivo )

[+] Adicionado método: pafmf_mfd_espelho( COOInicial, COOFinal, NomeArquivo )

Versão 0.9.00b 05/09/10 (Por: DSA)

[*] ACBrMonitor e ACBrMonitorConsole, e ECFTeste totalmente convertidos de Delphi para Lazarus/FPC

[*] Modificação do Terminador do envio de conexões TCP/IP, de: CR+LF para: CR+LF+'.'+CR+LF

[*] Novo instalador em Linux, usando o InstallJammer

[*] Substituição dos componentes de comunicação TCP/IP (Indy/Delphi) por (ACBrTCPServer/Synapse)

[+] Adicionado o Objeto BOLETO (Por: Juliana Tamizou)

[+] Adicionado o Objeto CEP

[+] Adicionado o Objeto IBGE

[*] Revisão da documentação

[*] Novos Icones e Glyphs

[+] Suporte a UTF-8 (nativo do Lazarus)

Versão 0.8.15b 27/10/09 (Por: DSA)

[*] Fontes revistos para corrigir declaração de "String" para "AnsiString"

quando necessário

[*] Rotina de Leitura do TXT de entrada aprimorada para Ler todo o conteudo

do TXT, mesmo que o arquivo contenha caracteres de controle.

Versão 0.8.14b 27/10/09 (Por: DSA)

[+] ECF.TotalCancelamentosISSQN

[+] ECF.TotalDescontosISSQN

[+] ECF.TotalAcrescimosISSQN

[+] ECF.TotalSubstituicaoTributariaISSQN

[+] ECF.TotalNaoTributadoISSQN

[+] ECF.TotalIsencaoISSQN

Versão 0.8.13b 27/10/09 (Por: Ivan Moreira)

[+] ECF.UsuarioAtual -> Retorna o Número do usuário (proprietário) atual

[+] ECF.DataHoraSB -> Retorna a DataHora de Gravação do SW básico

[+] ECF.SubModeloECF -> Retorna a Descrição do Modelo do ECF

[+] ECF.EspelhoMFD_DLL( dDataInicial, dDataFinal, cNomeArquivo ) ou

ECF.EspelhoMFD_DLL( cCOOInicial, cCOOFinal, cNomeArquivo )

Cria Arquivo informado em "cNomeArquivo" contendo o Espelho da MFD em

um periodo de COO ou Data

[+] ECF.ArquivoMFD_DLL( dDataInicial, dDataFinal, cNomeArquivo ) ou

ECF.ArquivoMFD_DLL( cCOOInicial, cCOOFinal, cNomeArquivo )

Cria Arquivo informado em "cNomeArquivo" de acordo com o Ato Cotepe 1704 em

um periodo de COO ou Data

Versão 0.8.12b 14/10/09 (Daniel Simões)

[+] LeituraMFDSerial. Adicionado novo parâmetro (opcional) "NomeArquivo : String"

- LeituraMFDSerial( DataInicial, DataFinal : TDateTime[, NomeArquivo : String] )

- LeituraMFDSerial( COOInicial, COOFinal : Integer[, NomeArquivo : String] )

Se NomeArquivo for especificado, o mesmo será criado com a resposta do ECF.

[+] LeituraMemoriaFiscalSerial. Adicionado novos parâmetros: (opcionais)

Simplificada : Boolean = False; NomeArquivo : String

- LeituraMemoriaFiscalSerial( DataInicial, DataFinal : TDateTime,

[Simplificada : Boolean, NomeArquivo : String] )

- LeituraMemoriaFiscalSerial( COOInicial, COOFinal : Integer,

[Simplificada : Boolean, NomeArquivo : String] )

Se NomeArquivo for especificado, o mesmo será criado com a resposta do ECF.

Versão 0.8.7b 01/12/08

[+] Adicionada aba para Servidor de Terminais de Consulta de Preços (Gertec)

Versão 0.8.6b 21/10/08

[+] Implementado os métodos:

ACBr.SaveToFile( cNomeArquivo, cTextoArquivo ) -> Salva o o conteudo de

"cTextoArquivo" no arquivo chamado "cNomeArquivo". Para enviar

caracteres "não imprimiveis" use a noteção em Hexa do Caractere: "\xHH".

Exemplos: CR = #13 -> '\x0D'; LF = #10 -> '\x0A'

ACBr.LoadFromFile( cNomeArquivo, nTempoEspera ) -> Lê e Retorna o

conteudo do arquivo "cNomeArquivo". Aguarda por "nTempoEspera" segundos

pela chagada (ou desbloqueio) do arquivo (default 0).

ACBr.FilesExists( cMascaraArquivo ) -> Retorna "True" se existem arquivos

de acordo com "cMascaraArquivo"

ACBr.DeleteFiles( cMascaraArquivo ) -> Apaga todos os arquivos que

correspondam a mascara "cMascaraArquivo"

ACBr.AppExists( cNomeJanela ) -> Retorna "True" se existir alguma

aplicação com o titulo idêntico a "cNomeJanela"

Versão 0.8.5b 20/06/08

[*] Função interna IntToStrZero modificada para aceitar Int64. Esse problema

poderia causar "erro de conversão" na criação do arquivo ACBrRFD

[*] vários métodos implementados para o modelo ecfQuattro e ecfYanco

Versão 0.8.4b 22/04/08

[+] Adicionado método ECF.IdentificaOperador(Nome: String);

[+] Adicionado método: ECF.CortaPapel( CorteParcial : Boolean = false) ;

[+] Adicionado método: ECF.Sangria( const Valor: Double; Obs: String;

DescricaoCNF: String = 'SANGRIA'; DescricaoFPG: String = 'DINHEIRO')

[+] Adicionado método: ECF.Suprimento( const Valor: Double; Obs: String;

DescricaoCNF: String = 'SUPRIMENTO'; DescricaoFPG: String = 'DINHEIRO')

[+] Adicionada propriedade: ECF.TimeOut -> Retorna o TimeOut atual

[+] Adicionado o método: ECF.SetTimeOut( nTimeOut ) -> Ajusta o TimeOut

[*] Metodo VendeItem modificado, adicionado parametro:

cDescontoAcrescimo, permite definir se o Valor informado no parametro

"nValorDescontoAcrescimo" é Desconto "D" ou Acréscimo "A".

Se nao informado, assume o Default = "D"

[*] Diversas corrreções e melhoraria de performance nas Classes Daruma

e Bematech

Versão 0.8.3b 05/03/08

[+] Adicionado novos métodos em Objeto ACBr

ACBr.AppActivate( cTituloJanela, nWaitTime = 0)

- Posiciona o foco na Janela com o titulo Informado em cTituloJanela

após esperar por nWaitTime milisegundos

ACBr.BlockInput( bBlock )

- Se bBlock = "True", Bloqueia Mouse e Teclado; Se "False" desbloqueia

[+] Adicionado suporte a geração de arqquivos RFD (CAT 52/07)

[+] Adicionada aba para controle de Balanças (Gabriel Frones)

Versão 0.7b 02/12/06

[*] Vários bugs corrigidos e melhorias incorporadas na versão 0.8.6b do ACBr

[+] Novas propriedades:

- DadosReducaoZ : String

- DataMovimento : TDateTime

- CNPJ : String

- NumCRZ : String

- NumCOOInicial : String

- VendaBruta : Double

- GrandeTotal : Double

- TotalCancelamentos : Double

- TotalDescontos : Double

- TotalAcrescimos : Double

- TotalSubstituicaoTributaria : Double

- TotalNaoTributado : Double

- TotalIsencao : Double

- NumUltItem : Integer

[+] Novos métodos:

- LerTotaisAliquota

- LerTotaisFormaPagamento

- LerTotaisComprovanteNaoFiscal

- LeituraMFDSerial( DataInicial, DataFinal : TDateTime )

- LeituraMFDSerial( COOInicial, COOFinal : Integer )

- NaoFiscalCompleto( CodCNF : String; Valor : Double; CodFPG : String;

Obs : String )

- AbreNaoFiscal( CPF_CNPJ : String = '')

- RegistraItemNaoFiscal( CodCNF : String; Valor : Double; Obs : String )

- SubtotalizaNaoFiscal( DescontoAcrescimo : Double = 0)

- EfetuaPagamentoNaoFiscal( CodFormaPagto : String; Valor : Double;

Observacao : String = '';

ImprimeVinculado : Boolean = false)

- FechaNaoFiscal( Observacao : String = '')

- CancelaNaoFiscal

PS.: As novas propriedades e métodos ainda não estão disponíveis em todos

os ECFs suportados pelo ACBrECF... Por favor consulte o link abaixo:

http://www.forumweb.com.br/foruns/index.php?showtopic=60802

Versão 0.6b 02/12/06

[+] Definida a Licença do ACBrMonitor: GPL / GNU Leia o arquivo: LICENCA.TXT

[+] Novo Instalador Windows, que permite Instalação: Completa / Mínima /

Customizada ( A instalação Mínima é util para usuários finais )

[-] Finalmente corrigido problema de congelamento do ACBrMonitor, em Win9X e

Linux, quando a janela estava aberta e o ACBrMonitor recebendo comandos

em TCP/IP... (Interface do programa não era atualizada)

[-] Corrigido bug na gravação do LOG. Em algumas situações, I/O error 103

[+] Novo executavel "ACBrMonitorConsole" disponivel no pacote de instalação

- Util para programas que trabalham apenas em modo Texto

(no Linux, não precisa do Servido X)

- Utiliza o mesmo arquivo de configuração "ACBrMonitor.ini"

[*] Novos Glyphs na Interface do programa :)

[*] Inicialização acelerada... minimiza para o SysTray mais rapidamente

[*] Inicialização mais segura. Mesmo que ocorra alguma exceção durante a

inicialização, como por exemplo a falha ao ativar algum equipamento. O

ACBrMonitor inicializará e ficará ativo. Caso alguma exceção ocorra

durante a inicialização, o ACBrMonitor NÃO será minimizado para o SysTray

[*] Todas as Exceções do programa ACBrMonitor agora são capturadas e

registradas no Memo de Saída, evitando a paralisação do programa com

janelas ShowModal de exibição de erro. Se a gravação do LOG estiver

ligada, os erros também serão gravados no LOG

[+] Adicionada a funcionalidade da aba "Impressoras de Cheque". Agora é

possivel interagir com várias impressoras de Cheque como: Bematech,

Chronos, Schalter, Sotomaq, Perto, Urano, ECFs 2 estações, e até mesmo

Impressoras matriciais comuns (Ex: LX-300).

- Veja o manual do ACBrMonitor para os Novos comandos do Objeto CHQ.

[+] Adicionada a funcionalidade da aba "Display". Agora é possível

interagir com diversos tipos de Display de Teclados (Gertec, KeyTec,

Smak) ou Seriais (Gertec)

- Veja o manual do ACBrMonitor para os Novos comandos do Objeto DIS.

[+] Adicionada a funcionalidade da aba "Gavetas de Dinheiro". Agora é

possível interagir com vários tipos de gaveta de dinheiro. Ligadas ao

ECF, ligada a Impressoras de bobinas ou diretamente a Porta serial

- Veja o manual do ACBrMonitor para os Novos comandos do Objeto GAV.

[*] Aba do Leitor de Cod.Barras otimizada para trabalhar em conjunto com o

ECF. Códigos apenas são enviados para o buffer de teclado, quando o ECF

estiver livre. Porém, os dados permanecem no buffer da serial e são

todos enviados assim que possível.

- Isso evita o problema de enviar teclas dos códigos em momento indevido,

como por exemplo, quando o EDIT / GET do Campo código não está em FOCO

[*] Adicionado novo objeto: LCB, que permite interagir diretamento com o

Leitor de Cod.Barras Serial. Vários métodos novos criados para esse

Objeto, verifique o manual do ACBrMonitor

Versão 0.5a 10/07/06

[*] Rotina de Gravação de Arquivo de Saída TXT mais segura... Agora ela

primeiro grava a resposta em um arquivo temporário para depois renomea-lo

para o arquivo de Saída...

- Isso evita problemas com aplicações que controlam o ACBrMonitor, que

poderiam ler o arquivo de Saída incompleto

[*] Interface melhorada com a substituição de alguns Edits por SpinEdits

[+] Adicionada StatusBar que exibe o comando que está sendo processado.

[+] Adicionada opção de configuração para numero máximo de linhas no LOG.

- Se o valor for diferente de 0, o Arquivo de LOG será ajustado sempre

que o ACBrMonitor iniciar

[+] Adicionada opção para Inverter o Sinal da Gaveta de Dinheiro

- Em alguns modelos de Gaveta, com pinagem diferente, pode ocorrer a

leitura inversa do Estado da Gaveta

[-] Usando a versão 0.8.5b do ACBr, corrigido diversos bugs no ACBrECF

( veja ACBr-change-log.txt )

[+] Novo modelo de ECF implementado FiscNET (ZPM).

( experimental, testado apenas no Emulador... veja ACBr-change-log.txt )

[-] Corrigido bug no Interpretador de comandos do ACBrMonitor.

( Problemas para detectar a separação de parâmetros (virgulas) sem

nenhum espaços entre os parâmetros )

Versão 0.4a 20/05/06

[*] Melhorada a interface geral do programa

[*] Vários componentes da interface agora possuem "Hints" com dicas de ajuda

[+] Adicionado Form "Sobre o ACBrMonitor", com botão para exibir o manual de

ajuda

[-] Corrigido alguns bugs na comunicação TCP/IP: congelamento do programa,

não re-conectava pela 2a vez

[+] Adicionada opção para definir quantas conexões simultâneas são permitidas

em modo TCP/IP. Default = 1

[+] Adicionada opção para definir o tempo (em milisegundos) para

monitoramento do arquivo de Entrada em modo TXT... O Default é 100,

diminua esse tempo para obter respostas mais rápidas do ACBrMonitor

quando usando o modo TXT

[-] Corrigido Bug no método "ECF.TotalPago" (não era executado)

[-] Alguns métodos como "CupomVinculado" ou "AbreCupomVinculado" não

efetuavam a conversão de valores com Decimais corretamente

[*] Adicionado suporte ao caracter (") Aspas dupla dentro da String. Para

informar uma Aspas dentro da String use 2 aspas (""), ela será convertida

para apenas uma Aspas.. Exemplo: "Texto ""com aspas"" dentro" será

considerado "Texto "com aspas" dentro"

[+] Adicionado o objeto "ACBR", para métodos genéricos

[+] Adicionado o método:

ACBr.Run( cComando [, cParams, bAguarda, nWindowState, bAltTab ] )

que permite executar comandos remotamente, na máquina do ACBrMonitor

[+] Adicionada opção na configuração que permite habilitar a execução de

comandos remotos (o padrão é desabilitado)

[+] Adicionado novos métodos no objeto ECF

- ECF.AchaICMSAliquota( nALiquota [, cTipo ] ) -> Procura por uma

alíquota previamente cadastrada. Se encontrar, retorna os dados da

Alíquota no mesmo formato de "CarregaAliquotas"

- ECF.AchaFPGDescricao( cDescricao ) -> Procura por uma Forma de

Pagamento pela Descrição, se encontrar, retorna os dados da Forma de

Pagamento no mesmo formato de "CarregaFormasPagamento"

- ECF.AchaCNFDescricao( cDescricao ) -> Procura por um Comprovante NAO

Fiscal pela Descrição, se encontrar, retorna os dados do Comprovante

NAO Fiscal no mesmo formato de "CarregaComprovantesNaoFiscais"

[+] Adicionada a funcionabilidade da aba "Leitor Serial". Ela permite desviar

toda a leitura de dados de um Leitor Serial para o buffer de teclado do

Windows. Permitindo modificar os sufixos / prefixos enviados pelo leitor

- Funciona mesmo quando em Prompt do MS-DOS tela cheia

[*] Métodos "LinhaCupomVinculado" e "LinhaRelatorioGerencial" agora permitem

informar várias linhas simultaneamente, sepradas por | (pipe).

Versão 0.3a 09/03/06

[+] Primeira versão distribuida do ACBrMonitor com instaladores para Windows

e Linux

Created with the Personal Edition of HelpNDoc: Full-featured EBook editor


Telas do MonitorPLUS

Tela de boas vindas, com aviso importante paraparametrização do ACBrMonitorPLUS antes de usa-lo.

Created with the Personal Edition of HelpNDoc: Easily create EBooks


Monitor

Telas do MonitorPLUS ››

Parametrizações

TCP/IP

Parâmetro para Comunicação via TCP/IP

Arquivo TXT

Entrada - Nome do arquivo que será criado na pasta para o MonitorPLUS ler e carregar os dados.

Saída - Nome do arquivo que será criado pelo MonitorPLUS, onde terá os dados de retorno para sua aplicação.

Created with the Personal Edition of HelpNDoc: Easy EPub and documentation editor


Cadastros

Telas do MonitorPLUS ››

Created with the Personal Edition of HelpNDoc: iPhone web sites made easy


Sw.House

Telas do MonitorPLUS ›› Cadastros ››

Created with the Personal Edition of HelpNDoc: Write EPub books for the iPad


Usuário

Telas do MonitorPLUS ›› Cadastros ››

Created with the Personal Edition of HelpNDoc: Full-featured multi-format Help generator


ECF

Telas do MonitorPLUS ››

Created with the Personal Edition of HelpNDoc: Free PDF documentation generator


Impressão de Cheque

Telas do MonitorPLUS ››

Created with the Personal Edition of HelpNDoc: Easily create iPhone documentation


Gaveta

Telas do MonitorPLUS ››

Created with the Personal Edition of HelpNDoc: Easily create EPub books


Display

Telas do MonitorPLUS ››

Created with the Personal Edition of HelpNDoc: Easily create EBooks


Leitor Serial

Telas do MonitorPLUS ››

Created with the Personal Edition of HelpNDoc: Full-featured multi-format Help generator


RFD

Telas do MonitorPLUS ››

Created with the Personal Edition of HelpNDoc: Free help authoring tool


Geral

Telas do MonitorPLUS ›› RFD ››

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Arquivos

Telas do MonitorPLUS ›› RFD ››

Created with the Personal Edition of HelpNDoc: Easily create CHM Help documents


Balança

Telas do MonitorPLUS ››

Created with the Personal Edition of HelpNDoc: Easily create Help documents


Etiqueta

Telas do MonitorPLUS ››

Created with the Personal Edition of HelpNDoc: Easily create HTML Help documents


Terminal de Consulta

Telas do MonitorPLUS ››

Created with the Personal Edition of HelpNDoc: Easily create Help documents


Boleto

Telas do MonitorPLUS ››

Created with the Personal Edition of HelpNDoc: Produce electronic books easily


Cedente

Telas do MonitorPLUS ›› Boleto ››

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Conta Bancária

Telas do MonitorPLUS ›› Boleto ››

Created with the Personal Edition of HelpNDoc: Easily create EBooks


Layout

Telas do MonitorPLUS ›› Boleto ››

Created with the Personal Edition of HelpNDoc: Easily create iPhone documentation


Remessa\Retorno

Telas do MonitorPLUS ›› Boleto ››

Created with the Personal Edition of HelpNDoc: Free Kindle producer


E-mail Boleto

Telas do MonitorPLUS ›› Boleto ››

Created with the Personal Edition of HelpNDoc: Free help authoring environment


Consultas CEP/IBGE

Telas do MonitorPLUS ››

Created with the Personal Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


E-Mail

Telas do MonitorPLUS ››

Created with the Personal Edition of HelpNDoc: Write EPub books for the iPad


Sedex

Telas do MonitorPLUS ››

Created with the Personal Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


NCM

Telas do MonitorPLUS ››

Created with the Personal Edition of HelpNDoc: Generate Kindle eBooks with ease


DFe

Telas do MonitorPLUS ››

Created with the Personal Edition of HelpNDoc: Free help authoring environment


Geral

Telas do MonitorPLUS ›› DFe ››

Created with the Personal Edition of HelpNDoc: News and information about help authoring tools and software


Certificados

Telas do MonitorPLUS ›› DFe ››

Created with the Personal Edition of HelpNDoc: Easily create EPub books


WebServices

Telas do MonitorPLUS ›› DFe ››

Created with the Personal Edition of HelpNDoc: iPhone web sites made easy


E-Mail

Telas do MonitorPLUS ›› DFe ››

Created with the Personal Edition of HelpNDoc: Easy CHM and documentation editor


Impressão

Telas do MonitorPLUS ›› DFe ››

Created with the Personal Edition of HelpNDoc: What is a Help Authoring tool?


Diretórios

Telas do MonitorPLUS ›› DFe ››

Created with the Personal Edition of HelpNDoc: Free Kindle producer


Teste

Telas do MonitorPLUS ›› DFe ››

Created with the Personal Edition of HelpNDoc: Produce electronic books easily


SAT

Telas do MonitorPLUS ››

Created with the Personal Edition of HelpNDoc: Free PDF documentation generator


Dados do SAT CFe

Telas do MonitorPLUS ›› SAT ››

Created with the Personal Edition of HelpNDoc: Full-featured EPub generator


Dados Emitente

Telas do MonitorPLUS ›› SAT ››

Created with the Personal Edition of HelpNDoc: Full-featured Kindle eBooks generator


Dados Sw.House

Telas do MonitorPLUS ›› SAT ››

Created with the Personal Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Rede

Telas do MonitorPLUS ›› SAT ››

Created with the Personal Edition of HelpNDoc: News and information about help authoring tools and software


Impressão

Telas do MonitorPLUS ›› SAT ››

Created with the Personal Edition of HelpNDoc: Free HTML Help documentation generator


PosPrinter

Telas do MonitorPLUS ››

Created with the Personal Edition of HelpNDoc: Full-featured multi-format Help generator


Comandos

Comandos aceitos pelo ACBrMonitor.

Created with the Personal Edition of HelpNDoc: Generate Kindle eBooks with ease


Comandos Gerais

Comandos ››

Bye, Exit, Sair ou Fim - Qualquer um desses comandos Encerra a comunicação TCP/IP com o ACBrMonitor, ou seja, desconecta-se do ACBrMonitor

Created with the Personal Edition of HelpNDoc: Easily create Help documents


Comandos do Objeto ACBr

Comandos ››

Comandos aceitos pelo Objeto ACBr

Created with the Personal Edition of HelpNDoc: What is a Help Authoring tool?


ACBr.Run

Comandos ›› Comandos do Objeto ACBr ››

Executa comandos na máquina em que o ACBrMonitor está rodando, útil para executar comandos no terminal Remoto, quando usando modo TCP/IP

ACBr.Run( cComando, [ cParams, bAguarda, nWindowState, bAltTab ] );

Parâmetros:

cComando – Linha de comando a ser executada pelo ACBrMonitor

cParams – (opcional) Parâmetros complementares informados a Linha de Comando

bAguarda – Opcional, se for omitido assume “False”. Quando informado “True”, aguarda o termino da execução do programa informado em cComando, antes de continuar com o ACBrMonitor (cuidado, esse parâmetro em “True” pode fazer o ACBrMonitor para de responder enquanto o Programa executado não seja finalizado)

nWindowState – (Opcional) Numérico informando o Estado daJanela: Utilize: 0 = Escondido; 1 = Normal (default); 2 = Minimizado; 3 = Maximizado (Disponível apenas no Windows)

bAltTab – Opcional, se for omitido assume “False”. Quando informado “True”, envia ALT+TAB para o teclado do Windows assim que a execução do programa terminar. Útil para restaurar o foco da aplicação controladora do ACBrMonitor (Disponível apenas no Windows)

Exemplos:

ACBr.Run(“NOTEPAD.EXE”,”Novo.TXT”) – Roda o Bloco de Notas do Windows, criando o arquivo Novo.TXT

ACBr.Run(“CALC.EXE”, ,”True”) – Executa a calculadora do Windows e aguarda o termino

Nota:

Necessita qua a Opção "Permitir Comandos Remotos" esteja selecionada

Created with the Personal Edition of HelpNDoc: Full-featured EPub generator


ACBr.Restaurar

Comandos ›› Comandos do Objeto ACBr ››

Exibe a tela do ACBrMonitor

Created with the Personal Edition of HelpNDoc: Easily create EPub books


ACBr.Ocultar

Comandos ›› Comandos do Objeto ACBr ››

Esconde o ACBrMonitor no Systray

Created with the Personal Edition of HelpNDoc: Full-featured multi-format Help generator


ACBr.EncerrarMonitor

Comandos ›› Comandos do Objeto ACBr ››

Encerra, finaliza o ACBrMonitor

Created with the Personal Edition of HelpNDoc: Full-featured multi-format Help generator


ACBr.SaveTofile

Comandos ›› Comandos do Objeto ACBr ››

Salva um arquivo na máquina em que o ACBrMonitor está rodando.

Util por exemplo, para implementar TEF discado em máquinas operadas remotamente por TCP/IP

ACBr.SaveToFile( cNomeArquivo, cConteudoArquivo );

Parâmetros:

cNomeArquivo – Nome completo do Arquivo a ser criado, informe o Path

cConteudoArquivo – Conteudo do Arquivo que será salvo. Para uso de caracteres de controle, como CR ou LF, use a notação especial "\x" seguido de 2 caracteres com o código em Hexadecimal do Caracter desejado.

Exemplos:

ACBr.SaveToFile("C:\TEF_Dial\Req\INTPOS.001","000-000 = ADM\x0D\x0A001-000 = 0001\x0D\x0A999-999 = 0\x0D\x0A") – Cria um arquivo de Requisição Administrativa para o programa TEF discado

Nota:

Necessita qua a Opção "Permitir Comandos Remotos" esteja selecionada

Created with the Personal Edition of HelpNDoc: Free HTML Help documentation generator


ACBr.LoadFromFile

Comandos ›› Comandos do Objeto ACBr ››

Lê um arquivo na máquina em que o ACBrMonitor está rodando.

Util por exemplo, para implementar TEF discado em máquinas operadas remotamente por TCP/IP

ACBr.LoadFromFile( cNomeArquivo [, nTempoDeEspera] );

Parâmetros:

cNomeArquivo – Nome completo do Arquivo a ser Lido, informe o Path

nTempoDeEspera – Tempo de Espera, em Milissegundos, até o arquivo ser encontrado ou liberado para Leitura. O ACBrMonitor tentará ler o arquivo até ter sucesso ou o Tempo de Espera seja atingido

Exemplos:

ACBr.LoadFromFile("C:\TEF_Dial\Resp\INTPOS.001", 7 ) – Tenta ler a resposta do TEF discado por até 7 segundos

A resposta com o conteudo do arquivo será gravada no arquivo de saída (ou enviada por TCP/IP), com a sinalização de sucesso ou não ("OK: " ou "ERRO: "). Exemplo:

OK: 000-000 = ADM

001-000 = 0001

002-000 =

009-000 = FF

030-000 = Cancelada pelo Operador

999-999 = 0

Nota:

Necessita qua a Opção "Permitir Comandos Remotos" esteja selecionada

Created with the Personal Edition of HelpNDoc: Full-featured Documentation generator


ACBr.DeleteFiles

Comandos ›› Comandos do Objeto ACBr ››

Apaga arquivos na máquina em que o ACBrMonitor está rodando.

Util por exemplo, para implementar TEF discado em máquinas operadas remotamente por TCP/IP

ACBr.DeleteFiles( cMascaraArquivos );

Parâmetros:

cMascaraArquivos – Nome completo do Arquivo a ser Apagado, ou Mascara com Arquivos a serem apagados

Exemplos:

ACBr.DeleteFiles("C:\TEF_Dial\Resp\INTPOS.001" )

Nota:

Necessita qua a Opção "Permitir Comandos Remotos" esteja selecionada

As mascaras '*', '*.*' ou '' não são permitidas por motivos de segurança

Created with the Personal Edition of HelpNDoc: Free EBook and documentation generator


ACBr.AppActivate

Comandos ›› Comandos do Objeto ACBr ››

Ativa o foco do Sistema Operacional para uma aplicação, baseado no nome da Janela.

ACBr.AppActivate( cNomeJanela [, nWait ] );

Parâmetros:

cNomeJanela – Nome da Janela que deseja ajustar o foco.

nWait – (opcional) Tempo em Milissegundos a esperar antes de efetuar o comando.

Exemplos:

ACBr.AppActivate("Calculator") - Traz a Calculadora do Windows para o Foco principal (se ela estiver em execução)

Nota:

Apenas disponível no Windows

Created with the Personal Edition of HelpNDoc: Create iPhone web-based documentation


ACBr.AppExists

Comandos ›› Comandos do Objeto ACBr ››

Retorna True ou False se existir uma aplicação em execução, baseado no nome da Janela informado

ACBr.AppExists( cNomeJanela );

Parâmetros:

cNomeJanela – Nome da Janela que deseja consultar a execução.

Exemplos:

ACBr.AppExists("Calculator") - Verifica se um programa chamado "Calculator" está em execução

OK: True

Nota:

Apenas disponível no Windows

Created with the Personal Edition of HelpNDoc: Create iPhone web-based documentation


ACBr.BlockInput

Comandos ›› Comandos do Objeto ACBr ››

Bloqueia/Desbloqueia o teclado.

ACBr.BlockInput( bTipo );

Parâmetros:

bTipo – True para bloquear e False para desbloquear o teclado.

Nota:

Apenas disponível no Windows

Created with the Personal Edition of HelpNDoc: Full-featured Kindle eBooks generator


ACBr.SendKeys

Comandos ›› Comandos do Objeto ACBr ››

Envia teclas para o Buffer de Teclado

ACBr.SendKeys( cTeclas [, bAguarda] );

Parâmetros:

cTeclas – Teclas a serem enviadas, usando a sintaxe especificada abaixo:

bAguarda - Se True, aguarda o termino do envio das teclas

Exemplos:

ACBr.SendKeys("^{ESC}") - Envia Ctrl+ESC para o buffer de Teclado

Sintaxe:

SendKeys supports the Visual Basic SendKeys syntax, as documented below.

Supported modifiers:

+ = Shift

^ = Control

% = Alt

Surround sequences of characters or key names with parentheses in order to

modify them as a group. For example, '+abc' shifts only 'a', while '+(abc)' shifts

all three characters.

Supported special characters

~ = Enter

( = Begin modifier group (see above)

) = End modifier group (see above)

{ = Begin key name text (see below)

} = End key name text (see below)

Supported characters:

Any character that can be typed is supported. Surround the modifier keys

listed above with braces in order to send as normal text.

Supported key names (surround these with braces):

BKSP, BS, BACKSPACE

BREAK

CAPSLOCK

CLEAR

DEL

DELETE

DOWN

END

ENTER

ESC

ESCAPE

F1

F2

F3

F4

F5

F6

F7

F8

F9

F10

F11

F12

F13

F14

F15

F16

HELP

HOME

INS

LEFT

NUMLOCK

PGDN

PGUP

PRTSC

RIGHT

SCROLLLOCK

TAB

UP

Follow the keyname with a space and a number to send the specified key a

given number of times (e.g., {left 6}).

Nota:

Apenas disponível no Windows

Created with the Personal Edition of HelpNDoc: Produce Kindle eBooks easily


ACBr.filesexists

Comandos ›› Comandos do Objeto ACBr ››

Comando para verificar se existem arquivos de acordo com "cMascaraArquivo"

ACBr.FilesExists( cMascaraArquivo )

Retorna "True" se existem arquivos.

Created with the Personal Edition of HelpNDoc: Easily create EPub books


ACBr.datahora

Comandos ›› Comandos do Objeto ACBr ››

Retorna a data e a hora.

Exemplo de resposta:

OK: 27/08/2015 09:01:18

Created with the Personal Edition of HelpNDoc: Easily create iPhone documentation


ACBr.data

Comandos ›› Comandos do Objeto ACBr ››

Retorna a data.

Exemplo de resposta:

OK: 27/08/2015

Created with the Personal Edition of HelpNDoc: Free iPhone documentation generator


ACBr.hora

Comandos ›› Comandos do Objeto ACBr ››

Retorna a hora.

Exemplo de resposta:

OK: 09:13:25

Created with the Personal Edition of HelpNDoc: Free Kindle producer


ACBr.lerini

Comandos ›› Comandos do Objeto ACBr ››

Recarrega configurações do arquivo INI

Created with the Personal Edition of HelpNDoc: Free Kindle producer


Comandos do Objeto ECF

Comandos ››

Comandos aceitos pelo Objeto ECF

Created with the Personal Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


Principal

Comandos ›› Comandos do Objeto ECF ››

Created with the Personal Edition of HelpNDoc: Free iPhone documentation generator


Ativo

Comandos ›› Comandos do Objeto ECF ›› Principal ››

Comando : ECF.Ativo

Retorna True para ECF ativo e False para ECF desativado

Exemplo de Resposta:

OK: True

Created with the Personal Edition of HelpNDoc: Easily create EPub books


Ativar

Comandos ›› Comandos do Objeto ECF ›› Principal ››

Comando : ECF.Ativar

Este procedimento ativa a ECF.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Write EPub books for the iPad


Desativar

Comandos ›› Comandos do Objeto ECF ›› Principal ››

Comando : ECF.Desativar

Este procedimento desativa a ECF.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Produce electronic books easily


Variaveis

Comandos ›› Comandos do Objeto ECF ››

Created with the Personal Edition of HelpNDoc: Free CHM Help documentation generator


Equipamentos

Comandos ›› Comandos do Objeto ECF ›› Variaveis ››

Created with the Personal Edition of HelpNDoc: Write EPub books for the iPad


Estado

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Equipamentos ››

Comando : ECF.Estado

Retorna o estado atual do ECF.

Exemplo de Resposta:

OK: estLivre

Tipo de estado de retorno:

    • estNaoInicializada, Porta Serial ainda não foi aberta;

    • estDesconhecido, Porta aberta, mas estado ainda não definido;

    • estLivre, Impressora Livre, sem nenhum cupom aberto pronta para nova venda, Redução Z e Leitura X ok, pode ou não já ter ocorrido 1ª venda no dia...;

    • estVenda, Cupom de Venda Aberto com ou sem venda do 1º Item;

    • estPagamento, Iniciado Fechamento de Cupom com Formas Pagamento pode ou não ter efetuado o 1º pagamento. Não pode mais vender itens, ou alterar Sub-total;

    • estRelatorio, Imprimindo Cupom Fiscal Vinculado ou Relatório Gerencial;

    • estBloqueada, Redução Z já emitida, bloqueada até as 00:00;

    • estRequerZ, Redução Z do dia anterior ainda não foi emitida. Emitir agora;

    • estRequerX, Esta impressora requer Leitura X todo inicio de dia. É necessário imprimir uma Leitura X para poder vender

Created with the Personal Edition of HelpNDoc: Full-featured EBook editor


Data Hora

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Equipamentos ››

Comando : ECF.DataHora

Retorna a data e hora do ECF.

Exemplo de Resposta:

OK: 06/12/12 13:36:15

Created with the Personal Edition of HelpNDoc: Full-featured Kindle eBooks generator


Modelo STR

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Equipamentos ››

Comando : ECF.ModeloStr

Retorna Modelo STR do ECF.

Exemplo de Resposta:

OK: Daruma

Created with the Personal Edition of HelpNDoc: Easily create Help documents


SubModelo ECF

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Equipamentos ››

Comando : ECF.SubModeloECF

Retorna Submodelo do ECF (Informações mais específicas sobre o Modelo).

Exemplo de Resposta:

OK: FS-600

Created with the Personal Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


Num ECF

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Equipamentos ››

Comando : ECF.NumECF

Retorna o Número do ECF.

Exemplo de Resposta:

OK: 001

Created with the Personal Edition of HelpNDoc: Easily create iPhone documentation


Num Loja

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Equipamentos ››

Comando : ECF.NumLoja

Retorna o Número da Loja.

Exemplo de Resposta:

OK: 001

Created with the Personal Edition of HelpNDoc: Produce electronic books easily


Num Série

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Equipamentos ››

Comando : ECF.NumSerie

Retorna o Número de Série do ECF.

Exemplo de Resposta:

OK: DR0208BR000000131549

Created with the Personal Edition of HelpNDoc: Free CHM Help documentation generator


Num Série MFD

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Equipamentos ››

Comando : ECF.NumSerieMFD

Retorna o Número de Série MFD.

Exemplo de Resposta:

OK: MFDSW00000000001

Created with the Personal Edition of HelpNDoc: Generate EPub eBooks with ease


Num Versao

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Equipamentos ››

Comando : ECF.NumVersao

Retorna o Número da versão do software do ECF.

Exemplo de Resposta:

OK: 010500

Created with the Personal Edition of HelpNDoc: Full-featured Documentation generator


CNPJ

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Equipamentos ››

Comando : ECF.CNPJ

Retorna o CNPJ cadastrado no ECF.

Exemplo de Resposta:

OK: 05.481.336/0001-37

Created with the Personal Edition of HelpNDoc: Full-featured EPub generator


IE

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Equipamentos ››

Comando : ECF.IE

Retorna a Inscrição Estadual cadastrada no ECF.

Exemplo de Resposta:

OK: 687.138.770.110

Created with the Personal Edition of HelpNDoc: Easily create CHM Help documents


IM

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Equipamentos ››

Comando : ECF.IM

Retorna a Inscrição Municipal cadastrada no ECF.

Exemplo de Resposta:

OK: 210987654321

Created with the Personal Edition of HelpNDoc: Easily create PDF Help documents


PAF

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Equipamentos ››

Comando : ECF.PAF

Retorna informações PAF como número de MD5, nome e versão do aplicativo fiscal.

Nota:

Não está disponível em todos os ECFs

Exemplo de Resposta:

OK: MD-5:22C5D38B8C715038C66FF34F459072F5 DJPDV 1.2.1

Created with the Personal Edition of HelpNDoc: Easy CHM and documentation editor


Usuario Atual

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Equipamentos ››

Comando : ECF.UsuarioAtual

Retorna o número do usuário atual do ECF.

Exemplo de Resposta:

OK: 01

Created with the Personal Edition of HelpNDoc: Free PDF documentation generator


Cliche

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Equipamentos ››

Comando : ECF.Cliche

Retorna as linhas do cliche do proprietário cadastrado no ECF (Cabeçalho).

Exemplo de Resposta:

OK: BEMATECH IND E COM DE EQUIP ELETRONICOS S/A

Estrada de Santa Candida, 263 Santa Candida

82.630-490 Curitiba - Parana

Created with the Personal Edition of HelpNDoc: Full-featured EBook editor


Data Hora SW Basico

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Equipamentos ››

Comando : ECF.DataHoraSB

Retorna a data e hora da Gravação do Software Básico do ECF.

Nota:

Não está disponível em todos os ECFs

Exemplo de Resposta:

OK: 07/12/12 08:59:36

Created with the Personal Edition of HelpNDoc: Free help authoring environment


Decimais Quantidade

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Equipamentos ››

Comando : ECF.DecimaisQtd

Retorna a quantidade de casas decimais para a Quantidade.

Exemplo de Resposta:

OK: 3

Created with the Personal Edition of HelpNDoc: Write EPub books for the iPad


Decimais Preço

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Equipamentos ››

Comando : ECF.DecimaisPreco

Retorna a quantidade de casas decimais para o Preço.

Exemplo de Resposta:

OK: 3

Created with the Personal Edition of HelpNDoc: Create iPhone web-based documentation


Colunas

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Equipamentos ››

Comando : ECF.Colunas

Retorna número de colunas do ECF.

Exemplo de Resposta:

OK: 48

Created with the Personal Edition of HelpNDoc: iPhone web sites made easy


MF Adicional

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Equipamentos ››

Comando : ECF.MFAdicional

Retorna se a ECF tem MF adicional. Geralmente as ECF identificam se ECF possui MF adicional através no Nº de Série e ao final a letra indicativa. Se não existe retornará OK.

Exemplo de MF Adicional: DR0105BR000000054098A

Exemplo sem a MF Adicional: DR0105BR000000054098

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Free PDF documentation generator


RFDID

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Equipamentos ››

Comando : ECF.RFDID

Retorna Registro de Fita Detalhe.

Exemplo de Resposta:

OK: DR

Created with the Personal Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Mapa Resumo

Comandos ›› Comandos do Objeto ECF ›› Variaveis ››

Created with the Personal Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Data Movimento

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ››

Comando : ECF.DataMovimento

Retorna data do movimento do ECF

Exemplo de Resposta:

OK: 07/12/12

Created with the Personal Edition of HelpNDoc: Full-featured multi-format Help generator


Dados Reducao Z

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ››

Comando : ECF.DadosReducaoZ

Retorna dados da Redução Z

Exemplo de Resposta:

OK: [ECF]

DataMovimento = 18/12/07

NumSerie = EMULADOR

NumECF = 0001

NumLoja = 0001

NumCOOInicial = 000004

NumCOO = 000013

NumCRZ = 0001

NumCRO = 0001

[Totalizadores]

VendaBruta = 653,64

GrandeTotal = 4201,84

TotalDescontos = 0,85

TotalCancelamentos = 0

TotalAcrescimos = 12

TotalNaoFiscal = 0

[Aliquotas]

01T1800 = 94,35

02T1200 = 202,1

03T0700 = 100,86

04S0500 = 0

[OutrasICMS]

TotalSubstituicaoTributaria = 161,99

TotalNaoTributado = 53,64

TotalIsencao = 39,85

[NaoFiscais]

SA_Sangria = 0

SU_Suprimento = 0

Created with the Personal Edition of HelpNDoc: Easily create HTML Help documents


Dados Ultima Reducao Z

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ››

Comando : ECF.DadosUltimaReducaoZ

Retorna dados da última Redução Z

Exemplo de Resposta:

OK: [ECF]

DataMovimento = 17/12/07

NumSerie = EMULADOR

NumLoja = 0001

NumECF = 0001

NumCOO = 000011

NumCRZ = 0001

NumCRO = 0001

[Aliquotas]

01T1800 = 0

02T1200 = 0

03T0700 = 0

04S0500 = 0

[OutrasICMS]

TotalSubstituicaoTributaria = 40

TotalNaoTributado = 3467

TotalIsencao = 32

[NaoFiscais]

SA_Sangria = 0

SU_Suprimento = 0

[Totalizadores]

TotalDescontos = 5,35

TotalCancelamentos = 3,85

TotalAcrescimos = 0

TotalNaoFiscal = 0

VendaBruta = 3544,35

GrandeTotal = 3548,2

Nota:

Não está disponível em todos os ECFs

Created with the Personal Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Num Reduções Z Restantes

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ››

Comando : ECF.NumReducoesZRestantes

Retorna o número de reduções Z restantes.

Exemplo de Resposta:

OK: 1834

Created with the Personal Edition of HelpNDoc: Free PDF documentation generator


Num COO

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ››

Comando : ECF.NumCOO

Retorna numero do COO (Contador de Ordem de Operação).

Exemplo de Resposta:

OK: 002435

Created with the Personal Edition of HelpNDoc: News and information about help authoring tools and software


Num CRZ

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ››

Comando : ECF.NumCRZ

Retorna número do CRZ (Contador de Reduções Z).

Exemplo de Resposta:

OK: 00001

Created with the Personal Edition of HelpNDoc: Write EPub books for the iPad


Num CRO

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ››

Comando : ECF.NumCRO

Retorna número do CRO (Contador de Reinicio de Operações (Intervenções) ).

Exemplo de Resposta:

OK: 001

Created with the Personal Edition of HelpNDoc: Free EBook and documentation generator


Num CCF

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ››

Comando : ECF.NumCCF

Retorna número do CCF (Contador de Cupom Fiscal).

Nota:

Não está disponível em todos os ECFs

Exemplo de Resposta:

OK: 000010

Created with the Personal Edition of HelpNDoc: Free iPhone documentation generator


Num COO Inicial

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ››

Comando : ECF.NumCOOInicial

Retorna Numero COO Inicial.

Exemplo de Resposta:

OK: 2434

Created with the Personal Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


Num GNF

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ››

Comando : ECF.NumGNF

Retorna número do GNF (Geral de Operação Não-Fiscal)

Nota:

Não está disponível em todos os ECFs

Exemplo de Resposta:

OK: 000017

Created with the Personal Edition of HelpNDoc: Easily create Web Help sites


Num GNFC

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ››

Comando : ECF.NumGNFC

Retorna número do GNF (Contador Geral de Operação Não-Fiscal)

Nota:

Não está disponível em todos os ECFs

Exemplo de Resposta:

OK: 000000

Created with the Personal Edition of HelpNDoc: Free Web Help generator


Num GRG

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ››

Comando : ECF.NumGRG

Retorna número do GRG (Contador Geral de Relatório Gerencial).

Nota:

Não está disponível em todos os ECFs

Exemplo de Resposta:

OK: 000016

Created with the Personal Edition of HelpNDoc: Full-featured multi-format Help generator


Num CDC

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ››

Comando : ECF.NumCDC

Retorna número do CDC (Comprovante de Credito ou Débito).

Nota:

Não está disponível em todos os ECFs

Exemplo de Resposta:

OK: 000017

Created with the Personal Edition of HelpNDoc: Generate EPub eBooks with ease


Num CFC

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ››

Comando : ECF.NumCFC

Retorna número do contador de Cupom Fiscal Cancelado.

Nota:

Não está disponível em todos os ECFs

Exemplo de Resposta:

OK: 0002

Created with the Personal Edition of HelpNDoc: Free help authoring environment


Num CCDC

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ››

Comando : ECF.NumCCDC

Retorna número do CCDC (Contador Comprovante de Credito ou Débito).

Nota:

Não está disponível em todos os ECFs

Exemplo de Resposta:

OK: 000000

Created with the Personal Edition of HelpNDoc: Easily create PDF Help documents


Num CFD

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ››

Comando : ECF.NumCFD

Retorna número do CFD (Contador de Fita Detalhe).

Exemplo de Resposta:

OK: 000000

Created with the Personal Edition of HelpNDoc: Free help authoring environment


Num NCN

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ››

Comando : ECF.NumNCN

Retorna número do NCN (Número de Comprovantes de Crédito ou Débito Não Emitidos).

Exemplo de Resposta:

OK: 0010

Created with the Personal Edition of HelpNDoc: Free help authoring tool


Venda Bruta

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ››

Comando : ECF.VendaBruta

Retorna o valor da Venda Bruta .

Exemplo de Resposta:

OK: 3548,20

Created with the Personal Edition of HelpNDoc: Free CHM Help documentation generator


Grande Total

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ››

Comando : ECF.GrandeTotal

Retorna o Valor do Grande Total .

Exemplo de Resposta:

OK: 223236.73

Created with the Personal Edition of HelpNDoc: Easily create CHM Help documents


Total Troco

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ››

Comando : ECF.TotalTroco

Retorna o Valor Total do Troco.

Exemplo de Resposta:

OK: 1

Created with the Personal Edition of HelpNDoc: Generate EPub eBooks with ease


Totais ICMS

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ››

Created with the Personal Edition of HelpNDoc: Produce Kindle eBooks easily


Total Cancelamentos

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ›› Totais ICMS ››

Comando : ECF.TotalCancelamentos

Retorna Total de Cancelamentos ICMS.

Exemplo de Resposta:

OK: 3,85

Created with the Personal Edition of HelpNDoc: Easily create HTML Help documents


Total Descontos

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ›› Totais ICMS ››

Comando : ECF.TotalDescontos

Retorna Total de Descontos ICMS.

Exemplo de Resposta:

OK: 5,35

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Total Acrescimos

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ›› Totais ICMS ››

Comando : ECF.TotalAcrescimos

Retorno Total de Acréscimos ICMS.

Exemplo de Resposta:

OK: 0

Created with the Personal Edition of HelpNDoc: Full-featured Help generator


Total Substituicao Tributaria

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ›› Totais ICMS ››

Comando : ECF.TotalSubstituicaoTributaria

Retorna Total Vendido em Substituição Tributária ICMS.

Exemplo de Resposta:

OK: 40

Created with the Personal Edition of HelpNDoc: Full-featured Documentation generator


Total Nao Tributado

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ›› Totais ICMS ››

Comando : ECF.TotalNaoTributado

Retorna Total Vendido Não Tributado ICMS.

Exemplo de Resposta:

OK: 3467.55

Created with the Personal Edition of HelpNDoc: Full-featured EBook editor


Total Isencao

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ›› Totais ICMS ››

Comando : ECF.TotalIsencao

Retorna Total Vendido Isento ICMS.

Exemplo de Resposta:

OK: 32

Created with the Personal Edition of HelpNDoc: Free help authoring environment


Totais ISSQN

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ››

Created with the Personal Edition of HelpNDoc: Write eBooks for the Kindle


Total Cancelamentos

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ›› Totais ISSQN ››

Comando : ECF.TotalCancelamentosISSQN

Retorna Total de Cancelamentos ISSQN.

Exemplo de Resposta:

OK: 45

Created with the Personal Edition of HelpNDoc: Create iPhone web-based documentation


Total Descontos

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ›› Totais ISSQN ››

Comando : ECF.TotalDescontosISSQN

Retorna Total de Descontos ISSQN

Exemplo de Resposta:

OK: 48.66

Created with the Personal Edition of HelpNDoc: Full-featured Help generator


Total Acrescimos

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ›› Totais ISSQN ››

Comando : ECF.TotalAcrescimosISSQN

Retorno Total de Acréscimos ISSQN.

Exemplo de Resposta:

OK: 0

Created with the Personal Edition of HelpNDoc: Easily create HTML Help documents


Total Substituicao Tributaria

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ›› Totais ISSQN ››

Comando : ECF.TotalSubstituicaoTributariaISSQN

Retorna Total Vendido em Substituição Tributária ISSQN.

Exemplo de Resposta:

OK: 7.67

Created with the Personal Edition of HelpNDoc: Easily create HTML Help documents


Total Nao Tributado

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ›› Totais ISSQN ››

Comando : ECF.TotalNaoTributadoISSQN

Retorna Total Vendido Não Tributado ISSQN.

Exemplo de Resposta:

OK: 8.08

Created with the Personal Edition of HelpNDoc: Easy EPub and documentation editor


Total Isencao

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ›› Totais ISSQN ››

Comando : ECF.TotalIsencaoISSQN

Retorna Total Vendido Isento ISSQN.

Exemplo de Resposta:

OK: 7.87

Created with the Personal Edition of HelpNDoc: Free HTML Help documentation generator


Total Nao Fiscal

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ››

Created with the Personal Edition of HelpNDoc: Free help authoring tool


Valor Total

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ›› Total Nao Fiscal ››

Comando : ECF.TotalNaoFiscal

Retorna Valor Total de Comprovantes Não Fiscal.

Exemplo de Resposta:

OK: 60

Created with the Personal Edition of HelpNDoc: Free help authoring tool


Total Cancelamentos

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ›› Total Nao Fiscal ››

Comando : ECF.TotalCancelamentosOPNF

Retorna Total de Cancelamentos Operações Não Fiscal.

Exemplo de Resposta:

OK: 200

Created with the Personal Edition of HelpNDoc: Produce electronic books easily


Total Descontos

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ›› Total Nao Fiscal ››

Comando : ECF.TotalDescontosOPNF

Retorna Total de Descontos de Operações Não Fiscais

Exemplo de Resposta:

OK: 10

Created with the Personal Edition of HelpNDoc: Easily create EPub books


Total Acrescimos

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ›› Total Nao Fiscal ››

Comando : ECF.TotalAcrescimosOPNF

Retorno Total de Acréscimos de Operações Não Fiscais.

Exemplo de Resposta:

OK: 30

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Flags

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ››

Created with the Personal Edition of HelpNDoc: What is a Help Authoring tool?


Tipo Ultimo documento

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ›› Flags ››

Comando : ECF.TipoUltimoDocumento

Retorna o tipo do último documento emitido pelo ECF.

Nota: Comando disponível apenas para Epson e FiscNet, os demais modelos de ECF irá retornar "docNenhum".

Exemplo de Resposta:

OK: docCF

OK: docNenhum

Tipo de documento:

    • docRZ - Redução Z;
    • docLX - Leitura X;
    • docCF - Cupom Fiscal;
    • docCFBP - Cupom Fiscal Bilhete de Passagem;
    • docCupomAdicional - Cupom Adicional;
    • docCFCancelamento - Cancelamento Cupom Fiscal;
    • docCCD - Comprovante de Crédito ou Débito;
    • docAdicionalCCD - Adicional de Comprovante de Crédito ou Débito;
    • docSegViaCCD - Segunda Via de Comprovante de Crédito ou Débito;
    • docReimpressaoCCD - Reimpressão de Comprovante de Crédito ou Débito;
    • docEstornoCCD - Estorno de Comprovante de Crédito ou Débito;
    • docCNF - Comprovante Não Fiscal;
    • docCNFCancelamento - Cancelamento Comprovante Não Fiscal;
    • docSangria - Sangria;
    • docSuprimento - Suprimento;
    • docEstornoPagto - Estorno Pagamento;
    • docRG - Relatório Gerencial;
    • docLMF - Leitura da Memória Fiscal;
    • docTodos - Todos;
    • docNenhum - Nenhum documento;

Created with the Personal Edition of HelpNDoc: Full-featured Kindle eBooks generator


Pouco Papel?

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ›› Flags ››

Comando : ECF.PoucoPapel

Retorna se o ECF está com pouco papel.

Exemplo de Resposta:

OK: False

Created with the Personal Edition of HelpNDoc: Easy EPub and documentation editor


Horario de Verao?

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ›› Flags ››

Comando : ECF.HorarioVerao

Retorna se o ECF está em Horário de Verão.

Nota: Isso também pode ser constatado observando a letra “V” ao lado da Hora no rodapé do Cupom Fiscal - Exemplo: 10:16:32V

Exemplo de Resposta:

OK: True

Created with the Personal Edition of HelpNDoc: Free Kindle producer


Arredonda?

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ›› Flags ››

Comando : ECF.Arredonda

Retorna se o ECF arredonda os valores do "Total por Item" durante a Venda.

Exemplo: Qtd 1 x Preço Unit. 1,207 = 1,21 com Arredondamento no ECF

= 1,20 sem Arredondamento no ECF.

Nota:

* Na maioria dos ECFs o Arredondamento deve ser programado, o que pode ser feito com o comando ECF.MudaArredondamento

* Em alguns ECFs o arredondamento é definido de acordo com o comando enviado para a Venda de Item, nesse caso, o ACBr procura usar o Arredondamento sempre que possível.

* Após o convênio do ICMS 56/94 o arredondamento não é mais permitido, portanto todos os novos ECFs apenas Truncam o Total por Item.

Exemplo de Resposta:

OK: False

Created with the Personal Edition of HelpNDoc: Produce electronic books easily


É MFD?

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ›› Flags ››

Comando : ECF.MFD

Retorna se a ECF tem MFD( Memória Fita Detalhe).

Exemplo de Resposta:

OK: True

Created with the Personal Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


É Termica?

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ›› Flags ››

Comando : ECF.Termica

Retorna se a ECF possui impressão Térmica.

Exemplo de Resposta:

OK: True

Created with the Personal Edition of HelpNDoc: iPhone web sites made easy


IdentificaConsumidorRodape?

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ›› Flags ››

Comando : ECF.IdentificaConsumidorRodape

Retorna se a ECF Identifica Consumidor no rodapé do cupom.

Exemplo de Resposta:

OK: True

Created with the Personal Edition of HelpNDoc: Full-featured Kindle eBooks generator


Parametro Desconto ISSQN?

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Mapa Resumo ›› Flags ››

Comando : ECF.ParamDescontoISSQN

Retorna se ECF permite desconto em ISSQN.

Exemplo de Resposta:

OK: True

Created with the Personal Edition of HelpNDoc: Free Web Help generator


Aliquotas

Comandos ›› Comandos do Objeto ECF ›› Variaveis ››

Created with the Personal Edition of HelpNDoc: Easily create EPub books


Aliquotas

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Aliquotas ››

Comando : ECF.Aliquotas

Retorna todas as alíquotas cadastradas no ECF.

IIIIT999.99|IIIIT999.99|IIIIT999.99|....

Onde:

I = índice da Alíquota usado pelo ACBrECF

T = Tipo da Alíquota, ( "T" = ICMS, "S" = ISS)

999.99 = Valor da Alíquota

Nota: Esse comando quando executado a primeira vez, se comunica com o ECF a fim de carregar a tabela de alíquotas. Após a carga, elas são transferidas para a memória do ACBrECF

Exemplo de Resposta:

OK: 01 S3.00|02 S5.00|03 T12.00|04 T18.00|05 T7.00|06 T25.00|07 S10.00|08 T17.00

Created with the Personal Edition of HelpNDoc: Free Web Help generator


Carrega Aliquotas (ICMS)

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Aliquotas ››

Comando : ECF.CarregaAliquotas

Semelhante ao comando ECF.Aliquotas , porém esse comando sempre se comunica com o ECF a fim de ler novamente todas as alíquotas cadastradas

Exemplo de Resposta:

OK: 01 S3.00|02 S5.00|03 T12.00|04 T18.00|05 T7.00|06 T25.00|07 S10.00|08 T17.00

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Ler Totais Aliquotas

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Aliquotas ››

Comando : ECF.LerTotaisAliquota

Retorna os valores totais das alíquotas cadastradas no ECF.

IIII999.99|IIII999.99|IIII999.99|....

Onde:

I = índice da Alíquota usado pelo ACBrECF

999.99 = Valor da Alíquota

Exemplo de Resposta:

OK: 01 0.00|02 0.00|03 10.12|04 0.00|05 18.80|06 0.00|07 401.24|08 0.00|09 42.00|10 0.00

Created with the Personal Edition of HelpNDoc: What is a Help Authoring tool?


Achar Aliquota por Valor

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Aliquotas ››

Comando : ECF.AchaIcmsAliquota( nValorAliquota, [cTipoAliquota] )

Procura Alíquota no ECF pelo valor informado e retorna o índice da alíquota.

Parâmetros:

nValorAliquota - Valor da Alíquota a procurar. Exemplos: 18 , 12 , 2.46

cTipoAliquota - Tipo da Alíquota , Use "T" para ICMS ou "S" para ISS. Pode ser omitido, nesse caso retorna a primeira alíquota encontrada.

Exemplo:

ECF.AchaIcmsAliquota(18)

ECF.AchaIcmsAliquota(10,"S")

ECF.AchaIcmsAliquota(32)

Retorna: IIIIT999.99

Onde:

I = índice da Alíquota usado pelo ACBrECF

T = Tipo da Alíquota, ( "T" = ICMS, "S" = ISS)

999.99 = Valor da Alíquota

Exemplo de Resposta:

OK: 01 T18,00

OK: 03 S10,00

ERRO: Aliquota: 32 não encontrada

Created with the Personal Edition of HelpNDoc: Free CHM Help documentation generator


Formas de Pagamento

Comandos ›› Comandos do Objeto ECF ›› Variaveis ››

Created with the Personal Edition of HelpNDoc: Create iPhone web-based documentation


Formas de Pagamento

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Formas de Pagamento ››

Comando : ECF.FormasPagamento

Retorna todas as Formas de Pagamento Cadastradas na ECF.

IIIITDDDDDDDDDDDDDDDDDDDDDDDDDDDDDD|....

Onde:

I = índice da forma de pagamento usado pelo ACBrECF

T = Permite vinculado ( "V" = Sim, "Vazio" = Não)

D = Descrição da forma de pagamento

Nota: Esse comando quando executado a primeira vez, se comunica com o ECF a fim de carregar a tabela de Formas de Pagamento. Após a carga, elas são transferidas para a memória do ACBrECF.

Exemplo de Resposta:

OK: 01 Dinheiro |02 VCARTAO

Created with the Personal Edition of HelpNDoc: Free EPub and documentation generator


Carrega Formas Pagamento

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Formas de Pagamento ››

Comando : ECF.CarregaFormasPagamento

Semelhante ao comando ECF.FormasPagamento , porém esse comando sempre se comunica com o ECF a fim de ler novamente todas as Formas de Pagamento cadastradas

Exemplo de Resposta:

OK: 01 Dinheiro |02 VCARTAO

Created with the Personal Edition of HelpNDoc: Write eBooks for the Kindle


Ler Totais Forma de Pagamento

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Formas de Pagamento ››

Comando : ECF.LerTotaisFormaPagamento

Retorna Total de cada Forma de Pagamento cadastradas no ECF

IIII999.99|IIII999.99|IIII999.99|....

Onde:

I = índice da Forma de Pagamento usado pelo ACBrECF

999.99 = Valor total da Forma de Pagamento.

Exemplo de Resposta:

OK: 01 103,00|02 400,00|03 0,00|04 40

Created with the Personal Edition of HelpNDoc: Easily create Web Help sites


Achar Forma de Pagamento por Descricao

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Formas de Pagamento ››

Comando : ECF.AchaFPGDescricao( cDescricaoForma )

Retorna informações sobre a Forma de Pagamento a ser procurada.

Parâmetros:

cDescricaoForma - Descrição da forma de pagamento

Exemplo:

ECF.AchaFPGDescricao("DINHEIRO")

Retorna: IIIITDDDDDDDDDDDDDDDDDDDDDDDDDDDDDD

Onde:

I = índice da forma de pagamento usado pelo ACBrECF

T = Permite vinculado ( "V" = Sim, "Vazio" = Não)

D = Descrição da forma de pagamento

Exemplo de Resposta:

OK: 01 VDinheiro

Created with the Personal Edition of HelpNDoc: Easily create iPhone documentation


Comprovantes Nao Fiscais

Comandos ›› Comandos do Objeto ECF ›› Variaveis ››

Created with the Personal Edition of HelpNDoc: Full-featured multi-format Help generator


Comprovantes Nao Fiscais

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Comprovantes Nao Fiscais ››

Comando : ECF.ComprovantesNaoFiscais

Retorna todas os CNFs cadastrados na ECF.

IIIITDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDFFFF|....

Onde:

I = índice do comprovante não fiscal usado pelo ACBrECF

T = Permite vinculado ( "V" = Sim, "Vazio" = Não)

D = Descrição do comprovante não fiscal

F = Forma de pagamento associada (apenas na Schalter).

Nota: Esse comando quando executado a primeira vez, se comunica com o ECF a fim de carregar a tabela de Comprovantes não Fiscais. Após a carga, elas são transferidas para a memória do ACBrECF

Exemplo de Resposta:

OK: 01 Sangria |02 Suprimento

Created with the Personal Edition of HelpNDoc: Free Web Help generator


Carrega Comprovantes Nao Fiscais

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Comprovantes Nao Fiscais ››

Comando : ECF.CarregaComprovantesNaoFiscais

Semelhante ao comando ECF.ComprovantesNaoFiscais , porém esse comando sempre se comunica com o ECF a fim de ler novamente todas os Comprovantes não Fiscais cadastrados

Exemplo de Resposta:

OK: 01 Sangria |02 Suprimento

Created with the Personal Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Ler Totais Comprovantes Nao Fiscais

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Comprovantes Nao Fiscais ››

Comando : ECF.LerTotaisComprovanteNaoFiscal

Retorna Total de cada comprovante não fiscal (CNF) cadastrados no ECF.

IIII999.99|IIII999.99|IIII999.99|....

Onde:

I = índice do CNF usado pelo ACBrECF

999.99 = Valor total do CNF.

Exemplo de Resposta:

OK: 01 0.00|02 0.00|03 0.00

Created with the Personal Edition of HelpNDoc: Free HTML Help documentation generator


Achar CNF por Descricao

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Comprovantes Nao Fiscais ››

Comando : ECF.AchaCNFDescricao( cDescricaoCNF )

Retorna informações sobre o Comprovante não Fiscal a ser procurado

Parâmetros:

cDescricaoCNF - Descrição do comprovante não fiscal.

Exemplo:

ECF.AchaCNFDescricao("SANGRIA")

Retorna: IIIITDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDFFFF

Onde:

I = índice do comprovante não fiscal usado pelo ACBrECF

T = Permite vinculado ( "V" = Sim, "Vazio" = Não)

D = Descrição do comprovante não fiscal

F = Forma de pagamento associada (apenas na Schalter).

Exemplo de Resposta:

OK: 01 Sangria

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Relatorios Gerenciais

Comandos ›› Comandos do Objeto ECF ›› Variaveis ››

Created with the Personal Edition of HelpNDoc: Free PDF documentation generator


Relatorios Gerenciais

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Relatorios Gerenciais ››

Comando : ECF.RelatoriosGerenciais

Retorna todas os Relatorios Gerenciais cadastrados na ECF.

IIIIDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDCCCCC|....

Onde:

I = índice do relatório gerencial usado pelo ACBrECF

D = Descrição do relatório gerencial

C = Contador de relatório gerencial.

Nota: Esse comando quando executado a primeira vez, se comunica com o ECF a fim de carregar a tabela de Relatórios Gerenciais. Após a carga, elas são transferidas para a memória do ACBrECF

Exemplo de Resposta:

OK: 01 Gerencial X 00000|02 MOV.CAIXA 00000

Created with the Personal Edition of HelpNDoc: Free help authoring environment


Carrega Relatorios Gerenciais

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Relatorios Gerenciais ››

Comando : ECF.CarregaRelatoriosGerenciais

Semelhante ao comando ECF.RelatoriosGerencial , porém esse comando sempre se comunica com o ECF a fim de ler novamente todos os Relatórios Gerenciais cadastrados

Exemplo de Resposta:

OK: 01 Gerencial X 00000|02 MOV.CAIXA 00000

Created with the Personal Edition of HelpNDoc: Produce Kindle eBooks easily


Ler Totais Relatorios Gerenciais

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Relatorios Gerenciais ››

Comando : ECF.LerTotaisRelatoriosGerenciais

Retorna Total de cada relatório gerencial cadastrados no ECF.

IIII99999|IIII99999|IIII99999|....

Onde:

I = índice do relatório Gerencial usado pelo ACBrECF

99999 = Contador .

Exemplo de Resposta:

OK: 01 00000|02 00000|03 00000

Created with the Personal Edition of HelpNDoc: Free iPhone documentation generator


Achar Relatorio Gerencial por Descricao

Comandos ›› Comandos do Objeto ECF ›› Variaveis ›› Relatorios Gerenciais ››

Comando : ECF.AchaRGDescricao( cDescricaoRG)

Retorna informações sobre o Relatório Gerencial a ser procurado

Parâmetros:

cDescricaoRG - Descrição do relatório gerencial.

Exemplo:

ECF.AchaRGDescricao("FECHAMENTO")

Retorna: IIIIDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDCCCCC

Onde:

I = índice do relatório gerencial usado pelo ACBrECF

D = Descrição do relatório gerencial

C = Contador relatório gerencial.

Exemplo de Resposta:

OK: 02 Fechamento 00000

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Unidades Medida

Comandos ›› Comandos do Objeto ECF ›› Variaveis ››

Comando : ECF.UnidadesMedida

Retorna todas Unidades de Medida Cadastradas na ECF.

IIIIDDDD|IIIIDDDD|IIIIDDDD|....

Onde:

I = índice da unidade de medida usada pelo ACBrECF

D = Descrição da unidade de medida

Nota: Esse comando quando executado a primeira vez, se comunica com o ECF a fim de carregar a tabela de Unidades de medida. Após a carga, elas são transferidas para a memória do ACBrECF

Nota:

Não está disponível em todos os ECFs

Exemplo de Resposta:

OK: 01 UN

Created with the Personal Edition of HelpNDoc: Produce electronic books easily


Carrega Unidades de Medida

Comandos ›› Comandos do Objeto ECF ›› Variaveis ››

Comando : ECF.CarregaUnidadesMedida

Semelhante ao comando ECF.UnidadesMedidas , porém esse comando sempre se comunica com o ECF a fim de ler novamente todas as Unidades de Medidas cadastradas.

Exemplo de Resposta:

OK: 01 UN

Created with the Personal Edition of HelpNDoc: Easily create PDF Help documents


Relatorios

Comandos ›› Comandos do Objeto ECF ››

Created with the Personal Edition of HelpNDoc: Full-featured Help generator


Leitura X

Comandos ›› Comandos do Objeto ECF ›› Relatorios ››

Comando : ECF.LeituraX

Emite o relatório de Leitura X.

Nota: em alguns estados, é necessário imprimir uma Leitura X todo inicio de dia e cada inicio de Bobina

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Produce electronic books easily


Reducao Z

Comandos ›› Comandos do Objeto ECF ›› Relatorios ››

Comando : ECF.ReducaoZ[( dDataHora )]

Emite o relatório de Redução Z.

Parâmetros:

dDataHora - Data / Hora atual do micro. Parâmetro pode ser omitido. Se dDataHora for informado, o ACBrECF tentará acertar o relógio do ECF (disponível apenas em alguns ECFs), aumentando ou diminuindo o horário no máximo de 5 minutos por dia.

Exemplos:

ECF.ReducaoZ -> Parâmetro dDataHora foi omitido

ECF.ReducaoZ("14/08/06 18:05:20") -> Informando o Parâmetro dDataHora

ECF.ReducaoZ("14/08/2006 18:05") -> Informando o Parâmetro dDataHora

Nota: Se emitido no mesmo dia fiscal, bloqueia o ECF até as 24:00hs.

Se não for emitida no mesmo dia fiscal o ECF ficará bloqueado, e o ACBr retornará o Estado como estRequerZ. Nesse caso será necessário emitir a Redução Z pendente (do dia anterior) para liberar o ECF

Cuidado: Apenas comande a Redução Z se o estado do ECF for estRequerZ ou se você deseja realmente bloquear o ECF até a meia-noite (fim de dia).

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Full-featured EPub generator


Cupom Vinculado ou CCD

Comandos ›› Comandos do Objeto ECF ›› Relatorios ››

Created with the Personal Edition of HelpNDoc: Free help authoring environment


Prepara TEF

Comandos ›› Comandos do Objeto ECF ›› Relatorios ›› Cupom Vinculado ou CCD ››

Comando: ECF.PreparaTEF

- Verifica se existe algum relatório Gerencial ou Vinculado aberto, se for o caso, fecha-o.

- Carrega as tabelas de Formas de Pagamento e Comprovantes não Fiscais na memória.

- Deve ser chamado apenas no inicio da aplicação

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Abre Cupom Vinculado

Comandos ›› Comandos do Objeto ECF ›› Relatorios ›› Cupom Vinculado ou CCD ››

Comando : ECF.AbreCupomVinculado( cCOO, cCodFormaPagto, nValor )

ou

Comando : ECF.AbreCupomVinculado( cCOO, cCodFormaPagto, cCodComprovanteNaoFiscal, nValor )

Ambos comandos emite o Cupom vinculado conforme os dados que foram informados nos parâmetros. A emissão é automaticamente encerrada 2 minutos após abertura (Tempo máximo de emissão).

Parâmetros:

cCOO - Número de COO do cupom anterior. (Necessário documento anterior seja cupom fiscal)

cCodFormaPagto - Código da forma de pagamento utilizada no cupom anterior.(Permite Vinculado)

cCodComprovanteNaoFiscal - Se necessário, informe o Código do Comprovante Não Fiscal.

nValor - Valor a vincular no cupom anterior.

Exemplos:

ECF.AbreCupomVinculado("002466", "02", 1.00)

ECF.AbreCupomVinculado("002468", "02", "02", 1.00)

Nota: Para imprimir um Cupom Vinculado você deve ter informaçoes dos Pagamentos Efetuados no último Cupom Fiscal.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Free CHM Help documentation generator


Cupom Vinculado

Comandos ›› Comandos do Objeto ECF ›› Relatorios ›› Cupom Vinculado ou CCD ››

Comando : ECF.CupomVinculado( cCOO, cCodFormaPagto, nValor )

ou

Comando : ECF.CupomVinculado( cCOO, cCodFormaPagto, cCodComprovanteNaoFiscal, nValor )

Semelhante ao comando ECF.AbreCupomVinculado. A diferença é que este comando realiza a impressão do cupom vinculado realizando o fechamento sem utilizar o tempo de espera do ECF.

Exemplos:

ECF.CupomVinculado("002466", "02", 1.00)

ECF.CupomVinculado("002468", "02", "02", 1.00)

Nota: Não permite imprimir linhas no cupom vinculado.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Free Kindle producer


Imprime Linha Cupom Vinculado

Comandos ›› Comandos do Objeto ECF ›› Relatorios ›› Cupom Vinculado ou CCD ››

Comando : ECF. LinhaCupomVinculado( cLinha )

Imprimi no final do cupom vinculado o texto informado no parâmetro.

Parâmetros:

cLinha - Texto a ser impresso no final do cupom vinculado.

Exemplos:

ECF.LinhaCupomVinculado("Teste texto de cupom Vinculado")

Nota: A impressão só é realizada com o cupom vinculado em estado aberto, portanto depende do comando ECF.AbreCupomVinculado ser executado primeiro.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Easily create CHM Help documents


Estorna CCD

Comandos ›› Comandos do Objeto ECF ›› Relatorios ›› Cupom Vinculado ou CCD ››

Comando : ECF.EstornaCCD[( bTodos )]

Estorna o cupom vinculado retornando a quantidade de cupons estornados.Para utilizar este comando é necessário que o último documento emitido seja docCCD.

Parâmetros:

bTodos - Parâmetro pode ser omitido e será considerado para estornar todos os cupons vinculados, se informado com "false" será estornado apenas o último CCD.

Exemplos:

ECF.EstornaCCD -> Será estornados todos

ECF.EstornaCCD(true) -> Será estornados todos

ECF.EstornaCCD(false) -> Será estornado apenas o último CCD.

Nota: Comando disponível apenas para Epson e FiscNet.

Exemplo de Resposta:

OK: 2

OK: 1

Created with the Personal Edition of HelpNDoc: Free iPhone documentation generator


Segunda Via Vinculado

Comandos ›› Comandos do Objeto ECF ›› Relatorios ›› Cupom Vinculado ou CCD ››

Comando : ECF.SegundaViaVinculado

Imprime a segunda via do cupom vinculado.Para utilizar este comando é necessário que o último documento emitido seja docCCD.

Nota: Comando disponível apenas para Daruma.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Easily create EPub books


Reimpressao Vinculado

Comandos ›› Comandos do Objeto ECF ›› Relatorios ›› Cupom Vinculado ou CCD ››

Comando : ECF.ReimpressaoVinculado

Reimprime o cupom vinculado.

Nota: Comando disponível apenas para Daruma.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Free EBook and documentation generator


Relatorio Gerencial

Comandos ›› Comandos do Objeto ECF ›› Relatorios ››

Created with the Personal Edition of HelpNDoc: Easily create HTML Help documents


Abre Relatorio Gerencial

Comandos ›› Comandos do Objeto ECF ›› Relatorios ›› Relatorio Gerencial ››

Comando : ECF.AbreRelatorioGerencial [( nIndice )]

Emite o Relatório Gerencial referente ao índice informado no parâmetro. A emissão é automaticamente encerrada 2 minutos após abertura (Tempo máximo de emissão).

Parâmetros:

nIndice - Indice do relatorio gerencial a ser impresso. Parâmetro pode ser omitido e será considerado o indice padrão de cada modelo de ECF.

Exemplos:

ECF.AbreRelatorioGerencial -> Imprime o RG padrão.

ECF.AbreRelatorioGerencial(2) -> Imprime RG de indice 2

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Relatorio Gerencial

Comandos ›› Comandos do Objeto ECF ›› Relatorios ›› Relatorio Gerencial ››

Comando : ECF.RelatorioGerencial( cRelatorio, [nVias] )

Emite Relatório Gerencial padrão contendo o texto e quantidade de vias informado nos parâmetros.

Parâmetros:

cRelatorio - Texto que será impresso no corpo do relatório gerencial.(Para imprimir várias linhas separar o texto com pipe "|" ).

nVias - Quantidade de vias a ser impressa. Parâmetro pode ser omitido e será considerado 1 via.

Exemplos:

ECF.RelatorioGerencial("Relatorio Gerencial linha1")

ECF.RelatorioGerencial("Relatorio Gerencial | Fechamento",2)

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Free EPub and documentation generator


Imprime Linha Relatorio

Comandos ›› Comandos do Objeto ECF ›› Relatorios ›› Relatorio Gerencial ››

Comando : ECF.LinhaRelatorioGerencial( cLinha )

Imprimi no final do cupom vinculado o texto informado no parâmetro.

Parâmetros:

cLinha - Texto a ser impresso no final do relatório gerencial. (Para imprimir várias linhas separar o texto com pipe "|" ).

Exemplos:

ECF.LinhaRelatorioGerencial("Teste texto de relatorio gerencial")

ECF.LinhaRelatorioGerencial("Teste texto de relatorio gerencial | Teste texto linha 2" )

Nota: A impressão só é realizada com o relatório gerencial em estado aberto, portanto depende do comando ECF.AbreRelatorioGerencial ser executado primeiro.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Easily create PDF Help documents


Pula Linhas

Comandos ›› Comandos do Objeto ECF ›› Relatorios ››

Comando : ECF.PulaLinhas( nNumLinhas )

Pula linhas no Cupom Vinculado ou Relatório Gerencial.

Parâmetros:

nNumLinhas - Quantidade de linhas para pular.

Exemplos:

ECF.PulaLinhas( 3 )

Nota: Pular linhas só é realizada com o RG ou CCD em estado aberto.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Full-featured Documentation generator


Corta Papel

Comandos ›› Comandos do Objeto ECF ›› Relatorios ››

Comando : ECF.CortaPapel[(bCorteParcial)]

Realiza o corte parcial do papel.

Parâmetros:

bCorteParcial - Parâmetro Opcional. Se informado como True efetua corte parcial do papel no ECF para equipamentos com guilhotina.

Exemplos:

ECF.CortaPapel

ECF.CortaPapel(true)

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Fechar Relatorio / Vinculado

Comandos ›› Comandos do Objeto ECF ›› Relatorios ››

Comando : ECF.FechaRelatorio

Encerra a emissão de Cupom vinculado (CCD) e Relatório Gerencial (RG).

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Easily create EBooks


Leitura de Memoria Fiscal

Comandos ›› Comandos do Objeto ECF ›› Relatorios ››

Created with the Personal Edition of HelpNDoc: Generate Kindle eBooks with ease


Captura por N.ReducaoZ

Comandos ›› Comandos do Objeto ECF ›› Relatorios ›› Leitura de Memoria Fiscal ››

Comando : ECF.LeituraMemoriaFiscalSerial(nReducaoInicial , nReducaoFinal)

ou

Comando : ECF.LeituraMemoriaFiscalSerial(nReducaoInicial , nReducaoFinal, cNomeArquivo )

Captura os dados da Memória Fiscal pela serial e retorna os dados da leitura MFD entre as Reduções Z informadas no parâmetros. Se deseja retornar em arquivo, escolher o segundo comando informando o nome do arquivo.

Parâmetros:

nReducaoInicial - Redução Z inicial.

nReducaoFinal - Redução Z final.

cNomeArquivo - Nome do arquivo que será gerado a leitura da memória fiscal.

Exemplos:

ECF.LeituraMemoriaFiscalSerial(001000, 001000) - > Retorna em linhas.

ECF.LeituraMemoriaFiscalSerial(001000, 001000, "LeituraMFD.txt" ) -> Retorna em arquivo na pasta do ACBrmonitor.

Exemplo de Resposta:

OK: EPSON DO BRASIL

Avenida Tucunaré, 720 - Tamboré - Barueri - São Paulo

CNPJ: 52.106.911/0001-00

IE : 11111111111111111111

IM : 22222222222222222222

--------------------------------------------------------

20/12/2012 15:18:30 COO:001001

LEITURA MEMÓRIA FISCAL

REDUÇÃO: 1000 a 1000

Contador Geral de Operação Não-Fiscal: 000292

Contador de Reduções Z: 0080

Contador de Reinício de Operação: 001

Contador de Fita-Detalhe: 000000

REINÍCIO OPERAÇÃO

CRO DATA HORA CRO DATA HORA

001# 08/07/2011 11:28:33

IMPRESSÃO FITA-DETALHE

CFD DATA HORA COOi COOf

CNPJ

USUÁRIOS

Usuário:001 CRO:001 08/07/2011 11:28:33

CNPJ: 52.106.911/0001-00

IE : 11111111111111111111

IM : 22222222222222222222

GT : 76497,89

REDUÇõES DIÁRIAS

Usuário:001

CRZ CRO COO DATA HORA VENDA BRUTA DIÁRIA(R$)

DT = desconto ICMS DS = desconto ISSQN

AT = acréscimo ICMS AS = acréscimo ISSQN

CT = canc. ICMS CS = canc. ISSQN

ON = operação não-fiscal

--------------------------------------------------------

Total do período:

Venda Bruta(R$) 0,00

Número de Reduções Restantes: 3420

DADOS GERAIS

SOFTWARE BÁSICO

01.00.04 16/05/2011 10:14:07

MOEDA: R$ 08/07/2011 11:16:44

QUANTIDADE: 3 08/07/2011 11:16:41

VALOR UNITÁRIO: 2 08/07/2011 11:16:41

MFD: MFD0810000000000300

CODIFICAÇÃO GT:

a partir de 08/07/2011 11:16:41

0=7, 1=c, 2=j, 3=k, 4=w, 5=z, 6=m, 7=q, 8=5, 9=!

--------------------------------------------------------

EPSON TM-T81 FBIII

ECF-IF VERSÃO:01.00.04 ECF:001 LJ:0001

77777777777qmw!q5! 20/12/2012 15:18:33

FAB:EP081010000000000300 BR

EP081010000000000300MFD0810000000000300 ECF-IF EPSON TM-T81 FBIII 0100042012201215183300152106911000100MF ESP

000000041A008000AE4AED004E5EACCA910FC1B54AC9BB2C13B1C4CFF44DD6E8E2DECB8C19F123490E201583D4D2A10B67933A62F5B21BD073AF39E1943D95F5695E77DA58375161EED0D11B2107BE10BEF69DE97191E8957208E2718472F5ABBD9952C11E50310BE2885C2E9BCBB42D4C3C6EC6194CE0A0752293DD65E43B6CDA5FAEAD766DE877

Created with the Personal Edition of HelpNDoc: Easily create EBooks


Captura por Periodo

Comandos ›› Comandos do Objeto ECF ›› Relatorios ›› Leitura de Memoria Fiscal ››

Comando : ECF.LeituraMemoriaFiscalSerial( dDatIni, dDatFim )

ou

Comando : ECF.LeituraMemoriaFiscalSerial( dDatIni, dDatFim, cNomeArquivo )

Captura os dados da Memória Fiscal pela serial e retorna os dados da leitura MFD entre as Datas informadas no parâmetros. Se deseja retornar em arquivo, escolher o segundo comando informando o nome do arquivo.

Parâmetros:

dDatIni - Data Inicial. (dd/mm/aaaa)

dDatFim - Data final. (dd/mm/aaaa)

cNomeArquivo - Nome do arquivo que será gerado a leitura da memória fiscal.

Exemplos:

ECF.LeituraMemoriaFiscalSerial("20/12/2012", "20/12/2012") - > Retorna em linhas.

ECF.LeituraMemoriaFiscalSerial("20/12/2012", "20/12/2012", "LeituraMFDPeriodo.txt") -> Retorna em arquivo na pasta do ACBrmonitor.

Exemplo de Resposta:

OK: EPSON DO BRASIL

Avenida Tucunaré, 720 - Tamboré - Barueri - São Paulo

CNPJ: 52.106.911/0001-00

IE : 11111111111111111111

IM : 22222222222222222222

--------------------------------------------------------

20/12/2012 15:38:59 COO:001001

LEITURA MEMÓRIA FISCAL

DATA: 20/12/2012 a 20/12/2012

Contador Geral de Operação Não-Fiscal: 000292

Contador de Reduções Z: 0080

Contador de Reinício de Operação: 001

Contador de Fita-Detalhe: 000000

REINÍCIO OPERAÇÃO

CRO DATA HORA CRO DATA HORA

001# 08/07/2011 11:28:33

IMPRESSÃO FITA-DETALHE

CFD DATA HORA COOi COOf

CNPJ

USUÁRIOS

Usuário:001 CRO:001 08/07/2011 11:28:33

CNPJ: 52.106.911/0001-00

IE : 11111111111111111111

IM : 22222222222222222222

GT : 76497,89

REDUÇõES DIÁRIAS

Usuário:001

CRZ CRO COO DATA HORA VENDA BRUTA DIÁRIA(R$)

DT = desconto ICMS DS = desconto ISSQN

AT = acréscimo ICMS AS = acréscimo ISSQN

CT = canc. ICMS CS = canc. ISSQN

ON = operação não-fiscal

--------------------------------------------------------

0080 001 001000 20/12/2012 10:15:49 5150,88

DT=1234,04 AT=1,99 CT=587,26 T17,00%=195,28 F1=3079,62

I1=54,68

Total do mês DEZEMBRO de 2012:

Venda Bruta(R$) 5150,88

DT=1234,04 AT=1,99 CT=587,26 T17,00%=195,28 F1=3079,62

I1=54,68

Total do período:

Venda Bruta(R$) 5150,88

DT=1234,04 AT=1,99 CT=587,26 T17,00%=195,28 F1=3079,62

I1=54,68

Número de Reduções Restantes: 3420

DADOS GERAIS

SOFTWARE BÁSICO

01.00.04 16/05/2011 10:14:07

MOEDA: R$ 08/07/2011 11:16:44

QUANTIDADE: 3 08/07/2011 11:16:41

VALOR UNITÁRIO: 2 08/07/2011 11:16:41

MFD: MFD0810000000000300

CODIFICAÇÃO GT:

a partir de 08/07/2011 11:16:41

0=7, 1=c, 2=j, 3=k, 4=w, 5=z, 6=m, 7=q, 8=5, 9=!

--------------------------------------------------------

EPSON TM-T81 FBIII

ECF-IF VERSÃO:01.00.04 ECF:001 LJ:0001

77777777777qmw!q5! 20/12/2012 15:39:03

FAB:EP081010000000000300 BR

EP081010000000000300MFD0810000000000300 ECF-IF EPSON TM-T81 FBIII 0100042012201215390300152106911000100MF ESP

000000041A00800020F4417B79DFBEF4BC904DAC1F8D186A0E317FE3064253657DFC5AD385773F1D1DB64F876DD54CADE18B3B8F3FBA3986565E157C635232D84FDFEEB809C0A8A1D8854BFB95A5AAE7F09A2745C96E0D0524B697D1D6ED421586CFD5EBC83DA969E70624AA70154ADEFB1B4D4D0A9C9E1AB303D53EE93B39F9759F56398AB2B2AB

Created with the Personal Edition of HelpNDoc: Easily create EPub books


Imprime por N.ReducaoZ

Comandos ›› Comandos do Objeto ECF ›› Relatorios ›› Leitura de Memoria Fiscal ››

Comando : ECF.LeituraMemoriaFiscal( nReducaoInicial , nReducaoFinal )

Imprime na ECF a leitura da memória fiscal entre as Reduções Z informadas no parâmetros.

Parâmetros:

nReducaoInicial - Redução Z inicial.

nReducaoFinal - Redução Z final.

Exemplos:

ECF.LeituraMemoriaFiscal(001000, 001000)

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Generate EPub eBooks with ease


Imprime por Periodo

Comandos ›› Comandos do Objeto ECF ›› Relatorios ›› Leitura de Memoria Fiscal ››

Comando : ECF.LeituraMemoriaFiscal(dDatIni, dDatFim)

Imprime na ECF a leitura da memória fiscal entre as Datas informadas no parâmetros.

Parâmetros:

dDatIni - Data Inicial. (dd/mm/aaaa)

dDatFim - Data final. (dd/mm/aaaa)

Exemplos:

ECF.LeituraMemoriaFiscal("20/12/2012", "20/12/2012")

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Easily create EBooks


Leitura X Serial

Comandos ›› Comandos do Objeto ECF ›› Relatorios ››

Comando : ECF.LeituraXSerial

ou

Comando : ECF.LeituraXSerial( cNomeArquivo )

Recebe os dados da Leitura X pela serial e retorna a leitura X. Se deseja retornar em arquivo, escolher o segundo comando informando o nome do arquivo.

Parâmetros:

cNomeArquivo - Nome do arquivo que será gerado a leitura X.

Exemplos:

ECF.LeituraXSerial - > Retorna em linhas.

ECF.LeituraXSerial("LeituraX.txt") -> Retorna em arquivo na pasta do ACBrmonitor.

Exemplo de Resposta:

OK: EPSON DO BRASIL

Avenida Tucunaré, 720 - Tamboré - Barueri - São Paulo

CNPJ: 52.106.911/0001-00

IE : 11111111111111111111

IM : 22222222222222222222

--------------------------------------------------------

20/12/2012 10:43:32 COO:001000

LEITURA X

CONTADORES

Geral de Operação Não-Fiscal: 000292

Contador de Reinício de Operação: 001

Contador de Reduções Z: 0080

Contador de Cupom Fiscal: 000464

Contador de Fita-Detalhe: 000000

Comprovante de Crédito ou Débito: 0000

Geral de Relatório Gerencial: 000188

Geral Oper. Não-Fiscal Canc.: 0000

Cupom Fiscal Cancelado: 0000

TOTALIZADORES

TOTALIZADOR GERAL: 76497,89

VENDA BRUTA DIÁRIA: 0,00

CANCELAMENTO ICMS: 0,00

DESCONTO ICMS: 0,00

Total de ISSQN: 0,00

CANCELAMENTO ISSQN: 0,00

DESCONTO ISSQN: 0,00

-----------------

VENDA LÍQUIDA: 0,00

ACRÉSCIMO ICMS: 0,00

ACRÉSCIMO ISSQN: 0,00

ICMS

Totalizador Base Cálculo(R$) Imposto(R$)

T18,00% 0,00 0,00

T07,00% 0,00 0,00

T12,00% 0,00 0,00

T25,00% 0,00 0,00

T17,00% 0,00 0,00

--------------------------------------

Total ICMS: 0,00 0,00

Não Tributados Valor Acumulado(R$)

F1 = 0,00

I1 = 0,00

N1 = 0,00

ISSQN

Totalizador Base Cálculo(R$) Imposto(R$)

S02,50% 0,00 0,00

S05,00% 0,00 0,00

S15,00% 0,00 0,00

--------------------------------------

Total ISSQN: 0,00 0,00

Não Tributados Valor Acumulado(R$)

FS1 = 0,00

IS1 = 0,00

NS1 = 0,00

TOTALIZADORES NÃO FISCAIS

Nº Operação CON Valor Acumulado(R$)

1 Sangria 0000 0,00

2 Fundo de Troco 0000 0,00

3 recebimento 0000 0,00

4 estorno 0000 0,00

5 DIVERSOS 0000 0,00

6 SUPRIMENTO 0000 0,00

-----------------

Total Oper Não-Fiscais 0,00

ACRE NÃO-FISC 0,00

DESC NÃO-FISC 0,00

CANC NÃO-FISC 0,00

RELATÓRIO GERENCIAL

Nº Relatório CER

1 Configuração 0000

2 TEF 0000

3 MOV.CAIXA 0000

4 ENTREGA 0000

5 DAV 0000

6 DAVS EMIT. 0000

7 MEIOS PAGTO 0000

8 IDENT.PAF 0000

9 DIVERSOS 0000

10 PARAM.CONFIG. 0000

MEIOS DE PAGAMENTO

Nº Meio Pagamento Valor Acumulado(R$)

1 Dinheiro 0,00

2 CARTAO (V) 0,00

3 CHEQUE (V) 0,00

4 VALE CREDITO (V) 0,00

5 A PRAZO (V) 0,00

6 TEF (V) 0,00

7 TICKET (V) 0,00

TROCO 0,00

Comprovante Não Emitido: 0000

Tempo Emitindo Doc. Fiscal: 00:00:00

Tempo Operacional: 00:00:00

Qtd. Reduções Restantes: 3420

Número série MFD: MFD0810000000000300

--------------------------------------------------------

EPSON TM-T81 FBIII

ECF-IF VERSÃO:01.00.04 ECF:001 LJ:0001

77777777777qmw!q5! 20/12/2012 10:43:35

FAB:EP081010000000000300 BR

EP081010000000000300MFD0810000000000300 ECF-IF EPSON TM-T81 FBIII 0100042012201210433500152106911000100LX ESP

000000041A008000C7429298F6CBD5C65F6F1324078E112966A179A316954CFA6E0C73AE9A4B0ABF8AFB0B6E244A6280961BD4C5218384B9C388D2EF2FF07D22BE21754B3153D7D13AD2FE035C1E51865B1E4A7C71303C83CC25AFA3223D66CE4F00BFA908C2974149343161EAE17B5A02B7A4B45A37C05C97E92433F93F9249D3CC5346B1149AA7

Created with the Personal Edition of HelpNDoc: Generate Kindle eBooks with ease


Leitura MFD Serial

Comandos ›› Comandos do Objeto ECF ›› Relatorios ››

Created with the Personal Edition of HelpNDoc: Full-featured Help generator


Por COO

Comandos ›› Comandos do Objeto ECF ›› Relatorios ›› Leitura MFD Serial ››

Comando : ECF.LeituraMFDSerial( nCOOInicial, nCOOFinal )

ou

Comando : ECF.LeituraMFDSerial( nCOOInicial, nCOOFinal, cNomeArquivo )

Recebe os dados da Leitura MFD pela serial e retorna todos os documentos emitidos pelo ECF dentro o número de COO inicial e COO final informado em parâmetros. Se deseja retornar em arquivo, escolher o segundo comando informando o nome do arquivo.

Parâmetros:

nCOOInicial - Número de COO inicial do filtro.

nCOOFinal - Número de COO final do filtro.

cNomeArquivo - Nome do arquivo que será gerado a leitura da memória fiscal.

Exemplos:

ECF.LeituraMFDSerial(000070,000072) - > Retorna em linhas

ECF.LeituraMFDSerial(000070,000072,"LeituraMFD2.txt") -> Retorna em arquivo na pasta do ACBrmonitor.

Nota: Comando disponível apenas para Bematech, Daruma, Fiscnet, Sweda e SwedaSTX.

Exemplo de Resposta:

OK: REINÍCIO DE OPERAÇÃO

(CRO: 003 25/08/2009 14:04:10)

S W E D A

Rua Dona Brígida, 713

Vila Mariana - São Paulo - SP

CNPJ: 53.485.215/0001-06

IE: 111.072.115.110

IM: 111.111.111.111

SIMULADOR SWEDA CONNECT/SIM

FITA-DETALHE

Emissão: 20/12/2012 13:38:12 COOi=000070 COOf=000072

--------------------------------------------------------

25/08/2009 14:04:11 COO:000070

LEITURA X

SAIDA DE INTERVENÇÃO

----------------------- CONTADORES ---------------------

Geral de Operação Não-Fiscal: 000000

Contador de Reinício de Operação: 003

Contador de Reduções Z: 0006

Contador de Cupom Fiscal: 000043

Contador de Fita-Detalhe: 000000

Comprovante de Crédito ou Débito: 0000

Geral de Relatório Gerencial: 000005

Geral Oper. Não-Fiscal Canc.: 0000

Cupom Fiscal Cancelado: 0000

--------------------- TOTALIZADORES --------------------

TOTALIZADOR GERAL: 21.288,00

VENDA BRUTA DIÁRIA: 0,00

CANCELAMENTO ICMS: 0,00

DESCONTO ICMS: 0,00

Total de ISSQN: 0,00

CANCELAMENTO ISSQN: 0,00

DESCONTO ISSQN: 0,00

------------------

VENDA LÍQUIDA: 0,00

ACRÉSCIMO ICMS: 0,00

ACRÉSCIMO ISSQN: 0,00

-------------------------- ICMS ------------------------

Totalizador Base Cálculo(R$) Imposto(R$)

T17,00% 0,00 0,00

T05,00% 0,00 0,00

T07,00% 0,00 0,00

T10,00% 0,00 0,00

T12,00% 0,00 0,00

------------------- ------------------

Total ICMS: 0,00 0,00

Não Tributados Valor Acumulado(R$)

F1 = 0,00

I1 = 0,00

N1 = 0,00

------------------------- ISSQN ------------------------

Totalizador Base Cálculo(R$) Imposto(R$)

S01,00% 0,00 0,00

S10,00% 0,00 0,00

S05,00% 0,00 0,00

S15,00% 0,00 0,00

------------------- ------------------

Total ISSQN: 0,00 0,00

Não Tributados Valor Acumulado(R$)

FS1 = 0,00

IS1 = 0,00

NS1 = 0,00

--------------- TOTALIZADORES NÃO FISCAIS --------------

Nº Operação CON Valor Acumulado(R$)

01 Sangria (-) 0000 0,00

02 Numerário (-) 0000 0,00

03 Boletos 0000 0,00

04 Carnês 0000 0,00

05 Consumo 0000 0,00

------------------

Total Oper Não Fiscais: 0,00

ACRE NÃO-FISC: 0,00

DESC NÃO-FISC: 0,00

CANC NÃO-FISC: 0,00

------------------ RELATÓRIO GERENCIAL -----------------

Nº Relatório CER

01 PARÂMETROS ECF 0000

02 Fechamento 0000

03 Resumo Vendas 0000

04 Devolução 0000

05 Trocas 0000

06 Saida Op. 0000

07 Entrada Op. 0000

------------------- MEIOS DE PAGAMENTO -----------------

Nº Meio Pagamento Valor Acumulado(R$)

01 Dinheiro 0,00

02 C. Débito (V) 0,00

03 C. Crédito (V) 0,00

04 Cheque 0,00

05 Ticket 0,00

06 Contra-Vale 0,00

07 Outro 0,00

TROCO: 0,00

--------------------------------------------------------

Comprovante Não Emitido: 0000

Tempo Emitindo Doc. Fiscal: 00:00:00

Tempo Operacional: 00:00:01

Qtd. Reduções Restantes: 3.687

Número série MFD: MFDSW00000000001

--------------------------------------------------------

SWEDA IF ST200

ECF-IF VERSÃO: 01.00.01 ECF: 001

ARA##VV 25/08/2009 14:04:12

FAB: 00000000000000000001 BR

S W E D A

Rua Dona Brígida, 713

Vila Mariana - São Paulo - SP

CNPJ: 53.485.215/0001-06

IE: 111.072.115.110

IM: 111.111.111.111

SIMULADOR SWEDA CONNECT/SIM

FITA-DETALHE

Emissão: 20/12/2012 13:38:12 COOi=000070 COOf=000072

--------------------------------------------------------

25/08/2009 14:04:13 GNF:000000 COO:000071

GRG:000006 CER:0001

NÃO É DOCUMENTO FISCAL

RELATÓRIO GERENCIAL

PARÂMETROS ECF

SÍMBOLO DA MOEDA: R$

IMPRIMIR CENTAVOS: SIM

CASAS DECIMAIS PARA VALOR UNITÁRIO: 3

CASAS DECIMAIS PARA QUANTIDADE: 3

IMPRESSÃO DE CASAS DECIMAIS NÃO-SIGNIFICATIVAS

VALOR UNITÁRIO: DESABILITADA

QUANTIDADE COMERCIALIZADA: DESABILITADA

DESCONTO DE ISSQN: HABILITADO

NÃO É DOCUMENTO FISCAL

ECF: 001

LOJA: (NÃO PROGRAMADO)

TOTALIZADORES ICMS

T17,00%

T05,00%

T07,00%

T10,00%

T12,00%

NÃO É DOCUMENTO FISCAL

TOTALIZADORES ISSQN

S01,00%

S10,00%

S05,00%

S15,00%

NÃO-TRIBUTADOS

F1

I1

N1

NÃO É DOCUMENTO FISCAL

FS1

IS1

NS1

MEIOS DE PAGAMENTO

01 Dinheiro MOEDA

02 C. Débito CDC

03 C. Crédito CDC

04 Cheque CHEQUE

05 Ticket TICKET/CONTRA-VALE

NÃO É DOCUMENTO FISCAL

06 Contra-Vale TICKET/CONTRA-VALE

07 Outro

TOTALIZADORES NÃO FISCAIS

01 Sangria (-)

02 Numerário (-)

03 Boletos

04 Carnês

05 Consumo

NÃO É DOCUMENTO FISCAL

RELATÓRIOS GERENCIAIS

01 PARÂMETROS ECF

02 Fechamento

03 Resumo Vendas

04 Devolução

05 Trocas

06 Saida Op.

07 Entrada Op.

CARACTERES DE CODIFICAÇÃO DO GT

NÃO É DOCUMENTO FISCAL

0=V, 1=R, 2=A, 3=Y, 4=&, 5=Z, 6=O, 7=E, 8=#, 9=I

--------------------------------------------------------

SWEDA IF ST200

ECF-IF VERSÃO: 01.00.01 ECF: 001

ARA##VV 25/08/2009 14:04:13

FAB: 00000000000000000001

S W E D A

Rua Dona Brígida, 713

Vila Mariana - São Paulo - SP

CNPJ: 53.485.215/0001-06

IE: 111.072.115.110

IM: 111.111.111.111

SIMULADOR SWEDA CONNECT/SIM

FITA-DETALHE

Emissão: 20/12/2012 13:38:12 COOi=000070 COOf=000072

--------------------------------------------------------

25/08/2009 14:05:40 COO:000072

LEITURA X

ENTRADA EM INTERVENÇÃO

----------------------- CONTADORES ---------------------

Geral de Operação Não-Fiscal: 000000

Contador de Reinício de Operação: 003

Contador de Reduções Z: 0006

Contador de Cupom Fiscal: 000043

Contador de Fita-Detalhe: 000000

Comprovante de Crédito ou Débito: 0000

Geral de Relatório Gerencial: 000006

Geral Oper. Não-Fiscal Canc.: 0000

Cupom Fiscal Cancelado: 0000

--------------------- TOTALIZADORES --------------------

TOTALIZADOR GERAL: 21.288,00

VENDA BRUTA DIÁRIA: 0,00

CANCELAMENTO ICMS: 0,00

DESCONTO ICMS: 0,00

Total de ISSQN: 0,00

CANCELAMENTO ISSQN: 0,00

DESCONTO ISSQN: 0,00

------------------

VENDA LÍQUIDA: 0,00

ACRÉSCIMO ICMS: 0,00

ACRÉSCIMO ISSQN: 0,00

-------------------------- ICMS ------------------------

Totalizador Base Cálculo(R$) Imposto(R$)

T17,00% 0,00 0,00

T05,00% 0,00 0,00

T07,00% 0,00 0,00

T10,00% 0,00 0,00

T12,00% 0,00 0,00

------------------- ------------------

Total ICMS: 0,00 0,00

Não Tributados Valor Acumulado(R$)

F1 = 0,00

I1 = 0,00

N1 = 0,00

------------------------- ISSQN ------------------------

Totalizador Base Cálculo(R$) Imposto(R$)

S01,00% 0,00 0,00

S10,00% 0,00 0,00

S05,00% 0,00 0,00

S15,00% 0,00 0,00

------------------- ------------------

Total ISSQN: 0,00 0,00

Não Tributados Valor Acumulado(R$)

FS1 = 0,00

IS1 = 0,00

NS1 = 0,00

--------------- TOTALIZADORES NÃO FISCAIS --------------

Nº Operação CON Valor Acumulado(R$)

01 Sangria (-) 0000 0,00

02 Numerário (-) 0000 0,00

03 Boletos 0000 0,00

04 Carnês 0000 0,00

05 Consumo 0000 0,00

------------------

Total Oper Não Fiscais: 0,00

ACRE NÃO-FISC: 0,00

DESC NÃO-FISC: 0,00

CANC NÃO-FISC: 0,00

------------------ RELATÓRIO GERENCIAL -----------------

Nº Relatório CER

01 PARÂMETROS ECF 0001

02 Fechamento 0000

03 Resumo Vendas 0000

04 Devolução 0000

05 Trocas 0000

06 Saida Op. 0000

07 Entrada Op. 0000

------------------- MEIOS DE PAGAMENTO -----------------

Nº Meio Pagamento Valor Acumulado(R$)

01 Dinheiro 0,00

02 C. Débito (V) 0,00

03 C. Crédito (V) 0,00

04 Cheque 0,00

05 Ticket 0,00

06 Contra-Vale 0,00

07 Outro 0,00

TROCO: 0,00

--------------------------------------------------------

Comprovante Não Emitido: 0000

Tempo Emitindo Doc. Fiscal: 00:00:00

Tempo Operacional: 00:00:03

Qtd. Reduções Restantes: 3.687

Número série MFD: MFDSW00000000001

--------------------------------------------------------

SWEDA IF ST200

ECF-IF VERSÃO: 01.00.01 ECF: 001

ARA##VV 25/08/2009 14:05:41

FAB: 00000000000000000001 BR

Created with the Personal Edition of HelpNDoc: Full-featured multi-format Help generator


Por Periodo

Comandos ›› Comandos do Objeto ECF ›› Relatorios ›› Leitura MFD Serial ››

Comando : ECF.LeituraMFDSerial( dDataInicial, dDataFinal )

ou

Comando : ECF.LeituraMFDSerial( dDataInicial, dDataFinal, cNomeArquivo )

Recebe os dados da Leitura MFD pela serial e retorna todos os documentos emitidos pelo ECF dentre as datas informadas em parâmetros. Se deseja retornar em arquivo, escolher o segundo comando informando o nome do arquivo.

Parâmetros:

dDataInicial - Data inicial do filtro. (dd/mm/aaaa)

dDataFinal - Data final do filtro. (dd/mm/aaaa)

cNomeArquivo - Nome do arquivo que será gerado a leitura da memória fiscal.

Exemplos:

ECF.LeituraMFDSerial( "10/12/2012", "20/12/2012" ) - > Retorna em linhas

ECF.LeituraMFDSerial( "10/12/2012", "20/12/2012", "LeituraMFD3.txt") -> Retorna em arquivo na pasta do ACBrmonitor )

Nota: Comando disponível apenas para Bematech, Daruma, Fiscnet, Sweda e SwedaSTX.

Exemplo de Resposta:

OK: LMF

(COO:000082 18/12/2012 16:09:03)

S W E D A

Rua Dona Brígida, 713

Vila Mariana - São Paulo - SP

CNPJ: 53.485.215/0001-06

IE: 111.072.115.110

IM: 111.111.111.111

SIMULADOR SWEDA CONNECT/SIM

FITA-DETALHE

Emissão: 20/12/2012 13:43:36

DATAi=10/12/2012 DATAf=20/12/2012

--------------------------------------------------------

18/12/2012 16:09:04 CCF:000045 COO:000083

CUPOM FISCAL

ITEM CÓDIGO DESCRIÇÃO

QTD. UN. VL UNIT(R$) ST VL ITEM(R$)

1 001 TESTES 1 UN F1 10,00

------------------

TOTAL R$ 10,00

Dinheiro 10,00

OBRIGADO, VOLTE SEMPRE

MD-5:F98F867ADEB5D3FA78E8B41AEFBCE912

DJPDV 1.2.1

--------------------------------------------------------

oV1#gcJNPTrkp4nJ31CXyT6mU(an8N8d2en?xC5NN(4ZfGcY#6?2C

SWEDA IF ST200

ECF-IF VERSÃO: 01.00.01 ECF: 001

ARAI#RO 18/12/2012 16:09:08

FAB: 00000000000000000001 BR

S W E D A

Rua Dona Brígida, 713

Vila Mariana - São Paulo - SP

CNPJ: 53.485.215/0001-06

IE: 111.072.115.110

IM: 111.111.111.111

SIMULADOR SWEDA CONNECT/SIM

FITA-DETALHE

Emissão: 20/12/2012 13:43:36

DATAi=10/12/2012 DATAf=20/12/2012

--------------------------------------------------------

20/12/2012 12:59:46 COO:000084

REDUÇÃO Z

MOVIMENTO DO DIA: 18/12/2012

----------------------- CONTADORES ---------------------

Geral de Operação Não-Fiscal: 000000

Contador de Reinício de Operação: 004

Contador de Reduções Z: 0008

Contador de Cupom Fiscal: 000045

Contador de Fita-Detalhe: 000000

Comprovante de Crédito ou Débito: 0000

Geral de Relatório Gerencial: 000007

Geral Oper. Não-Fiscal Canc.: 0000

Cupom Fiscal Cancelado: 0000

--------------------- TOTALIZADORES --------------------

TOTALIZADOR GERAL: 21.298,16

VENDA BRUTA DIÁRIA: 10,00

CANCELAMENTO ICMS: 0,00

DESCONTO ICMS: 0,00

Total de ISSQN: 0,00

CANCELAMENTO ISSQN: 0,00

DESCONTO ISSQN: 0,00

------------------

VENDA LÍQUIDA: 10,00

ACRÉSCIMO ICMS: 0,00

ACRÉSCIMO ISSQN: 0,00

-------------------------- ICMS ------------------------

Totalizador Base Cálculo(R$) Imposto(R$)

T17,00% 0,00 0,00

T05,00% 0,00 0,00

T07,00% 0,00 0,00

T10,00% 0,00 0,00

T12,00% 0,00 0,00

------------------- ------------------

Total ICMS: 0,00 0,00

Não Tributados Valor Acumulado(R$)

F1 = 10,00

I1 = 0,00

N1 = 0,00

------------------------- ISSQN ------------------------

Totalizador Base Cálculo(R$) Imposto(R$)

S01,00% 0,00 0,00

S10,00% 0,00 0,00

S05,00% 0,00 0,00

S15,00% 0,00 0,00

------------------- ------------------

Total ISSQN: 0,00 0,00

Não Tributados Valor Acumulado(R$)

FS1 = 0,00

IS1 = 0,00

NS1 = 0,00

--------------- TOTALIZADORES NÃO FISCAIS --------------

Nº Operação CON Valor Acumulado(R$)

01 Sangria (-) 0000 0,00

02 Numerário (-) 0000 0,00

03 Boletos 0000 0,00

04 Carnês 0000 0,00

05 Consumo 0000 0,00

06 DIVERSOS 0000 0,00

07 RECEBIMENTO 0000 0,00

------------------

Total Oper Não Fiscais: 0,00

ACRE NÃO-FISC: 0,00

DESC NÃO-FISC: 0,00

CANC NÃO-FISC: 0,00

------------------ RELATÓRIO GERENCIAL -----------------

Nº Relatório CER

01 PARÂMETROS ECF 0000

02 Fechamento 0000

03 Resumo Vendas 0000

04 Devolução 0000

05 Trocas 0000

06 Saida Op. 0000

07 Entrada Op. 0000

08 MOV.CAIXA 0000

09 ENTREGA 0000

10 TEF 0000

11 DAV 0000

12 DAVS EMIT. 0000

13 MEIOS PAGTO 0000

14 IDENT.PAF 0000

15 DIVERSOS 0000

16 PARAM.CONFIG. 0000

------------------- MEIOS DE PAGAMENTO -----------------

Nº Meio Pagamento Valor Acumulado(R$)

01 Dinheiro 10,00

02 C. Débito (V) 0,00

03 C. Crédito (V) 0,00

04 Cheque 0,00

05 Ticket 0,00

06 Contra-Vale 0,00

07 Outro 0,00

08 CARTAO (V) 0,00

09 VALE CREDITO (V) 0,00

10 A PRAZO (V) 0,00

TROCO: 0,00

--------------------------------------------------------

Comprovante Não Emitido: 0000

Tempo Emitindo Doc. Fiscal: 00:00:05

Tempo Operacional: 00:00:07

Qtd. Reduções Restantes: 3.685

Número série MFD: MFDSW00000000001

--------------------------------------------------------

3sfDRwM92zXRi68WZDFFsj7*R@qSsmnkEV4W7F3Cc@n

SWEDA IF ST200

ECF-IF VERSÃO: 01.00.01 ECF: 001

ARAI#RO 20/12/2012 12:59:46

FAB: 00000000000000000001 BR

S W E D A

Rua Dona Brígida, 713

Vila Mariana - São Paulo - SP

CNPJ: 53.485.215/0001-06

IE: 111.072.115.110

IM: 111.111.111.111

SIMULADOR SWEDA CONNECT/SIM

FITA-DETALHE

Emissão: 20/12/2012 13:43:36

DATAi=10/12/2012 DATAf=20/12/2012

--------------------------------------------------------

20/12/2012 13:37:33 COO:000085

LEITURA X

----------------------- CONTADORES ---------------------

Geral de Operação Não-Fiscal: 000000

Contador de Reinício de Operação: 004

Contador de Reduções Z: 0008

Contador de Cupom Fiscal: 000045

Contador de Fita-Detalhe: 000000

Comprovante de Crédito ou Débito: 0000

Geral de Relatório Gerencial: 000007

Geral Oper. Não-Fiscal Canc.: 0000

Cupom Fiscal Cancelado: 0000

--------------------- TOTALIZADORES --------------------

TOTALIZADOR GERAL: 21.298,16

VENDA BRUTA DIÁRIA: 0,00

CANCELAMENTO ICMS: 0,00

DESCONTO ICMS: 0,00

Total de ISSQN: 0,00

CANCELAMENTO ISSQN: 0,00

DESCONTO ISSQN: 0,00

------------------

VENDA LÍQUIDA: 0,00

ACRÉSCIMO ICMS: 0,00

ACRÉSCIMO ISSQN: 0,00

-------------------------- ICMS ------------------------

Totalizador Base Cálculo(R$) Imposto(R$)

T17,00% 0,00 0,00

T05,00% 0,00 0,00

T07,00% 0,00 0,00

T10,00% 0,00 0,00

T12,00% 0,00 0,00

------------------- ------------------

Total ICMS: 0,00 0,00

Não Tributados Valor Acumulado(R$)

F1 = 0,00

I1 = 0,00

N1 = 0,00

------------------------- ISSQN ------------------------

Totalizador Base Cálculo(R$) Imposto(R$)

S01,00% 0,00 0,00

S10,00% 0,00 0,00

S05,00% 0,00 0,00

S15,00% 0,00 0,00

------------------- ------------------

Total ISSQN: 0,00 0,00

Não Tributados Valor Acumulado(R$)

FS1 = 0,00

IS1 = 0,00

NS1 = 0,00

--------------- TOTALIZADORES NÃO FISCAIS --------------

Nº Operação CON Valor Acumulado(R$)

01 Sangria (-) 0000 0,00

02 Numerário (-) 0000 0,00

03 Boletos 0000 0,00

04 Carnês 0000 0,00

05 Consumo 0000 0,00

06 DIVERSOS 0000 0,00

07 RECEBIMENTO 0000 0,00

------------------

Total Oper Não Fiscais: 0,00

ACRE NÃO-FISC: 0,00

DESC NÃO-FISC: 0,00

CANC NÃO-FISC: 0,00

------------------ RELATÓRIO GERENCIAL -----------------

Nº Relatório CER

01 PARÂMETROS ECF 0000

02 Fechamento 0000

03 Resumo Vendas 0000

04 Devolução 0000

05 Trocas 0000

06 Saida Op. 0000

07 Entrada Op. 0000

08 MOV.CAIXA 0000

09 ENTREGA 0000

10 TEF 0000

11 DAV 0000

12 DAVS EMIT. 0000

13 MEIOS PAGTO 0000

14 IDENT.PAF 0000

15 DIVERSOS 0000

16 PARAM.CONFIG. 0000

------------------- MEIOS DE PAGAMENTO -----------------

Nº Meio Pagamento Valor Acumulado(R$)

01 Dinheiro 0,00

02 C. Débito (V) 0,00

03 C. Crédito (V) 0,00

04 Cheque 0,00

05 Ticket 0,00

06 Contra-Vale 0,00

07 Outro 0,00

08 CARTAO (V) 0,00

09 VALE CREDITO (V) 0,00

10 A PRAZO (V) 0,00

TROCO: 0,00

--------------------------------------------------------

Comprovante Não Emitido: 0000

Tempo Emitindo Doc. Fiscal: 00:00:00

Tempo Operacional: 00:37:47

Qtd. Reduções Restantes: 3.685

Número série MFD: MFDSW00000000001

--------------------------------------------------------

SWEDA IF ST200

ECF-IF VERSÃO: 01.00.01 ECF: 001

ARAI#RO 20/12/2012 13:37:33

FAB: 00000000000000000001 BR

Created with the Personal Edition of HelpNDoc: Easy EPub and documentation editor


Espelho MFD DLL

Comandos ›› Comandos do Objeto ECF ›› Relatorios ››

Created with the Personal Edition of HelpNDoc: News and information about help authoring tools and software


Por COO

Comandos ›› Comandos do Objeto ECF ›› Relatorios ›› Espelho MFD DLL ››

Comando : ECF.EspelhoMFD_DLL( nCOOInicial, nCOOFinal, cNomeArquivo )

Recebe os dados da MFD pela DLL gerando um arquivo do espelho de todos os documentos emitidos pelo ECF, dentre o número de COO inicial e COO final informado em parâmetros.

Parâmetros:

nCOOInicial - Número de COO inicial do filtro.

nCOOFinal - Número de COO final do filtro.

cNomeArquivo - Nome do arquivo onde será gerado o espelho.

Exemplos:

ECF.EspelhoMFD_DLL( 001002, 001002, "C:\temp\ACBr_Esp.txt" )

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


Por Periodo

Comandos ›› Comandos do Objeto ECF ›› Relatorios ›› Espelho MFD DLL ››

Comando : ECF.EspelhoMFD_DLL( dDataInicial, dDataFinal, cNomeArquivo )

Recebe os dados da MFD pela DLL gerando um arquivo do espelho de todos os documentos emitidos pelo ECF, dentre as datas informadas em parâmetros.

Parâmetros:

dDataInicial - Data inicial do filtro. (dd/mm/aaaa)

dDataFinal - Data final do filtro. (dd/mm/aaaa)

cNomeArquivo - Nome do arquivo onde será gerado o espelho.

Exemplos:

ECF.EspelhoMFD_DLL( "20/12/2012", "20/12/2012", "C:\temp\ACBr_Esp.txt" )

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Easy CHM and documentation editor


Arquivo MFD DLL

Comandos ›› Comandos do Objeto ECF ›› Relatorios ››

Created with the Personal Edition of HelpNDoc: Free EBook and documentation generator


Por COO

Comandos ›› Comandos do Objeto ECF ›› Relatorios ›› Arquivo MFD DLL ››

Comando : ECF.ArquivoMFD_DLL(nCOOIni, nCOOFim, Arquivo, [nTipoDoc], [nFinalidade])

Recebe os dados MFD pela DLL gerando um arquivo do MFD de todos os documentos emitidos pelo ECF, dentre o número de COO inicial e COO final informado em parâmetros.

Parâmetros:

nCOOInicial - Número de COO inicial do filtro.

nCOOFinal - Número de COO final do filtro.

cNomeArquivo - Nome do arquivo onde será gerado o espelho.

nTipoDoc - Númerico ou Tipo, que descreve o tipo do documento que deve ser gerado.

caso não informado assum "18 ou docTodos"

0 ou docRZ

1 ou docLX,

2 ou docCF,

3 ou docCFBP,

4 ou docCupomAdicional,

5 ou docCFCancelamento,

6 ou docCCD,

7 ou docAdicionalCCD,

8 ou docSegViaCCD,

9 ou docReimpressaoCCD,

10 ou docEstornoCCD,

11 ou docCNF,

12 ou docCNFCancelamento,

13 ou docSangria,

14 ou docSuprimento,

15 ou docEstornoPagto,

16 ou docRG,

17 ou docLMF,

18 ou docTodos,

19 ou docNenhum

nFinalidade - Numérico ou Tipo, que descreve a finalidade do arquivo, o que pode determinar os registros que serão incluidos no mesmo. Se não for informado assume "2 ou finMFD"

0 ou finMF

1 ou finMFD

2 ou finTDM

3 ou finRZ

4 ou finRFD

5 ou finNFP

6 ou finNFPTDM

7 ou finSintegra

8 ou finSPED

Exemplos:

ECF.ArquivoMFD_DLL( 001002, 001005, "C:\temp\ACBr_Esp.txt" )

ECF.ArquivoMFD_DLL( 001002, 001005, "C:\temp\ACBr_Esp.txt", 18, 3 )

ECF.ArquivoMFD_DLL( 001002, 001005, "C:\temp\ACBr_Esp.txt", docLMF, finRFD )

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Free Kindle producer


Por Periodo

Comandos ›› Comandos do Objeto ECF ›› Relatorios ›› Arquivo MFD DLL ››

Comando : ECF.ArquivoMFD_DLL( dDataInicial, dDataFinal, cNomeArquivo [, nFinalidade])

Recebe os dados da MFD pela DLL gerando um arquivo da MFD de todos os documentos emitidos pelo ECF, dentre as datas informadas em parâmetros.

Parâmetros:

dDataInicial - Data inicial do filtro. (dd/mm/aaaa)

dDataFinal - Data final do filtro. (dd/mm/aaaa)

cNomeArquivo - Nome do arquivo onde será gerado o espelho.

nFinalidade - Numérico, que descreve a finalidade do arquivo, o que pode determinar os registros que serão incluidos no mesmo.

Se não for informado assume "2 ou finMFD"

1 ou finMF

2 ou finMFD

3 ou finTDM

4 ou finRZ

5 ou finRFD

6 ou finNFP

7 ou finNFPTDM

8 ou finSintegra

9 ou finSPED

Exemplos:

ECF.ArquivoMFD_DLL( "20/12/2012", "20/12/2012", "C:\temp\ACBr_Esp.txt" )

ECF.ArquivoMFD_DLL( "20/12/2012", "20/12/2012", "C:\temp\ACBr_Esp.txt", 3 )

ECF.ArquivoMFD_DLL( "20/12/2012", "20/12/2012", "C:\temp\ACBr_Esp.txt", finRFD )

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Free EPub and documentation generator


Cupom Fiscal

Comandos ›› Comandos do Objeto ECF ››

Created with the Personal Edition of HelpNDoc: Free Kindle producer


Testa Pode Abrir Cupom

Comandos ›› Comandos do Objeto ECF ›› Cupom Fiscal ››

Comando : ECF.TestaPodeAbrirCupom

Realiza o teste com o estado da ECF se está livre para emissão de Cupom Fiscal. Retornando OK se estado é livre ou ERRO juntamente com o motivo.

Exemplo de Resposta:

OK:

ERRO: Estado da impressora SwedaSTX

estRelatorio (não é Livre)

Created with the Personal Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Identifica Consumidor

Comandos ›› Comandos do Objeto ECF ›› Cupom Fiscal ››

Comando : ECF.IdentificaConsumidor ( cCPF_CNPJ, [cNOME, cENDERECO])

O Método Identifica Consumidor, se for usado antes da abertura do cupom, os dados do consumidor serão usados no comando de AbreCupom, caso seja usado após o abre cupom, se o ECF não for MFD, os dados serão impressos nas linhas de mensagens do cupom.

Parâmetros:

cCPF_CNPJ - CPF/CNPJ do Consumidro

cNOME - Parâmetro opcional. Nome do Consumidor

cENDERECO - Parâmetro opcional. Endereço do Consumidor

Exemplos:

ECF.IdentificaConsumidor ( "47.508.411/0001-56" )

ECF.IdentificaConsumidor ( "47.508.411/0001-56", "Distribuidora de Alimentos" )

ECF.IdentificaConsumidor ( "47.508.411/0001-56", "Distribuidora de Alimentos", "Rua Marechal Deodoro - 6" )

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: iPhone web sites made easy


Abre Cupom

Comandos ›› Comandos do Objeto ECF ›› Cupom Fiscal ››

Comando : ECF.AbreCupom [ ( cCPF_CNPJ, cNOME, cENDERECO) ]

Realiza a abertura do Cupom Fiscal.

Parâmetros:

cCPF_CNPJ - Parâmetro opcional. Se necessário, informe o CPF/CNPJ do Consumidor

cNOME -Parâmetro opcional. Se necessário, informe o NOME do Consumidor

cENDERECO -Parâmetro opcional. Se necessário, informe o ENDEREÇO do Consumidor

Exemplos:

ECF.AbreCupom

ECF.AbreCupom("1234567890","ACBr","Tatui")

Nota: Nem todos os modelos de ECF fazem uso do parâmetro cCPF_CNPJ, nesse caso o Cupom será aberto, porém o número de identificação do cliente não será impresso. Dica: Para identificar o cliente prefira usar o Rodapé do Cupom, que permite até 8 linhas de texto livre.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: What is a Help Authoring tool?


Legenda InMetro Proximo Item

Comandos ›› Comandos do Objeto ECF ›› Cupom Fiscal ››

Comando : ECF.LegendaInMetroProximoItem

Habilita a Legenda InMetro para o próximo item. Este comando deve ser utilizado antes da venda de um item, com a Legenda habilitada é impresso no cupom fiscal a unidade de medida do InMetro. Exemplo : R$/UN.

A legenda INMETRO é desabilitada automaticamente após a impressão do item.

Nota: Comando disponível apenas para Daruma.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Free EBook and documentation generator


Vende Item

Comandos ›› Comandos do Objeto ECF ›› Cupom Fiscal ››

Comando : ECF.VendeItem(cCodigo, cDescricao, cAliquotaICMS, nQtd, nValorUnitario [,nValorDescontoAcrescimo, cUnidade, cTipoDescontoAcrescimo, cDescontoAcrescimo, nCodDepartamento] )

Realiza a venda dos itens.

Parâmetros:

cCodigo - Texto com o código do produto, geralmente á aceito até 13 caracteres, alguns ECFs apenas aceitam numéricos no código.

cDescricao - Texto com a descrição do Produto vendido. Procure não usar acentos, pois alguns ECFs não aceitam caracteres acentuados. Para imprimir Descrições "grandes" habilite a opção "Descrição Grande" no ACBrMonitor.

cAliquotaICMS - Texto com a representação da Alíquota do ICMS.

- As alíquotas podem ser informadas em Valor (mesmo sendo texto). Exemplos: "18", "2.46".

- Se no ECF existem alíquotas iguais para ICMS e ISS, use o sufixo "T" para informar que a alíquota é do ICMS ou "S" para alíquotas do ISS. Exemplo: "18T" = alíquota de 18% do ICMS; "2.5S" alíquota de 2,5% do ISS

- As alíquotas podem ser informadas em índice, de acordo com a Tabela de alíquotas do ECF, nesse caso use a letra "T", seguida da posição da Alíquota: Exemplo: "T01", "T10"

- Existem alíquotas internas do ECF para tratar produtos Isentos, nesse caso use: "FF" para Substituição Tributária, "NN" = Não incidência ou "II" = Isento

nQtd - Quantidade de Produtos a Vender. Permite valores com até 3 casas decimais. O ACBr verifica quantas casas decimais existem no valor informado e utiliza o comando apropriado para o ECF, otimizando a impressão para Inteiros o 2 casas decimais, sempre que possível

nValorUnitario – Preço Unitário do produto vendido. Permite valores com até 3 casas decimais. O ACBr verifica quantas casas decimais existem no valor informado e utiliza o comando apropriado para o ECF, otimizando a impressão para 2 casas decimais, sempre que possível.

nValorDescontoAcrescimo - Parâmetro opcional, Se necessário, informe a Porcentagem de Desconto a aplicar no item Vendido. Dependendo do ECF o valor e porcentagem do Desconto será impresso no Cupom.

cUnidade - Parâmetro opcional, Se necessário, informe o Texto com a unidade de medida do Item. Exemplo: "UN", "LT", "MT", "KG", etc

cTipoDescontoAcrescimo - Parâmetro opcional. Informar "%" para porcentagem ou "$" para valor.Se parâmetro omitido será considerado em porcentagem "%".

cDescontoAcrescimo - Parâmetro opcional. Informar "A" para acréscimo ou "D" para desconto.Se parâmetro omitido será considerado Desconto "D"

nCodDepartamento - Parâmetro opcional. Código de departamento.

Exemplos:

ECF.VendeItem("001","PRODUTO TESTE",12,1, 100.34, 10,LT,$,A,0)

ECF.VendeItem("789012456789","PRODUTO TESTE",II, 1.5, 2.5 )

Não especificou os parâmetros opcionais (Desconto e Unidade)...

Notas:

- O ACBr tentará otimizar a impressão ocupando o menor numero de linhas possíveis, de acordo com o tamanho dos parâmetros cCodigo e cDescricao. Espaços a direita de cDescricao são ignorados.

- Para evitar "diferenças" entre o seu programa e o impresso no ECF, procure informar os campos nQtd e nValorUnitario já arredondados para o número máximo de casas decimais que você deseja utilizar.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Free help authoring tool


Cancela Item Vendido

Comandos ›› Comandos do Objeto ECF ›› Cupom Fiscal ››

Comando : ECF.CancelaItemVendido( nNumItem )

Cancela o item informado no parâmetro.

Parâmetros:

nNumItem - Numero do Item, de acordo com a ordem de impressão no Cupom fiscal a cancelar.

Exemplo:

ECF.CancelaItemVendido(5) -> Cancela o quinto item impresso no Cupom.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Easily create EPub books


Cancela Item Vendido Parcial

Comandos ›› Comandos do Objeto ECF ›› Cupom Fiscal ››

Comando : ECF.CancelaItemVendidoParcial( nNumItem, nQuantidade )

Cancela o item parcialmente, ou seja cancela a quantidade informada no parâmetro.

Parâmetros:

nNumItem - Numero do Item, de acordo com a ordem de impressão no Cupom fiscal a cancelar.

nQuantidade - Quantidade a ser cancelada.

Exemplo:

ECF.CancelaItemVendidoParcial( 3, 1 ) -> Cancela 1 qtd do terceiro item impresso no Cupom.

Nota: Comando disponível apenas para Daruma.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Cancela Desconto Acréscimo Item

Comandos ›› Comandos do Objeto ECF ›› Cupom Fiscal ››

Comando : ECF.CancelaDescontoAcrescimoItem( nNumItem )

Cancela o Desconto ou Acréscimo atribuido a um item.

Parâmetros:

nNumItem - Numero do Item, de acordo com a ordem de impressão no Cupom fiscal.

Exemplo:

ECF.CancelaDescontoAcrescimoItem( 3 ) -> Cancela o desconto ou o acréscimo que foi atribuido ao terceiro item impresso no Cupom.

Nota: Comando disponível apenas para Daruma.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Easily create Web Help sites


Desconto de Item Anterior

Comandos ›› Comandos do Objeto ECF ›› Cupom Fiscal ››

Comando : ECF.DescontoAcrescimoItemAnterior ( nValorDescontoAcrescimo [, cDescontoAcrescimo, cTipoDescontoAcrescimo, nNumItem])

Realiza desconto ou acréscimo sobre o item informado em parâmetros ou o item anterior.

Parâmetros:

nValorDescontoAcrescimo - Valor do Desconto/Acréscimo.

cDescontoAcrescimo - Informa "D" para desconto e "A" para Acréscimo, se parâmetro for omitido será considerado desconto.

cTipoDescontoAcrescimo - Informar "%" para tipo em porcentagem ou "$" para valor, se parâmetro for omitido será considerado por porcentagem.

nNumItem - Número do item a ser atribuido o desconto ou acréscimo, se parâmetro for omitido será considerado o item anterior

Exemplo:

ECF.DescontoAcrescimoItemAnterior(1.00) -> 1% de desconto no item anterior.

ECF.DescontoAcrescimoItemAnterior(1.00,"A","$",2) -> R$ 1,00 de acréscimo no item 2.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Generate Kindle eBooks with ease


Subtotaliza Cupom

Comandos ›› Comandos do Objeto ECF ›› Cupom Fiscal ››

Comando : ECF.SubtotalizaCupom [ ( nDescontoAcrescimo, cMensagemRodape ) ]

Subtotaliza o cupom.

Parâmetros:

nDescontoAcrescimo - Parâmetro opcional. Para Descontos, informe valores negativos, para acréscimos valores positivos

cMensagemRodape – Parâmetro opcional. Informe até 8 linhas de mensagem a serem impressas no rodapé do cupom. Usado apenas para o ECF DataRegis que não possui o método FechaCupom, nos demais ECFs, se a mensagem for informada nesse momento, ela será armazenada pelo ACBr e utilizada em FechaCupom

Exemplos:

ECF.SubtotalizaCupom

ECF.SubtotalizaCupom( -1.45 ) -> Desconto de R$ 1,45

ECF.SubtotalizaCupom( 5 ) -> Acréscimo de R$ 5,00

ECF.SubtotalizaCupom( 0, "Mensagem Linha 1|Mensagem Linha 2") -> Sem desconto / acréscimo mas informando 2 linhas de mensagem para serem impressas no rodapé.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Create iPhone web-based documentation


Cancela Desconto Acréscimo SubTotal

Comandos ›› Comandos do Objeto ECF ›› Cupom Fiscal ››

Comando : ECF.CancelaDescontoAcrescimoSubTotal( cTipoAcrescimoDesconto )

Cancela o Desconto ou Acréscimo atribuido no subtotal do cupom.

Parâmetros:

cTipoAcrescimoDesconto - Tipo A -> Acrescimo D -> Desconto

Exemplo:

ECF.CancelaDescontoAcrescimoSubTotal( "A" ) -> Cancela o acréscimo atribuido no subtotal do cupom.

ECF.CancelaDescontoAcrescimoSubTotal( "D" ) -> Cancela o desconto atribuido no subtotal do cupom.

Nota: Comando disponível apenas para Daruma.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Write EPub books for the iPad


Efetua Pagamento

Comandos ›› Comandos do Objeto ECF ›› Cupom Fiscal ››

Comando : ECF.EfetuaPagamento( cCodFormaPagto, nValor [, cObservacao, bImprimeVinculado ] )

Efetua o Pagamento do Cupom fiscal.

Parâmetros:

cCodFormaPagto - Índice da Forma de pagamento cadastrada no ECF. Para conhecer todas as Formas de pagamento cadastradas e seus respectivos índices, utilize o comando ECF.FormasPagamento

nValor - Valor pago para essa forma de pagamento.

cObservacao - Pode ser omitido. Alguns ECFs permitem a impressão de até 2 linhas de observação para cada forma de pagamento

bImprimeVinculado - Pode ser omitido, nesse caso assume "False". Se for informado "True" para este parâmetro, o ACBr apenas verifica se é permitido imprimir Cupom Não Fiscal Vinculado para essa forma de Pagamento.

Exemplos:

EfetuaPagamento( "01", 10 ) -> Pagando R$ 10,00 para a Forma de Pagamento 01

EfetuaPagamento( "02", 5.43, "Pagamento A PRAZO" ) -> Pagando R$ 5,43 para a Forma de Pagamento 02, imprimindo uma observação sobre o Pagamento

EfetuaPagamento( "03", 30, "TEF", True ) -> Pagando R$ 30,00 para a Forma de Pagamento 03, imprimindo a Observação "TEF" e verificando se a Forma de pagamento 03 permite ou não a emissão de Cupom Vinculado

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Full-featured Kindle eBooks generator


Estorna Pagamento

Comandos ›› Comandos do Objeto ECF ›› Cupom Fiscal ››

Comando : ECF.EstornaPagamento( cCodFormaPagtoEstornar, cCodFormaPagtoEfetivar, nValor [, cObservacao] )

Estorna um pagamento substituindo por outro, conforme os dados informados nos parâmetros.

Parâmetros:

cCodFormaPagtoEstornar - Código da Forma de pagamento que será estornado.

cCodFormaPagtoEfetivar - Código da Forma de pagamento que será efetivado.

nValor - Valor do pagamento que será estornado.

cObservacao - Parâmetro opcional. Observação ( Mensagem promocional)

Exemplos:

ECF.EstornaPagamento( "01", "02", 3.75 )

Nota: Comando disponível apenas para Daruma.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Fecha Cupom

Comandos ›› Comandos do Objeto ECF ›› Cupom Fiscal ››

Comando : ECF.FechaCupom [ ( cMensagemRodape ) ]

Realiza o Fechamento do cupom Fiscal.

Parâmetros:

cMensagemRodape - Parâmetro opcional. Informe até 8 linhas de mensagem a serem impressas no rodapé do cupom. Se esse parâmetro for omitido aqui, porém foi informado em ECF.SubtotalizaCupom , o texto informado anteriormente será utilizado.

Exemplos:

ECF.FechaCupom

ECF.FechaCupom( "Mensagem Linha 1|Mensagem Linha 2") -> Informando 2 linhas de mensagem para serem impressas no rodapé.

Notas: Utilize a mensagem no rodapé para identificar o Cliente, (Nome, Documento, Endereço, etc)

Este comando só pode ser executado após o Total de Pagamentos ( ECF.TotalPago ) efetuados com ECF.EfetuaPagamento atingir ou ultrapassar o valor de ECF.SubTotal

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: iPhone web sites made easy


Cancela Cupom

Comandos ›› Comandos do Objeto ECF ›› Cupom Fiscal ››

Comando : ECF.CancelaCupom

Cancela o Cupom Fiscal atual (se estiver aberto) em qualquer estágio do Cupom.

Se não houver cupom aberto, cancela o Último Cupom emitido, caso o último documento seja realmente um Cupom Fiscal.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Full-featured Help generator


Variaveis

Comandos ›› Comandos do Objeto ECF ›› Cupom Fiscal ››

Created with the Personal Edition of HelpNDoc: Free PDF documentation generator


Num Cupom

Comandos ›› Comandos do Objeto ECF ›› Cupom Fiscal ›› Variaveis ››

Comando : ECF.NumCupom

Retorna o Número do cupom.

Exemplo de Resposta:

OK: 002482

Created with the Personal Edition of HelpNDoc: Easily create HTML Help documents


Sub Total

Comandos ›› Comandos do Objeto ECF ›› Cupom Fiscal ›› Variaveis ››

Comando : ECF.SubTotal

Retorna o Sub-total do cupom atual (em aberto). Considerando a soma dos Itens Vendidos, o Desconto / Acréscimo concedido em ECF.SubtotalizaCupom e os pagamentos já efetuados com ECF.EfetuaPagamento

Exemplo de Resposta:

OK: 234,94

Created with the Personal Edition of HelpNDoc: Easily create EBooks


Total Pago

Comandos ›› Comandos do Objeto ECF ›› Cupom Fiscal ›› Variaveis ››

Comando : ECF.TotalPago

Retorna o Total de pagamentos já efetuados quando o ECF está no estado estPagamento

Exemplo de Resposta:

OK: 100

Created with the Personal Edition of HelpNDoc: Easily create PDF Help documents


Num Ultimo Item

Comandos ›› Comandos do Objeto ECF ›› Cupom Fiscal ›› Variaveis ››

Comando : ECF.NumUltItem

Retorna o número do último item.

Exemplo de Resposta:

OK: 3

Created with the Personal Edition of HelpNDoc: Full-featured EBook editor


Nao Fiscal

Comandos ›› Comandos do Objeto ECF ››

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Nao Fiscal Completo

Comandos ›› Comandos do Objeto ECF ›› Nao Fiscal ››

Comando : ECF.NaoFiscalCompleto( cCodCNF, nValor, cCodFormaPagto [, cObs ] )

Realiza a impressão completa de Comprovante Não Fiscal, conforme os dados informados nos parâmetros.

Parâmetros:

cCodCNF - Código do comprovante não fiscal.

nValor - Valor para o comprovante não fiscal.

cCodFormaPagto - Código da Forma de Pagamento utilizada para pagamento Comprovante não Fiscal.

cObs - Parâmetro opcional. Observação será impresso no final do comprovante.

Exemplos:

ECF.NaoFiscalCompleto( "03", 1.00, "02")

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Easily create EPub books


Sangria

Comandos ›› Comandos do Objeto ECF ›› Nao Fiscal ››

Comando : ECF.Sangria( nValor, cObs [, cDescricaoCNF, cDescricaoFPG ] )

Emite comprovante não fiscal do tipo Sangria.

Parâmetros:

nValor - Valor para a Sangria.

cObs - Observação

cDescricaoCNF - Descrição do Comprovante não fiscal. Parâmetro pode ser omitido e será considerado "SANGRIA".

cDescricaoFPG - Descrição da Forma de Pagamento. Parâmetro pode ser omitido e será considerado "DINHEIRO".

Exemplos:

ECF.Sangria(100.00)

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Easy CHM and documentation editor


Suprimento

Comandos ›› Comandos do Objeto ECF ›› Nao Fiscal ››

Comando : ECF.Suprimento( nValor, cObs [, cDescricaoCNF, cDescricaoFPG ] )

Emite comprovante não fiscal do tipo Suprimento.

Parâmetros:

nValor - Valor para o Suprimento.

cObs - Observação

cDescricaoCNF - Descrição do Comprovante não fiscal. Parâmetro pode ser omitido e será considerado "SUPRIMENTO".

cDescricaoFPG - Descrição da Forma de Pagamento. Parâmetro pode ser omitido e será considerado "DINHEIRO".

Exemplos:

ECF.Suprimento(200.00)

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Free EPub producer


Abre Nao Fiscal

Comandos ›› Comandos do Objeto ECF ›› Nao Fiscal ››

Comando : ECF.AbreNaoFiscal [ ( cCPF_CNPJ, cNOME, cENDERECO) ]

Realiza a abertura do Comprovante Não Fiscal.

Parâmetros:

cCPF_CNPJ - Parâmetro opcional. Se necessário, informe o CPF/CNPJ do Consumidor

cNOME -Parâmetro opcional. Se necessário, informe o NOME do Consumidor

cENDERECO -Parâmetro opcional. Se necessário, informe o ENDEREÇO do Consumidor

Exemplos:

ECF.AbreNaoFiscal

ECF.AbreNaoFiscal( "47.508.411/0001-56" ,"ACBr,Tatui")

Nota: Nem todos os modelos de ECF fazem uso do parâmetro cCPF_CNPJ, nesse caso o Cupom será aberto, porém o número de identificação do cliente não será impresso. Dica: Para identificar o cliente prefira usar o Rodapé do Cupom, que permite até 8 linhas de texto livre.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Easily create Help documents


Registra Item Nao Fiscal

Comandos ›› Comandos do Objeto ECF ›› Nao Fiscal ››

Comando : ECF.RegistraItemNaoFiscal( cCodCNF, nValor [, cObs ] )

Registra o item Não Fiscal, conforme os dados informados nos parâmetros.

Parâmetros:

cCodCNF - Código do CNF (Comprovante Não Fiscal).

nValor - Valor do Comprovante não fiscal.

cObs - Parâmetro opcional. Se desejar deixar alguma Observação.

Exemplos:

ECF.RegistraItemNaoFiscal("03", 100.00)

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Write eBooks for the Kindle


Cancela Item Nao Fiscal

Comandos ›› Comandos do Objeto ECF ›› Nao Fiscal ››

Comando : ECF.CancelaItemNaoFiscal( nAItem )

Cancela o item informado no parâmetro do comprovante não fiscal .

Parâmetros:

nAItem - Numero do Item a cancelar de acordo com a ordem de impressão no Comprovante não fiscal.

Exemplo:

ECF.CancelaItemNaoFiscal( 1 ) -> Cancela o primeiro item impresso no Comprovante não fiscal.

Nota: Comando disponível apenas para Daruma.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Easily create Web Help sites


Subtotaliza Nao Fiscal

Comandos ›› Comandos do Objeto ECF ›› Nao Fiscal ››

Comando : ECF.SubtotalizaNaoFiscal [ ( nDescontoAcrescimo, cMensagemRodape ) ]

Subtotaliza o comprovane não fiscal.

Parâmetros:

nDescontoAcrescimo - Parâmetro opcional. Para Descontos, informe valores negativos, para acréscimos valores positivos

cMensagemRodape – Parâmetro opcional. Informe até 8 linhas de mensagem a serem impressas no rodapé do cupom. Usado apenas para o ECF DataRegis que não possui o método FechaCupom, nos demais ECFs, se a mensagem for informada nesse momento, ela será armazenada pelo ACBr e utilizada em FechaCupom

Exemplos:

ECF.SubtotalizaNaoFiscal

ECF.SubtotalizaNaoFiscal( -1.45 ) -> Desconto de R$ 1,45

ECF.SubtotalizaNaoFiscal( 5 ) -> Acréscimo de R$ 5,00

ECF.SubtotalizaNaoFiscal( 0, "Mensagem Linha 1|Mensagem Linha 2") -> Sem desconto / acréscimo mas informando 2 linhas de mensagem para serem impressas no rodapé.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Free CHM Help documentation generator


Efetua Pagamento Nao Fiscal

Comandos ›› Comandos do Objeto ECF ›› Nao Fiscal ››

Comando : ECF.EfetuaPagamentoNaoFiscal( cCodFormaPagto, nValor [, cObservacao, bImprimeVinculado ] )

Efetua o Pagamento do Comprovante Não Fiscal.

Parâmetros:

cCodFormaPagto - Índice da Forma de pagamento cadastrada no ECF. Para conhecer todas as Formas de pagamento cadastradas e seus respectivos índices, utilize o comando ECF.FormasPagamento

nValor - Valor pago para essa forma de pagamento.

cObservacao - Pode ser omitido. Alguns ECFs permitem a impressão de até 2 linhas de observação para cada forma de pagamento

bImprimeVinculado - Pode ser omitido, nesse caso assume "False". Se for informado "True" para este parâmetro, o ACBr apenas verifica se é permitido imprimir Cupom Não Fiscal Vinculado para essa forma de Pagamento.

Exemplos:

ECF.EfetuaPagamentoNaoFiscal( "01", 10 ) -> Pagando R$ 10,00 para a Forma de Pagamento 01

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


Fecha Nao Fiscal

Comandos ›› Comandos do Objeto ECF ›› Nao Fiscal ››

Comando : ECF.FechaNaoFiscal [ ( cObservacao ) ]

Realiza o Fechamento do comprovante Não Fiscal.

Parâmetros:

cObservacao - Parâmetro opcional. Observação no comprovante Não Fiscal, será impresso no final do comprovante.

Exemplos:

ECF.FechaNaoFiscal

ECF.FechaNaoFiscal( "Mensagem Linha 1|Mensagem Linha 2") -> Informando 2 linhas de mensagem para serem impressas no rodapé.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Full-featured Kindle eBooks generator


Cancela Nao Fiscal

Comandos ›› Comandos do Objeto ECF ›› Nao Fiscal ››

Comando : ECF.CancelaNaoFiscal

Cancela o Comprovante Não Fiscal atual (se estiver aberto) em qualquer estágio do Cupom.

Se não houver comprovante aberto, cancela o Último Comprovante emitido, caso o último documento seja realmente um Comprovante Não Fiscal.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Full-featured Help generator


Dispositivos

Comandos ›› Comandos do Objeto ECF ››

Created with the Personal Edition of HelpNDoc: Free EPub and documentation generator


Gaveta

Comandos ›› Comandos do Objeto ECF ›› Dispositivos ››

Created with the Personal Edition of HelpNDoc: Full-featured Documentation generator


Abre Gaveta

Comandos ›› Comandos do Objeto ECF ›› Dispositivos ›› Gaveta ››

Comando : ECF.AbreGaveta

Aciona a abertura da gaveta de dinheiro ligada ao ECF

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Full-featured Help generator


Gaveta Aberta?

Comandos ›› Comandos do Objeto ECF ›› Dispositivos ›› Gaveta ››

Comando : ECF.GavetaAberta

Retorna “True” se a gaveta de dinheiro está aberta.

Exemplo de Resposta:

OK: False

Created with the Personal Edition of HelpNDoc: iPhone web sites made easy


Cheque

Comandos ›› Comandos do Objeto ECF ›› Dispositivos ››

Created with the Personal Edition of HelpNDoc: News and information about help authoring tools and software


Cheque Pronto?

Comandos ›› Comandos do Objeto ECF ›› Dispositivos ›› Cheque ››

Comando : ECF.ChequePronto

Retorna “True” se cheque está pronto.

Exemplo de Resposta:

OK: True

Created with the Personal Edition of HelpNDoc: Free Web Help generator


Imprime Cheque

Comandos ›› Comandos do Objeto ECF ›› Dispositivos ›› Cheque ››

Comando : ECF.ImprimeCheque( cBanco, nValor, cFavorecido, cCidade, dData [, cObservação ] )

Realiza a impressão do cheque conforme os dados informados nos parâmetros.

Parâmetros:

cBanco - Número do Banco.

nValor - Valor do cheque.

cFavorecido - Nome o Favorecido

cCidade - Cidade

dData - Data formato "dd/mm/aaaa".

cObservação - Parâmetro opcional. Se desejar colocar alguma observação no cheque.

Exemplos:

ECF.ImprimeCheque( "237", 100.00, "Jose Pereira da Silva", "Alfenas", "23/12/2012" )

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Free Web Help generator


Cancela Impressao Cheque

Comandos ›› Comandos do Objeto ECF ›› Dispositivos ›› Cheque ››

Comando : ECF.CancelaImpressaoCheque

Cancela a impressão do cheque.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Free EPub producer


Leitura CMC7

Comandos ›› Comandos do Objeto ECF ›› Dispositivos ›› Cheque ››

Comando : ECF.LeituraCMC7

Retorna a leitura CMC7 do cheque (Caracteres Magnéticos Codificados em 7 barras).

Nota: Comando Disponível para modelos SwedaSTX, Sweda, Fiscnet e Epson

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Produce Kindle eBooks easily


Utilitarios

Comandos ›› Comandos do Objeto ECF ››

Created with the Personal Edition of HelpNDoc: Easy CHM and documentation editor


Programa Aliquota

Comandos ›› Comandos do Objeto ECF ›› Utilitarios ››

Comando : ECF.ProgramaAliquota( nValorAliquota[, cTipoAliquota , cPosicaoAliquota] )

Programa a aliquota no ECF conforme os dados informados nos parâmetros.

Parâmetros:

nValorAliquota - Valor da Alíquota a programar. Exemplos: 18 , 12 , 2.46

cTipoAliquota - Tipo da Alíquota , Use "T" para ICMS ou "S" para ISS. Pode ser omitido, nesse caso assume "T"

cPosicaoAliquota - Posição de cadastro da Alíquota. Não é aceito em todos os modelos de ECFs, e em alguns outros apenas é aceito em modo de Intervenção. Normalmente esse parâmetro deve ser omitido

Exemplos:

ECF.ProgramaAliquota( 18 ) – Programa a Alíquota de 18% do ICMS

ECF.ProgramaAliquota( 2.46 ,"T") – Programa a Alíquota de 2,46% do ICMS

ECF.ProgramaAliquota( 2.5, "S" ) – Programa a Alíquota de 2,5% do ISS

Notas:

Na maioria dos ECFs este comando somente é aceito quando o Movimento não foi iniciado, ou seja, após uma Redução Z e antes de uma Venda ou Leitura X

Não é possível apagar as alíquotas programadas, portanto CUIDADO ao programar novas Alíquotas. Apenas uma intervenção técnica pode remover as Alíquotas já programadas

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Programa Forma de Pagamento

Comandos ›› Comandos do Objeto ECF ›› Utilitarios ››

Comando : ECF.ProgramaFormaPagamento( cDescricao [, bPermitevinculado, cPosicao] )

Programa a Forma de Pagamento conforme os dados informados nos parâmetros.

Parâmetros:

cDescricao - Descrição da forma de pagamento a programar.

bPermitevinculado - Permite vinculado "true" ou "false". Pode ser omitido, nesse caso assume "True"

cPosicao - Posição de cadastro da Forma de Pagamento. Não é aceito em todos os modelos de ECFs, e em alguns outros apenas é aceito em modo de Intervenção. Normalmente esse parâmetro deve ser omitido

Exemplos:

ECF.ProgramaFormaPagamento("Cartao Debito")

ECF.ProgramaFormaPagamento("Cheque",False)

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Programa Comprovante Nao Fiscal

Comandos ›› Comandos do Objeto ECF ›› Utilitarios ››

Comando : ECF.ProgramaComprovanteNaoFiscal( cDescricao [, cTipo, cPosicao] )

Programa Comprovante não Fiscal conforme os dados informados nos parâmetros.

Parâmetros:

cDescricao - Descrição do Comprovante Não Fiscal.

cTipo - Permite vinculado "true" ou "false". Pode ser omitido, nesse caso assume "True"

cPosicao - Posição de cadastro do CNF. Não é aceito em todos os modelos de ECFs, e em alguns outros apenas é aceito em modo de Intervenção. Normalmente esse parâmetro deve ser omitido

Exemplos:

ECF.ProgramaComprovanteNaoFiscal("Recebimento")

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Easily create HTML Help documents


Programa Unidade Medida

Comandos ›› Comandos do Objeto ECF ›› Utilitarios ››

Comando : ECF.ProgramaUnidadeMedida( cDescricao)

Programa Unidade de Medida com a Descrição informada no parâmetro.

Parâmetros:

cDescricao - Descrição da Unidade de Medida.

Exemplos:

ECF.ProgramaUnidadeMedida("UN")

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Easily create EPub books


Programa Relatorio Gerencial

Comandos ›› Comandos do Objeto ECF ›› Utilitarios ››

Comando : ECF.ProgramaRelatoriosGerenciais(cDescricao [, cPosicao] )

Programa Relatórios Gerenciais conforme os dados informados nos parâmetros.

Parâmetros:

cDescricao - Descrição do Relatório Gerencial.

cPosicao - Posição de cadastro do CNF. Não é aceito em todos os modelos de ECFs, e em alguns outros apenas é aceito em modo de Intervenção. Normalmente esse parâmetro deve ser omitido

Exemplos:

ECF.ProgramaRelatoriosGerenciais("Entrega")

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Easily create iPhone documentation


Identifica Operador

Comandos ›› Comandos do Objeto ECF ›› Utilitarios ››

Comando : ECF.IdentificaOperador ( cNome )

Permite gravar no ECF informações sobre operadores.

Parâmetros:

cNome - Nome do operador.

Exemplos:

ECF.IdentificaOperador ( "Maria" )

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Free help authoring tool


Identifica PAF

Comandos ›› Comandos do Objeto ECF ›› Utilitarios ››

Comando : ECF.IdentificaPAF ( cNomeVersao, cMD5)

Permite gravar no ECF, informações sobre o Programa Aplicativo Fiscal (PAF) em operação. Esta informação deve ser impressa em todos os cupons, de acordo com a lei atual.

Parâmetros:

cNomeVersao - Nome e versão do aplicativo fiscal.

cMD5 - Numero do MD5.

Exemplos:

ECF.IdentificaPAF ( "DJPDV.1.2.1" , "MD-5:A7B63B2B53EB4FA7C789979D7BA83CAD")

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Easily create iPhone documentation


Muda Horario Verao

Comandos ›› Comandos do Objeto ECF ›› Utilitarios ››

Comando : ECF.MudaHorarioVerao [ ( bHorarioVerao ) ]

Se a ECF não esta em horário de verão , o relógio da ECF é reajustado Início de horário de verão ao contrário é reajustado para fim de horário de verão.

Parâmetros:

bHorarioVerao - Mudar horário de verão "true" ou "false". Pode ser omitido, nesse caso assume "True"

Exemplos:

ECF.MudaHorarioVerao

ECF.MudaHorarioVerao(true)

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Easily create EPub books


Muda Arredondamento

Comandos ›› Comandos do Objeto ECF ›› Utilitarios ››

Comando : ECF.MudaArredondamento( bArredonda )

Permite mudar o arredondamento da ECF.

Parâmetros:

bArredonda - Mudar Arredondamento da ECF "true" ou "false".

Exemplos:

ECF.MudaArredondamento(true)

Nota: Comando disponível apenas para Daruma, Urano e Bematech

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Generate EPub eBooks with ease


Corrige Estado de Erro

Comandos ›› Comandos do Objeto ECF ›› Utilitarios ››

Comando : ECF.CorrigeEstadoErro[ ( bReducaoZ ) ]

Verifica o estado atual do ECF e efetua as operações necessárias para deixar o ECF no estado livre. Portanto esse método tenta fechar ou cancelar qualquer documento que esteja aberto. Em alguns ECFs comandos adicionais são enviados para tentar “desbloquear” o ECF de alguma condição de erro que impeça a impressão de novos documentos.

Parâmetros:

bReducaoZ - Parâmetro opcional. Se necessário emitir a redução Z "True" ou "False", se parâmetro for omitido será considerado TRUE.

Exemplos:

ECF.CorrigeEstadoErro

ECF.CorrigeEstadoErro(False)

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Easily create CHM Help documents


Envia Comando

Comandos ›› Comandos do Objeto ECF ›› Utilitarios ››

Comando : ECF.EnviaComando( cComando )

ou

Comando : ECF.EnviaComando( cComando , nTimeOut )

Envia comando conforme a sintaxe de cada modelo de ECF. Verificar o manual de cada modelo.

Parâmetros:

cComando - Comando a ser processado. Verificar a sintaxe ou o comando a ser informado no manual de cada ECF.

nTimeOut - Time Out da eCF.

Exemplos:

ECF.Enviacomando("15") - Comando 15 da SwedaSTX (Emissão de LeituraX)

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Easy CHM and documentation editor


Comando Enviado

Comandos ›› Comandos do Objeto ECF ›› Utilitarios ››

Comando : ECF.ComandoEnviado

Retorna o último comando enviado para o ECF no formato da sintaxe suportada pelo ECF.

Exemplo de Resposta:

OK: [STX]815[ETX]

Created with the Personal Edition of HelpNDoc: Full-featured EPub generator


Resposta Comando

Comandos ›› Comandos do Objeto ECF ›› Utilitarios ››

Comando : ECF.RespostaComando

Retorna a resposta exata do ECF sem tratamento, na sintaxe de retorno do ECF

Exemplo de Resposta:

OK: [STX]815+0000A[ETX]

Created with the Personal Edition of HelpNDoc: Easy EPub and documentation editor


Retorna Informação ECF

Comandos ›› Comandos do Objeto ECF ›› Utilitarios ››

Comando : ECF.RetornaInfoECF( cRegistrador )

Retorna as informações da ECF conforme o Registrador informado no parâmetro.

Parâmetros:

cRegistrador - Registro para retornar determinada informação. Verificar no manual de programação da ECF para os registros.

Exemplos:

ECF.RetornaInfoECF("A1")

Registrador A1 da SwedaSTX retorna:

Totalizador Geral GT -> 18 bytes

Venda Líquida VL -> 14 bytes

Venda Bruta Diária VB -> 14 bytes

Exemplo de Resposta:

OK: 0000000000021298160000000000000000000000000000[ETX][ACK][STX]234+0000AA[x9B][x80][x82][x80][x80]A1

Created with the Personal Edition of HelpNDoc: Free help authoring tool


PAF - Menu Fiscal

Comandos ›› Comandos do Objeto ECF ››

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


LX

Comandos ›› Comandos do Objeto ECF ›› PAF - Menu Fiscal ››

Comando : ECF.PafMF_LX_Impressao

Impressão de uma Leitura X.

Nota: em alguns estados, é necessário imprimir uma Leitura X todo inicio de dia e cada inicio de Bobina

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


LMFC - Leitura Memória Fiscal Completa

Comandos ›› Comandos do Objeto ECF ›› PAF - Menu Fiscal ››

Created with the Personal Edition of HelpNDoc: Free help authoring tool


Impressão

Comandos ›› Comandos do Objeto ECF ›› PAF - Menu Fiscal ›› LMFC - Leitura Memória Fiscal Completa ››

Created with the Personal Edition of HelpNDoc: Free iPhone documentation generator


Por Periodo

Comandos ›› Comandos do Objeto ECF ›› PAF - Menu Fiscal ›› LMFC - Leitura Memória Fiscal Completa ›› Impressão ››

Comando : ECF.PafMF_LMFC_Impressao(dDataInicial, dDataFinal)

Imprime na ECF a leitura da memória fiscal completa por período de data.

Parâmetros:

dDataInicial - Data Inicial. (dd/mm/aaaa)

dDataFinal - Data final. (dd/mm/aaaa)

Exemplos:

ECF.PafMF_LMFC_Impressao("20/12/2012", "21/12/2012")

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Produce Kindle eBooks easily


Por CRZ

Comandos ›› Comandos do Objeto ECF ›› PAF - Menu Fiscal ›› LMFC - Leitura Memória Fiscal Completa ›› Impressão ››

Comando : ECF.PafMF_LMFC_Impressao( nCRZInicial , nCRZFinal )

Imprime na ECF a leitura da memória fiscal completa por intervalo de CRZ.

Parâmetros:

nCRZInicial - Redução Z inicial.

nCRZFinal - Redução Z final.

Exemplos:

ECF.PafMF_LMFC_Impressao(002542, 002542)

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: iPhone web sites made easy


Espelho

Comandos ›› Comandos do Objeto ECF ›› PAF - Menu Fiscal ›› LMFC - Leitura Memória Fiscal Completa ››

Created with the Personal Edition of HelpNDoc: Full-featured multi-format Help generator


Por Periodo

Comandos ›› Comandos do Objeto ECF ›› PAF - Menu Fiscal ›› LMFC - Leitura Memória Fiscal Completa ›› Espelho ››

Comando : ECF.PafMF_LMFC_Espelho(dDataInicial, dDataFinal, cPathArquivo)

Gera arquivo do espelho da Leitura Memória Fiscal Completa por período de Data e assina digitalmente, inserindo ao final do arquivo uma linha com o registro tipo EAD( Assinatura Digital ).

Parâmetros:

dDataInicial - Data Inicial. (dd/mm/aaaa)

dDataFinal - Data final. (dd/mm/aaaa)

cPathArquivo - Local onde será gerado o arquivo

Exemplos:

ECF.PafMF_LMFC_Espelho("20/12/2012", "21/12/2012", "EspLMFCPeriodo.txt")

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Full-featured EPub generator


Por CRZ

Comandos ›› Comandos do Objeto ECF ›› PAF - Menu Fiscal ›› LMFC - Leitura Memória Fiscal Completa ›› Espelho ››

Comando : ECF.PafMF_LMFC_Espelho( nCRZInicial , nCRZFinal, cPathArquivo )

Gera arquivo do espelho da Leitura Memória Fiscal Completa por intervalo de Redução Z e assina digitalmente, inserindo ao final do arquivo uma linha com o registro tipo EAD( Assinatura Digital ).

Parâmetros:

nCRZInicial - Redução Z inicial.

nCRZFinal - Redução Z final.

cPathArquivo - Local onde será gerado o arquivo

Exemplos:

ECF.PafMF_LMFC_Espelho(002542, 002542, "EspLMFCCRZ.txt")

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Cotepe 17/04

Comandos ›› Comandos do Objeto ECF ›› PAF - Menu Fiscal ›› LMFC - Leitura Memória Fiscal Completa ››

Created with the Personal Edition of HelpNDoc: Create iPhone web-based documentation


Por Periodo

Comandos ›› Comandos do Objeto ECF ›› PAF - Menu Fiscal ›› LMFC - Leitura Memória Fiscal Completa ›› Cotepe 17/04 ››

Comando : ECF.PafMF_LMFC_Cotepe1704(dDataInicial, dDataFinal, cPathArquivo)

Gera o arquivo da Leitura da Memória Fiscal completa no formato estabelecido no Ato COTEPE/ICMS 17/04 por período de Data e assina digitalmente, inserindo ao final do arquivo uma linha com o registro tipo EAD( Assinatura Digital ).

Parâmetros:

dDataInicial - Data Inicial. (dd/mm/aaaa)

dDataFinal - Data final. (dd/mm/aaaa)

cPathArquivo - Local onde será gerado o arquivo

Exemplos:

ECF.PafMF_LMFC_Cotepe1704("20/12/2012", "21/12/2012", "Cot1704LMFCPeriodo.txt")

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Free EBook and documentation generator


Por CRZ

Comandos ›› Comandos do Objeto ECF ›› PAF - Menu Fiscal ›› LMFC - Leitura Memória Fiscal Completa ›› Cotepe 17/04 ››

Comando : ECF.PafMF_LMFC_Cotepe1704( nCRZInicial , nCRZFinal, cPathArquivo )

Gera o arquivo no formato estabelecido no Ato COTEPE/ICMS 17/04 por intervalo de Redução Z e assina digitalmente, inserindo ao final do arquivo uma linha com o registro tipo EAD( Assinatura Digital ).

Parâmetros:

nCRZInicial - Redução Z inicial.

nCRZFinal - Redução Z final.

cPathArquivo - Local onde será gerado o arquivo

Exemplos:

ECF.PafMF_LMFC_Cotepe1704(002542, 002542, "Cot1704LMFCCRZ.txt")

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Free PDF documentation generator


LMFS - Leitura Memória Fiscal Simplificada

Comandos ›› Comandos do Objeto ECF ›› PAF - Menu Fiscal ››

Created with the Personal Edition of HelpNDoc: Easily create iPhone documentation


Impressão

Comandos ›› Comandos do Objeto ECF ›› PAF - Menu Fiscal ›› LMFS - Leitura Memória Fiscal Simplificada ››

Created with the Personal Edition of HelpNDoc: iPhone web sites made easy


Por Periodo

Comandos ›› Comandos do Objeto ECF ›› PAF - Menu Fiscal ›› LMFS - Leitura Memória Fiscal Simplificada ›› Impressão ››

Comando : ECF.PafMF_LMFS_Impressao(dDataInicial, dDataFinal)

Imprime na ECF a leitura da memória fiscal simplificada por período de data.

Parâmetros:

dDataInicial - Data Inicial. (dd/mm/aaaa)

dDataFinal - Data final. (dd/mm/aaaa)

Exemplos:

ECF.PafMF_LMFS_Impressao("20/12/2012", "21/12/2012")

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Free Kindle producer


Por CRZ

Comandos ›› Comandos do Objeto ECF ›› PAF - Menu Fiscal ›› LMFS - Leitura Memória Fiscal Simplificada ›› Impressão ››

Comando : ECF.PafMF_LMFS_Impressao( nCRZInicial , nCRZFinal )

Imprime na ECF a leitura da memória fiscal simplificada por intervalo de CRZ.

Parâmetros:

nCRZInicial - Redução Z inicial.

nCRZFinal - Redução Z final.

Exemplos:

ECF.PafMF_LMFS_Impressao(002542, 002542)

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Full-featured EBook editor


Espelho

Comandos ›› Comandos do Objeto ECF ›› PAF - Menu Fiscal ›› LMFS - Leitura Memória Fiscal Simplificada ››

Created with the Personal Edition of HelpNDoc: Free PDF documentation generator


Por Periodo

Comandos ›› Comandos do Objeto ECF ›› PAF - Menu Fiscal ›› LMFS - Leitura Memória Fiscal Simplificada ›› Espelho ››

Comando : ECF.PafMF_LMFS_Espelho(dDataInicial, dDataFinal, cPathArquivo)

Gera arquivo do espelho da Leitura Memória Fiscal Simplificada por período de Data e assina digitalmente, inserindo ao final do arquivo uma linha com o registro tipo EAD( Assinatura Digital ).

Parâmetros:

dDataInicial - Data Inicial. (dd/mm/aaaa)

dDataFinal - Data final. (dd/mm/aaaa)

cPathArquivo - Local onde será gerado o arquivo

Exemplos:

ECF.PafMF_LMFS_Espelho("20/12/2012", "21/12/2012", "EspLMFSPeriodo.txt")

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: iPhone web sites made easy


Por CRZ

Comandos ›› Comandos do Objeto ECF ›› PAF - Menu Fiscal ›› LMFS - Leitura Memória Fiscal Simplificada ›› Espelho ››

Comando : ECF.PafMF_LMFS_Espelho( nCRZInicial , nCRZFinal, cPathArquivo )

Gera arquivo do espelho da Leitura Memória Fiscal Simplificada por intervalo de Redução Z e assina digitalmente, inserindo ao final do arquivo uma linha com o registro tipo EAD( Assinatura Digital ).

Parâmetros:

nCRZInicial - Redução Z inicial.

nCRZFinal - Redução Z final.

cPathArquivo - Local onde será gerado o arquivo

Exemplos:

ECF.PafMF_LMFS_Espelho(002542, 002542, "EspLMFSCRZ.txt")

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Easily create iPhone documentation


MFD - Memória Fita Detalhe

Comandos ›› Comandos do Objeto ECF ›› PAF - Menu Fiscal ››

Created with the Personal Edition of HelpNDoc: Full-featured EPub generator


Espelho

Comandos ›› Comandos do Objeto ECF ›› PAF - Menu Fiscal ›› MFD - Memória Fita Detalhe ››

Created with the Personal Edition of HelpNDoc: Easily create iPhone documentation


Por periodo

Comandos ›› Comandos do Objeto ECF ›› PAF - Menu Fiscal ›› MFD - Memória Fita Detalhe ›› Espelho ››

Comando : ECF.PafMF_MFD_Espelho(dDataInicial, dDataFinal, cPathArquivo)

Gera arquivo do espelho da Memória de Fita Detalhe por período de Data e assina digitalmente, inserindo ao final do arquivo uma linha com o registro tipo EAD( Assinatura Digital ).

Parâmetros:

dDataInicial - Data Inicial. (dd/mm/aaaa)

dDataFinal - Data final. (dd/mm/aaaa)

cPathArquivo - Local onde será gerado o arquivo

Exemplos:

ECF.PafMF_MFD_Espelho("20/12/2012", "21/12/2012", "EspMFDPeriodo.txt")

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Easily create iPhone documentation


Por COO

Comandos ›› Comandos do Objeto ECF ›› PAF - Menu Fiscal ›› MFD - Memória Fita Detalhe ›› Espelho ››

Comando : ECF.PafMF_MFD_Espelho( nCOOInicial , nCOOFinal, cPathArquivo )

Gera arquivo do espelho da Memória de Fita Detalhe por intervalo de COO e assina digitalmente, inserindo ao final do arquivo uma linha com o registro tipo EAD( Assinatura Digital ).

Parâmetros:

nCOOInicial - COO Inicial.

nCOOFinal - COO final.

cPathArquivo - Local onde será gerado o arquivo

Exemplos:

ECF.PafMF_MFD_Espelho(002542, 002542, "EspMFDCOO.txt")

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Free HTML Help documentation generator


Cotepe 17/04

Comandos ›› Comandos do Objeto ECF ›› PAF - Menu Fiscal ›› MFD - Memória Fita Detalhe ››

Created with the Personal Edition of HelpNDoc: Easy CHM and documentation editor


Por Periodo

Comandos ›› Comandos do Objeto ECF ›› PAF - Menu Fiscal ›› MFD - Memória Fita Detalhe ›› Cotepe 17/04 ››

Comando : ECF.PafMF_MFD_Cotepe1704(dDataInicial, dDataFinal, cPathArquivo)

Gera o arquivo da Memória de Fita Detalhe no formato estabelecido no Ato COTEPE/ICMS 17/04 por período de Data e assina digitalmente, inserindo ao final do arquivo uma linha com o registro tipo EAD( Assinatura Digital ).

Parâmetros:

dDataInicial - Data Inicial. (dd/mm/aaaa)

dDataFinal - Data final. (dd/mm/aaaa)

cPathArquivo - Local onde será gerado o arquivo

Exemplos:

ECF.PafMF_MFD_Cotepe1704("20/12/2012", "21/12/2012", "Cot1704MFDPeriodo.txt")

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Easily create PDF Help documents


Por COO

Comandos ›› Comandos do Objeto ECF ›› PAF - Menu Fiscal ›› MFD - Memória Fita Detalhe ›› Cotepe 17/04 ››

Comando : ECF.PafMF_MFD_Cotepe1704( nCOOInicial , nCOOFinal, cPathArquivo )

Gera o arquivo da Memória de Fita Detalhe no formato estabelecido no Ato COTEPE/ICMS 17/04 por intervalo de COO e assina digitalmente, inserindo ao final do arquivo uma linha com o registro tipo EAD( Assinatura Digital ).

Parâmetros:

nCOOInicial - COO Inicial.

nCOOFinal - COO final.

cPathArquivo - Local onde será gerado o arquivo

Exemplos:

ECF.PafMF_MFD_Cotepe1704(002542, 002542, "Cot1704MFDCOO.txt")

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Free CHM Help documentation generator


CAT52

Comandos ›› Comandos do Objeto ECF ›› PAF - Menu Fiscal ››

Comando : ECF.PafMF_GerarCAT52(dDataInicial, dDataFinal, cDirArquivos)

Gera o CAT52 por período de data.

Parâmetros:

dDataInicial - Data Inicial. (dd/mm/aaaa)

dDataFinal - Data final. (dd/mm/aaaa)

cDirArquivos - Diretório onde será gerado o arquivo CAT52.

Exemplos:

ECF.PafMF_GerarCAT52("20/12/2012", "21/12/2012","C:\MenuFiscal")

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Full-featured multi-format Help generator


EAD - Assinatura Digital

Comandos ›› Comandos do Objeto ECF ›› PAF - Menu Fiscal ››

Created with the Personal Edition of HelpNDoc: Full-featured Kindle eBooks generator


ArqMF

Comandos ›› Comandos do Objeto ECF ›› PAF - Menu Fiscal ››

Comando : ECF.PafMF_ArqMF( cArquivo)

Essa função retornará dois arquivos, um binário e um outro arquivo texto com a assintatura EAD.

Parâmetros:

cArquivo – Nome do arquivo binário a ser assinado.

Exemplos:

ECF.PafMF_ArqMF("C:\Arquivos\ArqMF.bin")

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


ArqMFD

Comandos ›› Comandos do Objeto ECF ›› PAF - Menu Fiscal ››

Comando : ECF.PafMF_ArqMFD( cArquivo)

Essa função retornará dois arquivos, um binário e um outro arquivo texto com a assintatura EAD.

Parâmetros:

cArquivo – Nome do arquivo binário a ser assinado.

Exemplos:

ECF.PafMF_ArqMFD("C:\Arquivos\ArqMFD.bin")

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: What is a Help Authoring tool?


AssinarBlocoXEstoque

Comandos ›› Comandos do Objeto ECF ›› PAF - Menu Fiscal ››

Comando : ECF.AssinarBlocoXEstoque( cArquivo)

Essa função retornará a informação do arquivo assinado ou o conteúdo assinado

Parâmetros:

cArquivo – Nome do arquivo binário a ser assinado ou o conteúdo do XML pra assinar

Exemplos:

ECF.AssinarBlocoXEstoque("C:\Arquivos\BlocoXEstoque.xml")

ECF.AssinarBlocoXEstoque("<xml><utf-8>......<x>")

Exemplo de Resposta:

OK:

OK:<xml>..... <signature>......

Created with the Personal Edition of HelpNDoc: Free EPub and documentation generator


AssinarBlocoXReducaoZ

Comandos ›› Comandos do Objeto ECF ›› PAF - Menu Fiscal ››

Comando : ECF.AssinarBlocoXReducaoZ( cArquivo)

Essa função retornará a informação do arquivo assinado ou o conteúdo assinado

Parâmetros:

cArquivo – Nome do arquivo binário a ser assinado ou o conteúdo do XML pra assinar

Exemplos:

ECF.AssinarBlocoXReducaoZ("C:\Arquivos\BlocoXReducaoZ.xml")

ECF.AssinarBlocoXReducaoZ("<xml><utf-8>......<x>")

Exemplo de Resposta:

OK:

OK:<xml>..... <signature>......

Created with the Personal Edition of HelpNDoc: Full-featured Documentation generator


Parâmetros - ACBrECF

Comandos ›› Comandos do Objeto ECF ››

Created with the Personal Edition of HelpNDoc: Free EBook and documentation generator


Modelo

Comandos ›› Comandos do Objeto ECF ›› Parâmetros - ACBrECF ››

Comando : ECF.Modelo

Retorna modelo no formato usado no componente ACBrECF

Exemplo de Resposta:

OK: ecfDaruma

Created with the Personal Edition of HelpNDoc: Free HTML Help documentation generator


Porta

Comandos ›› Comandos do Objeto ECF ›› Parâmetros - ACBrECF ››

Comando : ECF.Porta

Retorna a porta que ECF está configurada no componente ACBrECF.

Exemplo de Resposta:

OK: COM1

Created with the Personal Edition of HelpNDoc: Generate Kindle eBooks with ease


Time Out

Comandos ›› Comandos do Objeto ECF ›› Parâmetros - ACBrECF ››

Comando : ECF.TimeOut

Retorna TimeOut que o componente está configurado.

Exemplo de Resposta:

OK: 3

Created with the Personal Edition of HelpNDoc: Write eBooks for the Kindle


Set Time Out

Comandos ›› Comandos do Objeto ECF ›› Parâmetros - ACBrECF ›› Time Out ››

Comando : ECF.SetTimeOut( nValorTimeout )

Muda o valor do TimeOut do componente ECF.

Parâmetros:

nValorTimeout - Valor do TimeOut

Exemplos:

ECF.SetTimeOut( 5 )

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Produce Kindle eBooks easily


Intervalo

Comandos ›› Comandos do Objeto ECF ›› Parâmetros - ACBrECF ››

Comando : ECF.IntervaloAposComando

Retorna o intervalo que está configurada no componente ACBrECF.

Exemplo de Resposta:

OK: 100

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Descrição Grande

Comandos ›› Comandos do Objeto ECF ›› Parâmetros - ACBrECF ››

Comando : ECF.DescricaoGrande

Retorna se aceitar Descrição Grande.

Exemplo de Resposta:

OK: True

Created with the Personal Edition of HelpNDoc: iPhone web sites made easy


Sinal Invertido da Gaveta

Comandos ›› Comandos do Objeto ECF ›› Parâmetros - ACBrECF ››

Comando : ECF.GavetaSinalInvertido

Retorna se sinal da gaveta esta invertido no componente ACBrECF.

Exemplo de Resposta:

OK: True

Created with the Personal Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


Ignorar Tags de Formatação

Comandos ›› Comandos do Objeto ECF ›› Parâmetros - ACBrECF ››

Comando : ECF.IgnorarTagsFormatacao

Retorna se ignora tags de formatação no componente ACBrECF.

Exemplo de Resposta:

OK: False

Created with the Personal Edition of HelpNDoc: Easily create Help documents


Operador

Comandos ›› Comandos do Objeto ECF ›› Parâmetros - ACBrECF ››

Comando : ECF.Operador

Retorna o operador configurado no parâmetro do componente ACBrECF.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: What is a Help Authoring tool?


Mensagem de Aguarde

Comandos ›› Comandos do Objeto ECF ›› Parâmetros - ACBrECF ››

Comando : ECF.MsgAguarde

Retorna a Mensagem de Aguarde configurada no componente ACBrECF.

Exemplo de Resposta:

OK: Aguardando a resposta da Impressora: %d segundos

Created with the Personal Edition of HelpNDoc: Free PDF documentation generator


Mensagem de Trabalhando

Comandos ›› Comandos do Objeto ECF ›› Parâmetros - ACBrECF ››

Comando : ECF.MsgTrabalhando

Retorna a Mensagem de Trabalhando configurada no componente ACBrECF.

Exemplo de Resposta:

OK: Impressora está trabalhando

Created with the Personal Edition of HelpNDoc: Easily create CHM Help documents


Mensagem Pouco Papel

Comandos ›› Comandos do Objeto ECF ›› Parâmetros - ACBrECF ››

Comando : ECF.MsgPoucoPapel

Retorna o tempo em segundos configurado para apresentar a mensagem de pouco papel que está configurada no componente ACBrECF.

Exemplo de Resposta:

OK: 5

Created with the Personal Edition of HelpNDoc: Easily create Help documents


Exibe Mensagem

Comandos ›› Comandos do Objeto ECF ›› Parâmetros - ACBrECF ››

Comando : ECF.ExibeMensagem

Retorna se está habilitado para exibir mensagem no componente ACBrECF.

Exemplo de Resposta:

OK: True

Created with the Personal Edition of HelpNDoc: Easily create EPub books


Arredonda por Quantidade

Comandos ›› Comandos do Objeto ECF ›› Parâmetros - ACBrECF ››

Comando : ECF.ArredondaPorQtd

Retorna se o ECF realiza o arredondamento por quantidade.

Exemplo de Resposta:

OK: False

Created with the Personal Edition of HelpNDoc: Easily create iPhone documentation


Arredonda por MFD

Comandos ›› Comandos do Objeto ECF ›› Parâmetros - ACBrECF ››

Comando : ECF.ArredondaItemMFD

Retorna se o ECF realiza o arredondamento de itens por MFD.

Exemplo de Resposta:

OK: False

Created with the Personal Edition of HelpNDoc: Write eBooks for the Kindle


Set Arredonda MFD

Comandos ›› Comandos do Objeto ECF ›› Parâmetros - ACBrECF ›› Arredonda por MFD ››

Comando : ECF.SetArredondaItemMFD( bValor )

Atribui valor para o parâmetro de arredondamento de Item por MFD.

Parâmetros:

bValor - Informar "True" se deseja arredondar por MFD ou "False".

Exemplos:

ECF.SetArredondaItemMFD( false )

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Free Web Help generator


Bloqueia Mouse Teclado

Comandos ›› Comandos do Objeto ECF ›› Parâmetros - ACBrECF ››

Comando : ECF.BloqueiaMouseTeclado

Retorna se está habilitado para bloquear o mouse e o teclado no componente ACBrECF.

Exemplo de Resposta:

OK: True

Created with the Personal Edition of HelpNDoc: Easy EPub and documentation editor


Linhas entre Cupons

Comandos ›› Comandos do Objeto ECF ›› Parâmetros - ACBrECF ››

Comando : ECF.LinhasEntreCupons

Retorna o número de linhas entre os cupons que está configurada no componente ACBrECF.

Exemplo de Resposta:

OK: 2

Created with the Personal Edition of HelpNDoc: Full-featured Kindle eBooks generator


Máximo Linhas Buffer

Comandos ›› Comandos do Objeto ECF ›› Parâmetros - ACBrECF ››

Comando : ECF.MaxLinhasBuffer

Retorna o número máximo de Linhas a ser impressa simultaneamente em Relatórios Gerenciais ou Comprovantes Vinculados

Exemplo de Resposta:

OK: 2

Created with the Personal Edition of HelpNDoc: Free help authoring environment


Set Maximo Linhas Buffer

Comandos ›› Comandos do Objeto ECF ›› Parâmetros - ACBrECF ›› Máximo Linhas Buffer ››

Comando : ECF.SetMaxLinhasBuffer( nLinhas )

Muda o valor de MaxLinhasBuffer do componente ECF, determinando o número máximo de Linhas a ser impressa simultaneamente em Relatórios Gerenciais ou Comprovantes Vinculados.

Parâmetros:

nLinhas - Número máximo de linhas.Se for 0, não faz nenhuma verificação do número de linhas.

Exemplos:

ECF.SetMaxLinhasBuffer(2)

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Full-featured EPub generator


Página de Código

Comandos ›› Comandos do Objeto ECF ›› Parâmetros - ACBrECF ››

Comando : ECF.PaginaDeCodigo

Retorna a página de código que está configurada no componente ACBrECF.

Exemplo de Resposta:

OK: 3

Created with the Personal Edition of HelpNDoc: Free Web Help generator


ConfigBarras

Comandos ›› Comandos do Objeto ECF ›› Parâmetros - ACBrECF ››

Comando : ECF.ConfigBarras( nValorAltura, nValorLarguraLinha )

Muda o valor do TimeOut do componente ECF.

Parâmetros:

nValorAltura - Valor da Altura

nValorLarguraLinha - Valor da Largura da Linha

Exemplos:

ECF.ConfigBarras( 5, 5 )

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Easy CHM and documentation editor


Comandos do Objeto CHQ

Comandos ››

Comandos aceitos pelo Objeto CHQ

Created with the Personal Edition of HelpNDoc: Free CHM Help documentation generator


CHQ.Ativar

Comandos ›› Comandos do Objeto CHQ ››

Ativa a comunicação com a Impressora de Cheques. Não precisa ser usado... o ACBrMonitor ativará o componente se for necessário.

Created with the Personal Edition of HelpNDoc: Free EPub and documentation generator


CHQ.Desativar

Comandos ›› Comandos do Objeto CHQ ››

Desativa a comunicação com a impressora de Cheques

Created with the Personal Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


CHQ.Ativo

Comandos ›› Comandos do Objeto CHQ ››

Retorna “True” se a comunicação com a Impressora de Cheques está ativa

Created with the Personal Edition of HelpNDoc: Easily create EPub books


CHQ.ModeloStr

Comandos ›› Comandos do Objeto CHQ ››

Retorna Texto descritivo do Modelo da Impressora de Cheque selecionada no ACBrMonitor. Exemplo: “Bematech”

Created with the Personal Edition of HelpNDoc: Free help authoring environment


CHQ.Modelo

Comandos ›› Comandos do Objeto CHQ ››

Retorna Texto com o valor da propriedade “Modelo” de ACBrCHQ. Exemplo: “chqBematech”

Created with the Personal Edition of HelpNDoc: Free EPub and documentation generator


CHQ.Porta

Comandos ›› Comandos do Objeto CHQ ››

Retorna Texto com a Porta utilizada para a comunicação serial / paralela

Created with the Personal Edition of HelpNDoc: Free iPhone documentation generator


CHQ.Banco

Comandos ›› Comandos do Objeto CHQ ››

Retorna Texto com o Banco atual

Created with the Personal Edition of HelpNDoc: Easily create Help documents


CHQ.SetBanco( cCodBanco )

Comandos ›› Comandos do Objeto CHQ ››

Informa para a Impressora de Cheques o lay-out de Banco que será utilizado

Created with the Personal Edition of HelpNDoc: Free help authoring tool


CHQ.Cidade

Comandos ›› Comandos do Objeto CHQ ››

Retorna Texto com a Cidade atual

Created with the Personal Edition of HelpNDoc: Full-featured multi-format Help generator


CHQ.SetCidade( cCidade )

Comandos ›› Comandos do Objeto CHQ ››

Informa para a Impressora de Cheques a Cidade

Created with the Personal Edition of HelpNDoc: Easily create PDF Help documents


CHQ.Favorecido

Comandos ›› Comandos do Objeto CHQ ››

Retorna Texto com o Favorecido atual

Created with the Personal Edition of HelpNDoc: Free iPhone documentation generator


CHQ.SetFavorecido

Comandos ›› Comandos do Objeto CHQ ››

Informa para a Impressora de Cheques o Nome do Favorecido

Created with the Personal Edition of HelpNDoc: Free Kindle producer


CHQ.Observacao

Comandos ›› Comandos do Objeto CHQ ››

Retorna Texto com a Observação atual

Created with the Personal Edition of HelpNDoc: Free help authoring environment


CHQ.SetObservcao

Comandos ›› Comandos do Objeto CHQ ››

Informa para a Impressora de Cheques Observações a serem impressas no cheque

Created with the Personal Edition of HelpNDoc: Free iPhone documentation generator


CHQ.Valor

Comandos ›› Comandos do Objeto CHQ ››

Retorna Texto com o Valor atual

Created with the Personal Edition of HelpNDoc: Create iPhone web-based documentation


CHQ.SetValor

Comandos ›› Comandos do Objeto CHQ ››

Informa para a Impressora de Cheques o Valor a ser impresso

Created with the Personal Edition of HelpNDoc: Free help authoring environment


CHQ.Data

Comandos ›› Comandos do Objeto CHQ ››

Retorna Texto com a Data atual

Created with the Personal Edition of HelpNDoc: Easily create Help documents


CHQ.SetData

Comandos ›› Comandos do Objeto CHQ ››

Informa para a Impressora de Cheques a data a ser impressa

Created with the Personal Edition of HelpNDoc: Full-featured Kindle eBooks generator


CHQ.ChequePronto

Comandos ›› Comandos do Objeto CHQ ››

Retorna “True” se o papel estiver posicionado corretamente. Nota: Nem todas as impressoras de Cheque possuem este sensor, ou retornam essa informação.

Created with the Personal Edition of HelpNDoc: Free EPub and documentation generator


CHQ.ImprimirCheque

Comandos ›› Comandos do Objeto CHQ ››

Efetua a impressão do Cheque com os parâmetros informados anteriormente.

Created with the Personal Edition of HelpNDoc: Write EPub books for the iPad


CHQ.TravarCheque

Comandos ›› Comandos do Objeto CHQ ››

Aciona o mecanismo de travamento do documento. Disponível apenas em algumas impressoras de Cheque. Em alguns modelos é necessário enviar este comando antes de imprimir linhas avulsas

Created with the Personal Edition of HelpNDoc: Full-featured Documentation generator


CHQ.DestravarCheque

Comandos ›› Comandos do Objeto CHQ ››

Libera o documento preso com o comando TravarCheque

Created with the Personal Edition of HelpNDoc: Easily create Web Help sites


CHQ.ImprimirLinha ( cTexto )

Comandos ›› Comandos do Objeto CHQ ››

Impressão de linha de texto livre. Em alguns equipamentos é necessário executar TravarCheque antes, e DestravarCheque após o termino da impressão.

Created with the Personal Edition of HelpNDoc: Generate EPub eBooks with ease


CHQ.ImprimirVerso( cLinhas )

Comandos ›› Comandos do Objeto CHQ ››

Impressão de várias linhas de texto livre. Geralmente usadas para impressão de endereço e telefone no verso do cheque. Em alguns equipamentos é necessário executar TravarCheque antes, e DestravarCheque após o termino da impressão.

Created with the Personal Edition of HelpNDoc: Easily create EBooks


Comandos do Objeto GAV

Comandos ››

Comandos aceitos pelo Objeto GAV

Created with the Personal Edition of HelpNDoc: Produce electronic books easily


Ativo

Comandos ›› Comandos do Objeto GAV ››

Comando : GAV.Ativo

Retorna “True” se a comunicação com a Gaveta de Dinheiro está ativa

Exemplo de Resposta:

OK: True

Created with the Personal Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Ativar

Comandos ›› Comandos do Objeto GAV ››

Comando : GAV.Ativar

Ativa a comunicação com a Gaveta de Dinheiro. Não precisa ser usado... o ACBrMonitor ativará o componente se for necessário. (usado apenas em Gavetas Seriais)

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Full-featured Documentation generator


Desativar

Comandos ›› Comandos do Objeto GAV ››

Comando : GAV.Desativar

Desativa a comunicação com a Gaveta de Dinheiro (usado apenas em Gavetas Seriais)

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Easily create iPhone documentation


ModeloStr

Comandos ›› Comandos do Objeto GAV ››

Comando : GAV.ModeloStr

Retorna Texto descritivo do Modelo da Gaveta de Dinheiro que está conectado.

Exemplo de Resposta:

OK: Gerbo Serial

OK: Conectada a ECF

Created with the Personal Edition of HelpNDoc: Produce Kindle eBooks easily


Modelo

Comandos ›› Comandos do Objeto GAV ››

Comando : GAV.Modelo

Retorna Texto com o valor da propriedade “Modelo” de ACBrGAV.

Exemplo de Resposta:

OK: gavSerialGerbo

OK: gavImpressoraECF

Created with the Personal Edition of HelpNDoc: Full-featured EPub generator


Porta

Comandos ›› Comandos do Objeto GAV ››

Comando : GAV.Porta

Retorna Texto com a Porta utilizada para a comunicação serial / paralela.

Exemplo de Resposta:

OK: COM1

Created with the Personal Edition of HelpNDoc: Easy CHM and documentation editor


Abre Gaveta

Comandos ›› Comandos do Objeto GAV ››

Comando : GAV.AbreGaveta

Comanda a Abertura da Gaveta de Dinheiro.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Free CHM Help documentation generator


Gaveta Aberta

Comandos ›› Comandos do Objeto GAV ››

Comando : GAV.GavetaAberta

Retorna “True” se a Gaveta de Dinheiro estiver aberta.

Nota: Não é possível ler o estado da Gaveta em Impressoras Comuns (não-fiscal) de bobina.

Exemplo de Resposta:

OK: False

Created with the Personal Edition of HelpNDoc: Free CHM Help documentation generator


String Comando

Comandos ›› Comandos do Objeto GAV ››

Comando : GAV.StrComando

Retorna a “String” descrevendo o comando que será enviado para a Impressora para causar a abertura da gaveta. Veja GAV.SetStrComando .

Nota: Gavetas ligadas a Impressoras Matriciais Comuns,precisam de uma String de Comando que quando enviada para a impressora disparam a abertura da Gaveta.

Exemplo de Resposta:

OK: #027,v,#140 | Bematech

Created with the Personal Edition of HelpNDoc: Easily create EPub books


Set String Comando

Comandos ›› Comandos do Objeto GAV ›› String Comando ››

Comando : GAV.SetStrComando( cComando )

Útil apenas quando a Gaveta de Dinheiro está ligada a uma Impressora Comum de Bobina. Consulte o manual de sua impressora para saber a sequencia de caracteres de comando a enviar para a impressora para acionar a abertura da Gaveta. Separe todos os caracteres por virgula (,). Para definir caracteres de comando, utilize o sinal # seguido de 3 digitos com o código ASC II do caracter.

Parâmetros:

cComando - Comando para abrir a gaveta.

Exemplos:

GAV.SetStrComando(#027,v,#140 | Bematech)

Nota: para abrir a Gaveta em impressoras de bobina Bematech use o comando: #027,v,#140 ou seja, ESC+'v'+chr(140)

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Free Kindle producer


Intervalo Após Abertura

Comandos ›› Comandos do Objeto GAV ››

Comando : GAV.AberturaIntervalo

Retorna o mínimo intervalo de tempo de espera (em milisegundos) entre uma abertura da Gaveta e outra. Veja GAV.SetAberturaIntervalo .

Exemplo de Resposta:

OK: 300

Created with the Personal Edition of HelpNDoc: Free EPub and documentation generator


Set Intervalo Após Abertura

Comandos ›› Comandos do Objeto GAV ›› Intervalo Após Abertura ››

Comando : GAV.SetAberturaIntervalo( nIntervalo )

Define o intervalo de tempo de espera (em milisegundos) entre uma abertura da Gaveta e outra. Este tempo pode variar muito de um modelo de Gaveta e outro.

Parâmetros:

nIntervalo - Intervalo de tempo de espera (em milisegundos).

Exemplos:

GAV.SetAberturaIntervalo(500)

Nota: Gavetas ligadas diretamente a porta Serial demoram mais para carregar seu capacitor interno a fim de permitir uma nova abertura. (de 5 a 7 segundos)

Gavetas ligadas a Impressoras Fiscais ou Impressoras de Bobina podem ser re-abertas rapidamente (em média 300 a 500 milisegundos)

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: What is a Help Authoring tool?


Ação Abertura Antecipada

Comandos ›› Comandos do Objeto GAV ››

Comando : GAV.AberturaAntecipada

Retorna a ação que está configurado no componente ACBr para abertura antecipada da gaveta.

Nota: Existe 3 tipos de ação aaIgnorar, aaException e aaAguardar.

Exemplo de Resposta:

OK: aaIgnorar

Created with the Personal Edition of HelpNDoc: Full-featured Documentation generator


Comandos do Objeto DIS

Comandos ››

Comandos aceitos pelo Objeto DIS

Created with the Personal Edition of HelpNDoc: What is a Help Authoring tool?


DIS.Ativar

Comandos ›› Comandos do Objeto DIS ››

Ativa a comunicação com o Display de Mensagem

Created with the Personal Edition of HelpNDoc: Free iPhone documentation generator


DIS.Desativar

Comandos ›› Comandos do Objeto DIS ››

Desativa a comunicação com o Display de Mensagem

Created with the Personal Edition of HelpNDoc: Free EBook and documentation generator


DIS.Ativo

Comandos ›› Comandos do Objeto DIS ››

Retorna “True” se a comunicação com o Display está ativa

Created with the Personal Edition of HelpNDoc: Generate EPub eBooks with ease


DIS.ModeloStr

Comandos ›› Comandos do Objeto DIS ››

Retorna Texto descritivo do Modelo do Display selecionada no ACBrMonitor

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


DIS.Modelo

Comandos ›› Comandos do Objeto DIS ››

Retorna Texto com o valor da propriedade “Modelo” de ACBrDIS. Exemplo: “disKeytecTeclado”

Created with the Personal Edition of HelpNDoc: Free iPhone documentation generator


DIS.Porta

Comandos ›› Comandos do Objeto DIS ››

Retorna Texto com a Porta utilizada para a comunicação serial / paralela

Created with the Personal Edition of HelpNDoc: Easily create CHM Help documents


DIS.Trabalhando

Comandos ›› Comandos do Objeto DIS ››

Retorna “True” se a Thread do componente está executando alguma operação de exibição no Display (efeitos como Rolar, Vai e Vem, etc)

Created with the Personal Edition of HelpNDoc: Easily create Help documents


DIS.LinhasCount

Comandos ›› Comandos do Objeto DIS ››

Created with the Personal Edition of HelpNDoc: Free help authoring environment


DIS.SetLinhasCount

Comandos ›› Comandos do Objeto DIS ››

Created with the Personal Edition of HelpNDoc: Full-featured Documentation generator


DIS.Colunas

Comandos ›› Comandos do Objeto DIS ››

Created with the Personal Edition of HelpNDoc: Full-featured EPub generator


DIS.SetColunas

Comandos ›› Comandos do Objeto DIS ››

Created with the Personal Edition of HelpNDoc: Full-featured EPub generator


DIS.Alinhamento

Comandos ›› Comandos do Objeto DIS ››

Created with the Personal Edition of HelpNDoc: Easily create EBooks


DIS.SetAlinhamento

Comandos ›› Comandos do Objeto DIS ››

Created with the Personal Edition of HelpNDoc: Free EPub producer


DIS.Intervalo

Comandos ›› Comandos do Objeto DIS ››

Created with the Personal Edition of HelpNDoc: Free iPhone documentation generator


DIS.SetIntervalo

Comandos ›› Comandos do Objeto DIS ››

Created with the Personal Edition of HelpNDoc: Generate Kindle eBooks with ease


DIS.Passos

Comandos ›› Comandos do Objeto DIS ››

Created with the Personal Edition of HelpNDoc: Generate EPub eBooks with ease


DIS.SetPassos

Comandos ›› Comandos do Objeto DIS ››

Created with the Personal Edition of HelpNDoc: Produce Kindle eBooks easily


DIS.LimparDisplay

Comandos ›› Comandos do Objeto DIS ››

Created with the Personal Edition of HelpNDoc: Easy CHM and documentation editor


DIS.Escrever

Comandos ›› Comandos do Objeto DIS ››

Created with the Personal Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


DIS.PosicionarCursor

Comandos ›› Comandos do Objeto DIS ››

Created with the Personal Edition of HelpNDoc: Free EPub producer


DIS.Parar

Comandos ›› Comandos do Objeto DIS ››

Created with the Personal Edition of HelpNDoc: Free Kindle producer


DIS.Continuar

Comandos ›› Comandos do Objeto DIS ››

Created with the Personal Edition of HelpNDoc: Easily create EBooks


DIS.PararLinha

Comandos ›› Comandos do Objeto DIS ››

Created with the Personal Edition of HelpNDoc: Write EPub books for the iPad


DIS.ContinuarLinha

Comandos ›› Comandos do Objeto DIS ››

Created with the Personal Edition of HelpNDoc: Generate Kindle eBooks with ease


DIS.ExibirLinha

Comandos ›› Comandos do Objeto DIS ››

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


DIS.RolarLinha

Comandos ›› Comandos do Objeto DIS ››

Created with the Personal Edition of HelpNDoc: Easily create Web Help sites


Comandos do Objeto LCB

Comandos ››

Comandos aceitos pelo Objeto LCB

Created with the Personal Edition of HelpNDoc: iPhone web sites made easy


Ativo

Comandos ›› Comandos do Objeto LCB ››

Comando : LCB.Ativo

Retorna “True” se a comunicação com o dispositivo está ativa.

Exemplo de Resposta:

OK: True

Created with the Personal Edition of HelpNDoc: What is a Help Authoring tool?


Ativar

Comandos ›› Comandos do Objeto LCB ››

Comando : LCB.Ativar

Ativa a comunicação com o dispositivo Serial.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Free EBook and documentation generator


Desativar

Comandos ›› Comandos do Objeto LCB ››

Comando : LCB.Desativar

Desativa a comunicação com o dispositivo Serial.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: What is a Help Authoring tool?


Porta

Comandos ›› Comandos do Objeto LCB ››

Comando : LCB.Porta

Retorna Texto com a Porta utilizada para a comunicação serial / paralela.

Exemplo de Resposta:

OK: COM4

Created with the Personal Edition of HelpNDoc: Full-featured EPub generator


Intervalo

Comandos ›› Comandos do Objeto LCB ››

Comando : LCB.Intervalo

Retorna o intervalo que está configurada no componente ACBr para Leitor de Código de barras.

Exemplo de Resposta:

OK: 100

Created with the Personal Edition of HelpNDoc: Easy CHM and documentation editor


Set Intervalo

Comandos ›› Comandos do Objeto LCB ›› Intervalo ››

Comando : LCB.SetIntervalo( nValorIntervalo )

Muda o valor do Intervalo do componente Leitor de Código de Barras.

Parâmetros:

nValorIntervalo - Valor do Intervalo.

Exemplos:

LCB.SetIntervalo(50)

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Easily create EPub books


Última Leitura

Comandos ›› Comandos do Objeto LCB ››

Comando : LCB.UltimaLeitura

Retorna a Última Leitura realizada pelo Leitor de Códifo de Barras.

Exemplo de Resposta:

OK: 7891313262802#13

Created with the Personal Edition of HelpNDoc: Free help authoring tool


Último Código

Comandos ›› Comandos do Objeto LCB ››

Comando : LCB.UltimoCodigo

Retorna o Último Código capturado pelo Leitor de Código de Barras.

Exemplo de Resposta:

OK: 7891313262802

Created with the Personal Edition of HelpNDoc: Easily create HTML Help documents


Enviar String

Comandos ›› Comandos do Objeto LCB ››

Comando : LCB.EnviarString

Envia String para o componente ACBrLCB.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Ler String

Comandos ›› Comandos do Objeto LCB ››

Comando : LCB.LerString

Retorna a String de comando.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Full-featured multi-format Help generator


Usar Fila

Comandos ›› Comandos do Objeto LCB ››

Comando : LCB.UsarFila

Retorna se esta habilitado para usar a fila ( Acumula códigos lidos em uma fila interna ).

Exemplo de Resposta:

OK: True

Created with the Personal Edition of HelpNDoc: Easily create EPub books


Set Usar Fila

Comandos ›› Comandos do Objeto LCB ›› Usar Fila ››

Comando : LCB.SetUsarFila( bUsar )

Habilita ou desabilita o uso da fila interna.

Parâmetros:

bUsar - Habilitar = "true" e desabilitar = "false".

Exemplos:

LCB.SetUsarFila(true) - >Habilitado

LCB.SetUsarFila(false) - >Desabilitado

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Free PDF documentation generator


Fila Max Itens

Comandos ›› Comandos do Objeto LCB ››

Comando : LCB.FilaMaxItens

Retorna o número máximo de itens permitido na fila.

Exemplo de Resposta:

OK: 100

Created with the Personal Edition of HelpNDoc: Easily create PDF Help documents


Set Fila Max Itens

Comandos ›› Comandos do Objeto LCB ›› Fila Max Itens ››

Comando : LCB.SetFilaMaxItens( nMaxItens )

Atribui valor máximo de itens permitidos na fila.

Parâmetros:

nMaxItens - Valor máximo permitido de itens na fila.

Exemplos:

LCB.SetFilaMaxItens(50)

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Free EPub and documentation generator


Ler Fila

Comandos ›› Comandos do Objeto LCB ››

Comando : LCB.LerFila

Retorna o item que foi retirado(lido) da fila.

Exemplo de Resposta:

OK: 7891313262802

Created with the Personal Edition of HelpNDoc: Free CHM Help documentation generator


Apagar Fila

Comandos ›› Comandos do Objeto LCB ››

Comando : LCB.ApagarFila

Apaga todos os itens armazenados na fila.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Generate Kindle eBooks with ease


Fila Count

Comandos ›› Comandos do Objeto LCB ››

Comando : LCB.FilaCount

Retorna o número de itens que estão armazenados na fila.

Exemplo de Resposta:

OK: 4

Created with the Personal Edition of HelpNDoc: Generate EPub eBooks with ease


Prefixo A Excluir

Comandos ›› Comandos do Objeto LCB ››

Comando : LCB.PrefixoAExcluir

Retorna o prefixo do leitor a ser excluido.

Exemplo de Resposta:

OK: 789

Created with the Personal Edition of HelpNDoc: Free EBook and documentation generator


Set Prefixo a Excluir

Comandos ›› Comandos do Objeto LCB ›› Prefixo A Excluir ››

Comando : LCB.SetPrefixoAExcluir( cPrefixo )

Atribui o prefixo a ser excluido.

Parâmetros:

cPrefixo - Prefixo a ser excluido.

Exemplos:

LCB.SetPrefixoAExcluir(789) -> Código do produto de 5 dígitos = 25777 e leitor de código de barras sempre lê 78925777, ou seja, 789 é o prefixo no leitor.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Full-featured multi-format Help generator


Sufixo

Comandos ›› Comandos do Objeto LCB ››

Comando : LCB.Sufixo

Retorna o Sufixo definido no componente ACBrLCB.

Exemplo de Resposta:

OK: #13,#10

Created with the Personal Edition of HelpNDoc: Free CHM Help documentation generator


Set Sufixo

Comandos ›› Comandos do Objeto LCB ›› Sufixo ››

Comando : LCB.SetSufixo( cSufixo )

Atribui o sufixo.

Parâmetros:

cSufixo - Sufixo a ser atribuido.

Exemplos:

LCB.SetSufixo(#13)

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Excluir Sufixo

Comandos ›› Comandos do Objeto LCB ››

Comando : LCB.ExcluirSufixo

Retorna se esta habilitado para excluir sufixo.

Exemplo de Resposta:

OK: False

Created with the Personal Edition of HelpNDoc: Easily create Help documents


Set Excluir Sufixo

Comandos ›› Comandos do Objeto LCB ›› Excluir Sufixo ››

Comando : LCB.SetExcluirSufixo( bExcluir )

Habilita ou desabilita a exclusão do Sufixo.

Parâmetros:

bExcluir - Habilitar = "true" e desabilitar = "false".

Exemplos:

LCB.SetExcluirSufixo(true) - >Habilitado

LCB.SetExcluirSufixo(false) - >Desabilitado

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: What is a Help Authoring tool?


Comandos do Objeto BAL

Comandos ››

Comandos aceitos pelo Objeto BAL

Created with the Personal Edition of HelpNDoc: Full-featured multi-format Help generator


Ativo

Comandos ›› Comandos do Objeto BAL ››

Comando : BAL.Ativo

Retorna “True” se a comunicação com a Balança está ativa

Exemplo de Resposta:

OK: True

Created with the Personal Edition of HelpNDoc: Free Kindle producer


Ativar

Comandos ›› Comandos do Objeto BAL ››

Comando : BAL.Ativar

Ativa a comunicação com a Balança conectada na porta Serial.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Write EPub books for the iPad


Desativar

Comandos ›› Comandos do Objeto BAL ››

Comando : BAL.Desativar

Desativa a comunicação com a Balança.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Free EPub producer


ModeloStr

Comandos ›› Comandos do Objeto BAL ››

Comando : BAL.ModeloStr

Retorna Texto descritivo do Modelo da Balança que está conectado.

Exemplo de Resposta:

OK: Filizola

Created with the Personal Edition of HelpNDoc: Free CHM Help documentation generator


Modelo

Comandos ›› Comandos do Objeto BAL ››

Comando : BAL.Modelo

Retorna Texto com o valor da propriedade “Modelo” de ACBrBAL.

Exemplo de Resposta:

OK: balFilizola

Created with the Personal Edition of HelpNDoc: Free Web Help generator


Porta

Comandos ›› Comandos do Objeto BAL ››

Comando : BAL.Porta

Retorna Texto com a Porta utilizada para a comunicação serial / paralela.

Exemplo de Resposta:

OK: COM4

Created with the Personal Edition of HelpNDoc: Free help authoring environment


Intervalo

Comandos ›› Comandos do Objeto BAL ››

Comando : BAL.Intervalo

Retorna o intervalo que está configurada no componente ACBrECF.

Exemplo de Resposta:

OK: 100

Created with the Personal Edition of HelpNDoc: Produce electronic books easily


Set Intervalo

Comandos ›› Comandos do Objeto BAL ›› Intervalo ››

Comando : BAL.SetIntervalo( nValorIntervalo )

Muda o valor do Intervalo do componente Balança.

Parâmetros:

nValorIntervalo - Valor do Intervalo.

Exemplos:

BAL.SetIntervalo(50)

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Free help authoring tool


Ler Peso

Comandos ›› Comandos do Objeto BAL ››

Comando : BAL.LePeso [( nMillisecTimeOut )]

Retorna o Peso capturado pela balança.

Parâmetros:

nMillisecTimeOut - Tempo limite para tentar ler o peso válido. Se omitido será considerado 3000 millisec.

Exemplos:

BAL.LePeso

BAL.LePeso(2000)

Exemplo de Resposta:

OK: 0,305

Created with the Personal Edition of HelpNDoc: Write EPub books for the iPad


Último Peso Lido

Comandos ›› Comandos do Objeto BAL ››

Comando : BAL.UltimoPesoLido

Retorna o Último Peso lido pela balança.

Exemplo de Resposta:

OK: 0,305

Created with the Personal Edition of HelpNDoc: Easily create CHM Help documents


Última Resposta

Comandos ›› Comandos do Objeto BAL ››

Comando : BAL.UltimaResposta

Retorna a Última Resposta obtida pela balança.

Exemplo de Resposta:

OK: [STX]00305[ETX]

Created with the Personal Edition of HelpNDoc: What is a Help Authoring tool?


Monitorar Balança

Comandos ›› Comandos do Objeto BAL ››

Comando : BAL.MonitorarBalanca

Retorna “True” se a balança esta sendo monitorada.

Exemplo de Resposta:

OK: False

Created with the Personal Edition of HelpNDoc: Easily create iPhone documentation


Comandos do Objeto ETQ

Comandos ››

Comandos aceitos pelo Objeto ETQ

Created with the Personal Edition of HelpNDoc: Free CHM Help documentation generator


Ativo

Comandos ›› Comandos do Objeto ETQ ››

Comando : ETQ.Ativo

Retorna “True” se a comunicação com a Impressora de etiqueta estiver ativa.

Exemplo de Resposta:

OK: True

Created with the Personal Edition of HelpNDoc: Easily create PDF Help documents


Ativar

Comandos ›› Comandos do Objeto ETQ ››

Comando : ETQ.Ativar

Ativa a comunicação com a Impressora de etiqueta.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Free EBook and documentation generator


Desativar

Comandos ›› Comandos do Objeto ETQ ››

Comando : ETQ.Desativar

Desativa a comunicação com a Impressora de etiqueta.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Free iPhone documentation generator


ModeloStr

Comandos ›› Comandos do Objeto ETQ ››

Comando : ETQ.ModeloStr

Retorna Texto descritivo do Modelo da Impressora de Etiqueta que está conectado.

Exemplo de Resposta:

OK: PPLA

Created with the Personal Edition of HelpNDoc: Easily create EPub books


Modelo

Comandos ›› Comandos do Objeto ETQ ››

Comando : ETQ.Modelo

Retorna Texto com o valor da propriedade “Modelo” de ACBrETQ.

Exemplo de Resposta:

OK: etqPpla

Created with the Personal Edition of HelpNDoc: Full-featured Documentation generator


Porta

Comandos ›› Comandos do Objeto ETQ ››

Comando : ETQ.Porta

Retorna a Porta utilizada para a comunicação serial / paralela.

Exemplo de Resposta:

OK: COM4

Created with the Personal Edition of HelpNDoc: Generate Kindle eBooks with ease


Set Porta

Comandos ›› Comandos do Objeto ETQ ›› Porta ››

Comando : ETQ.SetPorta( cPorta )

Altera a porta de comunicação com a impressora de etiqueta.

Parâmetros:

cPorta - Valor da porta.

Exemplos:

ETQ.SetPorta(COM3)

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Full-featured Help generator


Temperatura

Comandos ›› Comandos do Objeto ETQ ››

Comando : ETQ.Temperatura

Retorna a Temperatura da Impressora.

Exemplo de Resposta:

OK: 10

Created with the Personal Edition of HelpNDoc: News and information about help authoring tools and software


Set Temperatura

Comandos ›› Comandos do Objeto ETQ ›› Temperatura ››

Comando : ETQ.SetTemperatura( nValor )

Altera a temperatura da Impressora.

Parâmetros:

nValor - Valor da temperatura.

Exemplos:

ETQ.SetTemperatura(15)

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Full-featured EBook editor


Avanço

Comandos ›› Comandos do Objeto ETQ ››

Comando : ETQ.Avanco

Retorna o número de avanços.

Exemplo de Resposta:

OK: 0

Created with the Personal Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


Set Avanço

Comandos ›› Comandos do Objeto ETQ ›› Avanço ››

Comando : ETQ.SetAvanco( nValor )

Altera o valor de avanço da Impressora.

Parâmetros:

nValor - Valor do avanço.

Exemplos:

ETQ.SetAvanco(2)

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Create iPhone web-based documentation


Imprimir Texto

Comandos ›› Comandos do Objeto ETQ ››

Comando : ETQ.ImprimirTexto(nOrientacao, nFonte, nMultiplicadorH , nMultiplicadorV, nVertical, nHorizontal, cTexto [, nSubFonte])

Prepara o texto a ser impresso na etiqueta.

Parâmetros:

nOrientacao - Tipo de orientação do texto. Informar conforme tabela de orientação.

nFonte - Número da fonte.

nMultiplicadorH - Multiplicador Horizontal (Número da fonte * multiplicador Horizontal).

nMultiplicadorV - Multiplicador Vertical (Número da fonte * multiplicador Vertical).

nVertical - Posição Inicial Vertical.

nHorizontal - Posição Inicial Horizontal.

cTexto - Texto a ser Impresso.

nSubFonte - Valor da Subfonte.Se omitido será considerado "0".

Tabela de Orientação:

0 -> Normal

1 -> 270º

2 -> 180º

3 -> 90º

Nota: É necessário chamar o comando ETQ.Imprimir para realizar a impressão.

Exemplos:

ETQ.ImprimirTexto( 0, 3, 1, 1, 160, 720, Teste de etiqueta)

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Imprimir Barras

Comandos ›› Comandos do Objeto ETQ ››

Comando : ETQ.ImprimirBarras( Orientacao, cTipoBarras, cLarguraBarraLarga , cLarguraBarraFina, nVertical, nHorizontal, cTexto, nAlturaCodBarras );

Created with the Personal Edition of HelpNDoc: Easily create EBooks


ETQ.ImprimirLinha

Comandos ›› Comandos do Objeto ETQ ››

ImprimirLinha( nVertical, nHorizontal, nLargura, nAltura );

Created with the Personal Edition of HelpNDoc: Full-featured Kindle eBooks generator


ETQ.ImprimirCaixa

Comandos ›› Comandos do Objeto ETQ ››

ImprimirCaixa( nVertical, nHorizontal, nLargura, nAltura, nEspessuraVertical, nEspessuraHorizontal );

Created with the Personal Edition of HelpNDoc: News and information about help authoring tools and software


ETQ.Imprimir

Comandos ›› Comandos do Objeto ETQ ››

Imprimir( nCopias, nAvancoEtq );

Created with the Personal Edition of HelpNDoc: Easy CHM and documentation editor


Limpar Memória

Comandos ›› Comandos do Objeto ETQ ››

Comando : ETQ.LimparMemoria

Retorna se o flag "ETQ.LimparMemoria" está ligado ou desligado

Exemplo de Resposta:

OK: False

Created with the Personal Edition of HelpNDoc: Free Web Help generator


Set Limpar Memoria

Comandos ›› Comandos do Objeto ETQ ›› Limpar Memória ››

Comando : ETQ.SetLimparMemoria( bValor )

Atribui valor para o parâmetro Limpeza de Memória do ETQ.

Quando verdadeiro o ACBrETQ enviará a impressora comando de Limpeza de memória, antes de iniciar a Impressão.

Utilizado apenas nos modelos EPL2 e PPLA

Parâmetros:

bValor - Informar "True" para habilitar a Limpeza de Memória antes da Impressão ou "False" para desabilitar

Exemplos:

ECF.SetLimparMemoria( false )

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Easy CHM and documentation editor


Unidade

Comandos ›› Comandos do Objeto ETQ ››

Created with the Personal Edition of HelpNDoc: Full-featured EBook editor


Imprimir Imagem

Comandos ›› Comandos do Objeto ETQ ››

Created with the Personal Edition of HelpNDoc: Free EPub and documentation generator


Carregar Imagem

Comandos ›› Comandos do Objeto ETQ ››

tem 2 comandos

Created with the Personal Edition of HelpNDoc: Generate EPub eBooks with ease


Comandos do Objeto BOLETO

Comandos ››

Comandos aceitos pelo objeto BOLETO.

Created with the Personal Edition of HelpNDoc: Write eBooks for the Kindle


BOLETO.ConfigurarDados

Comandos ›› Comandos do Objeto BOLETO ››

BOLETO.ConfigurarDados(cDados)

Parâmetros:

cDados - path do arquivo ini com o nome do arquivo, contendo os dados do cedente(Informações do cedente, conta, banco) ou conteúdo do arquivo ini.

Exemplos:

BOLETO.ConfigurarDados("c:\cedente.ini" ) – Está sendo informando o path do arquivo contendo as informações.

BOLETO.ConfiguraDados("[Cedente]

Cedente.Nome = Teste de Cedente

Cedente.CNPJCPF = 99.999.999/9999-99

[Banco]

Numero=237

CNAB=1") – Está sendo informado o conteúdo do arquivo INI

Notas:

Apenas devem ser informados os campos que deverão ser modificados, caso exista algum campo com conteúdo vazio, estas propriedades ficaram vazias no componente.

Exemplo de Resposta:

OK:

Exemplo de Ini com os dados do Cendente\Conta\Banco

[Cedente]

Nome=São João LTDA.

CNPJCPF= 99.999.999/9999-99

Logradouro=Rua Evaristo Mendes

Numero=200

Bairro=Centro

Cidade=Tatui

CEP=18.270-000

Complemento=Sala 10

UF=SP

RespEmis=0

TipoPessoa=1

CodigoCedente=123456

LayoutBol=3

CaracTitulo=0

[Conta]

Conta=99999

DigitoConta=9

Agencia=9999

DigitoAgencia=9

[Banco]

Numero=237

CNAB=1

IndiceACBr=5

Valores válidos para o campo RespEmis (Responsabilidade Emissão do Boleto)

0 - Cliente Emite

1 - Banco Emite

2 - Banco Reemite

3 - Banco não Reemite

Caso nenhum desses valores seja passado, será assumido como valor default 0.

Valores válidos para o campo TipoPessoa (Fisica,Juridica,Outras)

0 - Pessoa Física

1 - Pessoa Juridica

2 - Outros

Caso nenhum desses valores seja passado, será assumido como valor default 2.

Valores válidos para o campo CNAB (240 e 400)

0 - CNAB240

1 - CNAB400

Valores válidos para o campo INDICEACBR

Este campo não é obrigatório, desde que o número do banco seja informado.

Caso ambos sejam informados, o Número terá prioridade.

1 - Banco do Brasil

2 - Santander

3 - Caixa Econômica Federal (Convênio SIGCB)

4 - Caixa Econômica Federal (Convênio SICOB)

5 - Bradesco

6 - Itaú

7 - Banco Mercantil

8 - Sicred

9 - Bancoob

10 - Banrisul

11- HSBC

12- Banestes

13- Banco do Nordeste

14- Banco BRB

Valores válidos para o campo LayoutBol

0 - Padrão

1 - Carnê

2 - Fatura (Não implementado = Padrão)

3 - Padrão Entrega

Valores válidos para o campo CaracTitulo

0 - Cobrança Simples

1 - Cobrança Vinculada

2 - Cobrança Caucionada

3 - Cobrança Descontada

4 - Cobrança Vendor

Created with the Personal Edition of HelpNDoc: Easily create PDF Help documents


BOLETO.Imprimir

Comandos ›› Comandos do Objeto BOLETO ››

Imprime os boletos adicionados na lista, de acordo com as configurações feitas no ACBrMonitor(PDF,HTML,Impressora)

Created with the Personal Edition of HelpNDoc: Full-featured EBook editor


BOLETO.GerarPDF

Comandos ›› Comandos do Objeto BOLETO ››

Lista no formato PDF os boletos existentes na lista de titulos.

Created with the Personal Edition of HelpNDoc: Easily create EBooks


BOLETO.GerarHTML

Comandos ›› Comandos do Objeto BOLETO ››

Lista no formato HTML os boletos existentes na lista de titulos.

Created with the Personal Edition of HelpNDoc: Write EPub books for the iPad


BOLETO.EnviarEmail

Comandos ›› Comandos do Objeto BOLETO ››

BOLETO.EnviarEmail([cDestinatario])

Parâmetros:

Gera um arquivo PDF com os boletos existentes na lista de titulos e envia como anexo para o e-mail informado em "cDestinatario", se o parâmetro não for informado, será utilizado o email informado no Sacado.

Created with the Personal Edition of HelpNDoc: Easily create Web Help sites


BOLETO.GerarRemessa

Comandos ›› Comandos do Objeto BOLETO ››

BOLETO.GerarRemessa(cDirArqRemessa,nNumeroArquivo[,nNomeArquivo])

cDirArqRemessa - Diretório onde deverá ser gravado o arquivo de Remessa.

nNumeroArquivo - Numero do arquivo que deve ser gerado, utilizado pelo Bradesco, funciona como um contador de arquivos remessa já enviados.

nNomeArquivo - nome do arquivo . Parâmetro opcional, caso não seja informado o ACBrMonitor irá calcular o nome do arquivo.

Exemplos:

BOLETO.GerarRemessa("c:\remessa\",1,000001.rem ) – Irá gerar o arquivo de remessa no diretório "C:\Remessa", com o nome formatado de acordo com o banco para o qual esta sendo feita a remessa .000001.rem

BOLETO.GerarRemessa("c:\remessa\" ) – Irá gerar o arquivo de remessa no diretório "C:\Remessa", com o nome formatado de acordo com o banco para o qual esta sendo feita a remessa . No caso do Bradesco cb00002.rem, considerando que já exista o arquivo cb00001.rem em C:\Remessa.

Created with the Personal Edition of HelpNDoc: Free iPhone documentation generator


BOLETO.LerRetorno

Comandos ›› Comandos do Objeto BOLETO ››

BOLETO.LerRetorno(cDirArqRetorno[,cNomeArquivo])

cDirArqRetorno - Diretório onde está o arquivo de Retorno.

cNomeArquivo - Nome do arquivo de retorno, pode ser informado o path completo do arquivo ou somente o nome.

Exemplos:

BOLETO.GerarLerRetorno("c:\retorno\","00001.ret" ) – Irá buscar o arquivo de retorno no diretório "C:\Retorno".

BOLETO.GerarRemessa("c:\retorno\","c:\retorno\00001.ret" )

Após a leitura do arquivo retorno será gerado no mesmo diretório informado no comando o arquivo Retorno.Ini, contendo

as informações do títulos lidos no arquivo do arquivo de retorno fornecido pelo banco de forma parecida ao que é exigido no

arquivo ini de inclusão de titulos.

Exemplo de arquivo gerado pelo ACBrMonitor

[CEDENTE]

Nome=Empresa Teste

CNPJCPF=12.345.678/9012-34

CodigoCedente=123456

MODALIDADE=

CODTRANSMISSAO=

CONVENIO=

[BANCO]

Numero=104

IndiceACBr=4

[CONTA]

Conta=12345

DigitoConta=6

Agencia=12345

DigitoAgencia=5

[Titulo1]

Sacado.Nome=

Sacado.CNPJCPF=

Vencimento=29/06/2012

DataDocumento=30/12/1899

NumeroDocumento=NF 12345

DataProcessamento=06/06/2013

NossoNumero=12345

Carteira=123

ValorDocumento=300

DataOcorrencia=27/06/2012

DataCredito=28/06/2012

DataBaixa=29/06/2012

ValorDespesaCobranca=3,26

ValorAbatimento=0

ValorDesconto=0

ValorMoraJuros=0

ValorIOF=0

ValorOutrasDespesas=0

ValorOutrosCreditos=0

ValorRecebido=300

SeuNumero=NF 00548 12345

CodTipoOcorrencia=toRetornoLiquidado

DescricaoTipoOcorrencia=06-Liquidação

MotivoRejeicao1=04-Compensação Eletrônica.

....

Created with the Personal Edition of HelpNDoc: Generate EPub eBooks with ease


BOLETO.LimparLista

Comandos ›› Comandos do Objeto BOLETO ››

Limpa a lista de titulos

Created with the Personal Edition of HelpNDoc: Full-featured multi-format Help generator


BOLETO.TotalTitulosLista

Comandos ›› Comandos do Objeto BOLETO ››

Retorna o número de títulos adicionados na lista.

Exemplo de Retorno

OK: 10

Created with the Personal Edition of HelpNDoc: Free HTML Help documentation generator


BOLETO.IncluirTitulo

Comandos ›› Comandos do Objeto BOLETO ››

BOLETO.IncluirTitulos(cDados[,cTipoDeSaida])

Parâmetros:

cDados - path do arquivo ini com o nome do arquivo, contendo os titulos a serem incluídos ou conteúdo do arquivo ini.

cTipoDeSaida - Tipo de saída dos boletos adicionados (P - PDF , I - Impressora ou E - E-mail). Pode ser omitido, neste caso os títulos apenas serão inseridos na lista, caso contrário os boletos darão saída de acordo com o parâmetro. A opção E-mail gera um arquivo PDF com os boletos existentes na lista de titulos e envia como anexo para o e-mail do Sacado.

Exemplos:

BOLETO.IncluirTitulos("c:\titulos.ini" ,"I") – Está sendo informando o path do arquivo contendo as informações dos titulos, após adicionar os titulos na lista será dado saída para a impressora.

BOLETO.IncluirTitulos("c:\titulos.ini" ,"P") – Está sendo informando o path do arquivo contendo as informações dos titulos, após adicionar os titulos na lista será dado saída para um arquivo PDF.

BOLETO.IncluirTitulos("c:\titulos.ini" ,"E") – Está sendo informando o path do arquivo contendo as informações dos titulos, após adicionar os titulos na lista será feito o envio dos boletos para o e-mail do Sacado.

BOLETO.IncluirTitulos("c:\titulos.ini") – Está sendo informando o path do arquivo contendo as informações dos titulos, apenas serão adicionados os titulos na lista.

BOLETO.IncluirTitulos("[Titulo1]

NumeroDocumento=000010

NossoNumero=0000001

Carteira=20

ValorDocumento=100,50

Sacado.NomeSacado=Sacado Teste

Sacado.CNPJCPF=123.456.789.01

Sacado.Logradouro=Rua das Flores

Sacado.Numero=1000

Sacado.Bairro=Centro

Sacado.Complemento=

Sacado.Cidade=Cidade Teste

Sacado.UF=SP

Sacado.CEP=12345.678

Mensagem=teste1|teste2

ValorMoraJuros=0,50

Vencimento=10/09/2010") – Está sendo informado o conteúdo do arquivo INI.

Notas:

Quando houver mais de um titulo a ser adicionado será necessário seguir uma numeração sequencial para o nome de cada sessão do INI, caso contrário não serão lidos todos os titulos existentes no arquivo. Exemplo: [titulo1],[titulo2],.....[titulo10]

Exemplo de Resposta:

OK:

Modelo de Ini de Titulos:

[Titulo1]

NumeroDocumento=000010

NossoNumero=0000001

Carteira=20

ValorDocumento=100,50

Vencimento=10/09/2010

ValorMoraJuros=0,50

DataDocumento=10/08/2010

DataProcessamento=10/08/2010

DataAbatimento=05/09/2010

DataDesconto=07/09/2010

DataMoraJuros=12/09/2010

DataProtesto=10/10/2010

ValorAbatimento=5,00

ValorDesconto=0,50

ValorMoraJuros=0,55

ValorIOF=3,50

ValorOutrasDespesas=2,50

PercentualMulta=05,00

LocalPagamento=Pagável em qualquer agência bancária mesmo após o vencimento

Especie=DM

EspecieMod=R$

Sacado.NomeSacado=Sacado Teste

Sacado.CNPJCPF=999.999.999.99

Sacado.Pessoa=0

Sacado.Logradouro=Rua Jose Rodrigues

Sacado.Numero=100

Sacado.Bairro=Jardim Moderno

Sacado.Complemento=Casa

Sacado.Cidade=Tatui

Sacado.UF=SP

Sacado.CEP=18277.500

Sacado.Email=teste@email.com

Mensagem=teste1|teste2

Instrucao1=10

Instrucao2=11

Aceite=1

OcorrenciaOriginal=0

Parcela=1

TotalParcelas=1

SeuNumero=000020

TipoDiasProtesto=1

TipoImpressao=1

*Os campos em negrito são obrigatóriamente devem constar no arquivo.

Como preencher o campo Sacado.Pessoa (Fisica ou Juridica)

0 - Pessoa Física

1 - Pessoa Juridica

2 - Outras

Caso nenhum desses valores seja passado, será assumido como valor default 2.

Como preencher o campo Aceite (Sim ou Não)

0 - Sim

1 - Não

Caso nenhum desses valores seja passado, será assumido como valor default 1.

Como preencher o campo OcorrenciaOriginal (Tipo de Ocorrência)

0 - RemessaRegistrar

1 - RemessaBaixar

2 - RemessaDebitarEmConta

3 - RemessaConcederAbatimento,

4 - RemessaCancelarAbatimento,

5 - RemessaConcederDesconto,

6 - RemessaCancelarDesconto,

7 - RemessaAlterarVencimento,

8 - RemessaProtestar,

9 - RemessaSustarProtesto,

10 - RemessaCancelarIntrucaoProtestoBaixa,

11 - RemessaCancelarInstrucaoProtesto,

12 - RemessaDispensarJuros,

13 - RemessaAlterarNomeEnderecoSacado,

14 - RemessaAlterarNumeroControle,

15 - RemessaOutrasOcorrencias,

16 - RemessaAlterarControleParticipante,

17 - RemessaAlterarSeuNumero,

18 - RemessaTransfCessaoCreditoIDProd10,

19 - RemessaTransferenciaCarteira,

20 - RemessaDevTransferenciaCarteira,

21 - RemessaDesagendarDebitoAutomatico,

22 - RemessaAcertarRateioCredito,

23 - RemessaCancelarRateioCredito,

24 - RemessaAlterarUsoEmpresa,

25 - RemessaNaoProtestar,

26 - RemessaProtestoFinsFalimentares,

27 - RemessaBaixaporPagtoDiretoCedente,

28 - RemessaCancelarInstrucao,

29 - RemessaAlterarVencSustarProtesto,

30 - RemessaCedenteDiscordaSacado,

31 - RemessaCedenteSolicitaDispensaJuros,

32 - RemessaOutrasAlteracoes,

33 - RemessaAlterarModalidade,

Caso nenhum desses valores seja passado, será assumido como valor default 0.

Como preencher o campo TipoDiasProtesto (Tipo de Ocorrência)

0 - Dias corridos

1 - Dias úteis

Como preencher o campo TipoImpressao (Tipo de Impressão)

0 - Carnê

1 - Padrão

Created with the Personal Edition of HelpNDoc: Easily create Web Help sites


Boleto.TamNossoNumero

Comandos ›› Comandos do Objeto BOLETO ››

Retorna o tamanho máximo do Nosso Número de acordo com as regras de cada banco, para tanto é necessário que a

Carteira de Cobrança seja informada.

BOLETO.IncluirTitulos(cCarteira)

cCarteira - Código da Carteira de Cobrança.

Exemplo de Comando e seu Retorno

BOLETO.IncluirTitulos(1)

OK: 10

Created with the Personal Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Como imprimir um Boleto

Comandos ›› Comandos do Objeto BOLETO ››

Passos para imprimir Boletos

A impressão dos boletos pode ser feita em diversas sequências diferentes, utilizando-se os comandos separados para cada passo ou as funções extras do comando IncluirTitulo.

Para que ao imprimir novos titulos os antigos não sejam impressos novamente, sempre utilize o comando LimparLista.

Modo 1 - Fazendo os passos separadamente

1 - Limpe a lista de titulos.

Exemplo: BOLETO.LimparLista

2 - Utilize o comando ConfiguraDados para configurar as informações da Conta e do Cedente, pode ser informando o Path do arquivo INI ou então o seu conteúdo.

Exemplo: BOLETO.ConfigurarDados("c:\cedente.ini" )

3 - Utilize o comando IncluirTitulo para adicionar os boletos a serem impressos, pode ser informando o Path do arquivo INI ou então o seu conteúdo.

Exemplo: BOLETO.IncluirTitulos("c:\titulos.ini")

4 - Utilize o comando Imprimir para que os boletos enviados no comando IncluirTitulo sejam impressos.

Exemplo: BOLETO.Imprimir

Modo 2 - Informando os dados da Conta e Cedente através do IncluirTitulo

1 - Limpe a lista de titulos.

Exemplo: BOLETO.LimparLista

2 - Utilize o comando IncluirTitulo, informando o caminho para o arquivo com os titulos, para informar os Dados do Conta e do Cedente e também para adicionar os boletos a serem impressos.

Exemplo: BOLETO.IncluirTitulos("c:\titulos.ini")

3 - Utilize o comando Imprimir para que os boletos enviados no comando IncluirTitulo sejam impressos.

Exemplo: BOLETO.Imprimir

Modo 3 - Utilizando apenas o IncluirTitulo

1 - Limpe a lista de titulos.

Exemplo: BOLETO.LimparLista

2 - Neste modo, todas as operações necessárias são feitas através do comando IncluirTitulo, para tanto, utilize o comando da seguinte maneira:

Exemplo: BOLETO.IncluirTitulos("c:\titulos.ini", "I")

O arquivo titulos.ini, deverá conter as informações referentes a Conta e ao Cedente e também os boletos a serem impressos.

O parâmetro "I" significa que após efetuar a configuração e incluir os títulos, em seguida deve ser feita a impressão dos mesmos.

Created with the Personal Edition of HelpNDoc: Full-featured Kindle eBooks generator


Comandos do Objeto CEP

Comandos ››

Faz consulta HTTP em WebServices que fornecem dados do Endereço baseado no CEP ou Logradouro fornecido

  • Selecione o WebService desejado na aba "Consultas" do ACBrMonitor
  • Se necessário ajuste o Proxy de http

A resposta será no formato .INI e poderá conter vários endereços (principalmente quando usada busca por Logradouro)

Exemplo de Resposta:

OK: [Endereco1]

CEP=18270-170

Tipo_Logradouro=Rua

Logradouro=Coronel Aureliano de Camargo

Bairro=Centro

Municipio=Tatuí

UF=SP

IBGE_Municipio=3554003

IBGE_UF=35

Created with the Personal Edition of HelpNDoc: Full-featured EPub generator


CEP.BuscarPorCEP

Comandos ›› Comandos do Objeto CEP ››

Retorna dados de um Endereço baseado no CEP fornecido

CEP.BuscarPorCEP( cCEP )

Exemplo de Resposta:

CEP.BuscarPorCEP( "18270170" )

OK: [Endereco1]

CEP=18270-170

Tipo_Logradouro=Rua

Logradouro=Coronel Aureliano de Camargo

Bairro=Centro

Municipio=Tatuí

UF=SP

IBGE_Municipio=3554003

IBGE_UF=35

Created with the Personal Edition of HelpNDoc: Free Web Help generator


CEP.BuscarPorLogradouro

Comandos ›› Comandos do Objeto CEP ››

Retorna dados de Endereços baseado no Logradouro fornecido

CEP.BuscarPorLogradouro( cCidade, cTipoLogradouro, cLogradouro, cUF [, cBairro ] )

Notas:

Não está disponível em todos os WebServices.

Alguns WebServices só retornam se o nome do logradouro for informado por completo

Exemplo de Resposta: (usando o WebService wsBuscarCEP)

CEP.BuscarPorLogradouro( "Tatui", "Rua", "Aureliano", "SP" )

OK: [Endereco1]

CEP=18274552

Tipo_Logradouro=Rua

Logradouro=Aureliano Lopes Guimarães

Bairro=Jardim Gramado

Municipio=Tatuí

UF=SP

IBGE_Municipio=3554003

IBGE_UF=35

[Endereco2]

CEP=18270170

Tipo_Logradouro=Rua

Logradouro=Coronel Aureliano de Camargo

Bairro=Centro

Municipio=Tatuí

UF=SP

IBGE_Municipio=3554003

IBGE_UF=35

Created with the Personal Edition of HelpNDoc: Produce electronic books easily


Comandos do Objeto IBGE

Comandos ››

Faz consulta HTTP na página do IBGE, capturando informações sobre a Cidade na página retornada.

http://www.ibge.gov.br/home/geociencias/areaterritorial/area.shtm

  • Se necessário ajuste o Proxy de http

A resposta será no formato .INI e poderá conter várias Cidades

Exemplo de Resposta:

OK: [Endereco1]

CEP=18270-170

Tipo_Logradouro=Rua

Logradouro=Coronel Aureliano de Camargo

Bairro=Centro

Municipio=Tatuí

UF=SP

IBGE_Municipio=3554003

IBGE_UF=35

Created with the Personal Edition of HelpNDoc: Free EPub producer


IBGE.BuscarPorCodigo

Comandos ›› Comandos do Objeto IBGE ››

Retorna dados de uma Cidade baseado no Código fornecido

IBGE.BuscarPorCodigo( cCodigoIBGE )

Exemplo de Resposta:

IBGE.BuscarPorCodigo("3554003")

OK: [Cidade1]

UF=SP

CodUF=35

Municipio=Tatuí

CodMunicio=3554003

Area=524,156

Created with the Personal Edition of HelpNDoc: News and information about help authoring tools and software


IBGE.BuscarPorNome

Comandos ›› Comandos do Objeto IBGE ››

Retorna dados de uma Cidade baseado no Nome da Cidade fornecido

IBGE.BuscarPorNome( cNomeCidade )

Exemplo de Resposta:

IBGE.BuscarPorNome("Petrolina")

OK: [Cidade1]

UF=PE

CodUF=26

Municipio=Petrolina

CodMunicio=2611101

Area=4558,537

[Cidade2]

UF=GO

CodUF=52

Municipio=Petrolina de Goiás

CodMunicio=5216809

Area=540,451

Created with the Personal Edition of HelpNDoc: Free EPub and documentation generator


Comandos do Objeto EMAIL

Comandos ››

Permite o envio de e-mails em html e/ou texto puro com ou sem anexo(s).

Exemplo:

EMAIL.Novo

EMAIL.ConfirmarLeitura(True)

EMAIL.AdicionaPara("usuario@servidor.com")

EMAIL.Assunto("Teste de e-mail")

EMAIL.TextoMensagem("Veja anexo!")

EMAIL.AdicionaAnexo("C:\arquivo.pdf")

EMAIL.Enviar

Created with the Personal Edition of HelpNDoc: Easily create EPub books


Configurações Iniciais

Comandos ›› Comandos do Objeto EMAIL ››

Antes de usar o Objeto EMAIL, é necessário configurar no ACBrMonitor (aba E-mail) uma conta de e-mail (servidor SMTP), que será usada para realizar os envios. Esta mesma aba, permite testar se as configurações estão corretas. Um e-mail de teste é enviado para a própria conta. Veja, na figura abaixo, a área de configuração destacada por um retângulo vermelho:

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


EMAIL.Novo

Comandos ›› Comandos do Objeto EMAIL ››

Comando para iniciar um novo e-mail. O ideal é aguardar a resposta OK, antes de enviar os outros comandos do e-mail.

Exemplo de Resposta:

OK: Novo E-mail iniciado!

Created with the Personal Edition of HelpNDoc: Free help authoring environment


EMAIL.AdicionaPara

Comandos ›› Comandos do Objeto EMAIL ››

Este comando adiciona um e-mail na lista “Para” ( To: ).

EMAIL.AdicionaPara(cEmail, cNome)

Parâmetros:

cEmail – E-mail do destinatário.

cNome – Nome do destinatário.

Exemplo:

EMAIL.AdicionaPara(“usuario@servidor.com”, “Nome Destinatário”)

Exemplo de Resposta:

OK: E-mail usuario@servidor.com adicionado a lista "Para".

Notas:

Este comando verifica se a sintaxe do e-mail é válida. Se não for válida retorna ERRO. O ideal é tratar a resposta, antes de enviar outros comandos de e-mail.

Created with the Personal Edition of HelpNDoc: Free Kindle producer


EMAIL.AdicionaCC

Comandos ›› Comandos do Objeto EMAIL ››

Este comando adiciona um e-mail para a lista “CC” ( Com Cópia: ).

EMAIL.AdicionaCC(cEmail, cNome)

Parâmetros:

cEmail – E-mail do destinatário.

cNome – Nome do destinatário.

Exemplo:

EMAIL.AdicionaCC(“usuario@servidor.com”, “Nome Destinatário”)

Exemplo de Resposta:

OK: E-mail usuario@servidor.com adicionado a lista "CC".

Notas:

Este comando verifica se a sintaxe do e-mail é válida. Se não for válida retorna ERRO. O ideal é tratar a resposta, antes de enviar outros comandos de e-mail.

Created with the Personal Edition of HelpNDoc: Generate EPub eBooks with ease


EMAIL.AdicionaBCC

Comandos ›› Comandos do Objeto EMAIL ››

Este comando adiciona um e-mail para a lista “BCC” ( Com Cópia Oculta: ).

EMAIL.AdicionaBCC(cEmail)

Parâmetro:

cEmail – E-mail do destinatário.

Exemplo:

EMAIL.AdicionaBCC(“usuario@servidor.com”)

Exemplo de Resposta:

OK: E-mail usuario@servidor.com adicionado a lista "BCC".

Notas:

Este comando verifica se a sintaxe do e-mail é válida. Se não for válida retorna ERRO. O ideal é tratar a resposta, antes de enviar outros comandos de e-mail.

Created with the Personal Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


EMAIL.AdicionaResponderA

Comandos ›› Comandos do Objeto EMAIL ››

Este comando adiciona um e-mail para a lista “Responder a” ( ReplyTo: ).

EMAIL.AdicionaResponderA(cEmail, cNome)

Parâmetros:

cEmail – E-mail do destinatário.

cNome – Nome do destinatário.

Exemplo:

EMAIL.AdicionaResponderA(“usuario@servidor.com”, “Nome Destinatário”)

Exemplo de Resposta:

OK: E-mail usuario@servidor.com adicionado a lista "ReplyTo".

Notas:

Este comando verifica se a sintaxe do e-mail é válida. Se não for válida retorna ERRO. O ideal é tratar a resposta, antes de enviar outros comandos de e-mail.

Created with the Personal Edition of HelpNDoc: Free EPub producer


EMAIL.Assunto

Comandos ›› Comandos do Objeto EMAIL ››

Assunto (título) do e-mail.

EMAIL.Assunto(cAssunto)

Parâmetro:

cAssunto – Texto do assunto.

Exemplo:

EMAIL.Assunto(“Texto do assunto do e-mail”)

Created with the Personal Edition of HelpNDoc: Full-featured Kindle eBooks generator


EMAIL.TextoMensagem

Comandos ›› Comandos do Objeto EMAIL ››

Mensagem do e-mail. Pode ser texto simples ou html (veja o comando EMAIL.UsarHTML).

EMAIL.TextoMensagem(cTexto)

Parâmetro:

cTexto – Texto da mensagem.

Exemplo:

EMAIL.TextoMensagem(“Texto da mensagem do e-mail”)

Created with the Personal Edition of HelpNDoc: Easy CHM and documentation editor


EMAIL.TextoAlternativo

Comandos ›› Comandos do Objeto EMAIL ››

Mensagem alternativa em texto puro. Geralmente usado quando o texto da mensagem está em html. O texto alternativo será exibido caso o e-mail seja visualizado em um leitor de e-mails que não suporte html.

EMAIL.TextoAlternativo(cTexto)

Parâmetro:

cTexto – Texto puro alternativo.

Exemplo:

EMAIL.TextoAlternativo(“Texto puro alternativo do e-mail”)

Created with the Personal Edition of HelpNDoc: Free help authoring environment


EMAIL.UsarHTML

Comandos ›› Comandos do Objeto EMAIL ››

Ativa ou desativa o reconhecimento de HTML no texto da mensagem.

EMAIL.UsarHTML(bValor)

Parâmetro:

bValor – Padrão False.

Exemplo:

EMAIL.UsarHTML(True)

Created with the Personal Edition of HelpNDoc: Easily create Web Help sites


EMAIL.TentativasEnvio

Comandos ›› Comandos do Objeto EMAIL ››

Configura o número de tentativas de envio até o servidor SMTP responder.

EMAIL.TentativasEnvio(nValor)

Parâmetro:

nValor – Número de tentativas. Padrão 3.

Exemplo:

EMAIL.TentativasEnvio(5)

Created with the Personal Edition of HelpNDoc: News and information about help authoring tools and software


EMAIL.ConfirmarLeitura

Comandos ›› Comandos do Objeto EMAIL ››

Ativa ou desativa pedido de confirmação de leitura.

EMAIL.ConfirmarLeitura(bValor)

Parâmetro:

bValor – Padrão False.

Exemplo:

EMAIL.ConfirmarLeitura(True)

Created with the Personal Edition of HelpNDoc: Easily create HTML Help documents


EMAIL.SetPrioridade

Comandos ›› Comandos do Objeto EMAIL ››

Configura a prioridade de envio do e-mail.

EMAIL.SetPrioridade(cNivel)

Parâmetro:

cNivel – Padrão “normal”. Valores permitidos: (naodefinida, alta, normal e baixa)

Exemplo:

EMAIL.SetPrioridade(“alta”)

Created with the Personal Edition of HelpNDoc: Easily create HTML Help documents


EMAIL.SetCodificacao

Comandos ›› Comandos do Objeto EMAIL ››

Configura a tabela de caracteres (charset) que será usada para o assunto e a mensagem do e-mail.

EMAIL.SetCodificacao(cCharset)

Parâmetro:

cCharset – Padrão ISO_8859_1. Valores permitidos: ARMASCII, BIG5, BIG5_HKSCS, C99, CP1125, CP1133, CP1250, CP1251, CP1252, CP1253, CP1254, CP1255, CP1256, CP1257, CP1258, CP1361, CP737, CP775, CP852, CP853, CP855, CP857, CP858, CP860, CP861, CP862, CP863, CP864, CP865, CP866, CP869, CP874, CP895, CP932, CP936, CP949, CP950, EUC_JP, EUC_KR, EUC_TW, GB18030, GB1988_80, GB2312, GB2312_80, GEORGIAN_AC, GEORGIAN_PS, HZ, ISO_2022_CN, ISO_2022_CNE, ISO_2022_JP, ISO_2022_JP1, ISO_2022_JP2, ISO_2022_KR, ISO_8859_1, ISO_8859_10, ISO_8859_13, ISO_8859_14, ISO_8859_15, ISO_8859_16, ISO_8859_2, ISO_8859_3, ISO_8859_4, ISO_8859_5, ISO_8859_6, ISO_8859_7, ISO_8859_8, ISO_8859_9, ISO_IR_14, ISO_IR_149, ISO_IR_165, JAVA, JIS_X0201, JIS_X0208, JIS_X0212, KOI8_R, KOI8_RU, KOI8_T, KOI8_U, MAC, MACAR, MACCE, MACCRO, MACCYR, MACGR, MACHEB, MACICE, MACRO, MACTH, MACTU, MACUK, MULELAO, NEXTSTEP, ROMAN8, SHIFT_JIS, TCVN, TIS620, UCS_2, UCS_2LE, UCS_4, UCS_4LE, UTF_16, UTF_16LE, UTF_32, UTF_32LE, UTF_7, UTF_7mod, UTF_8, VISCII

Exemplo:

EMAIL.SetCodificacao(“UTF_8”)

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


EMAIL.AdicionaAnexo

Comandos ›› Comandos do Objeto EMAIL ››

Adiciona um arquivo como anexo ao e-mail.

EMAIL.AdicionaAnexo(cArquivo, cNome)

Parâmetros:

cArquivo – Caminho completo do arquivo que será anexado.

cNome – Nome de referência do arquivo.

Exemplo:

EMAIL.AdicionaAnexo(“C:\documentos\memorando.doc”, “DocMemorando”)

Exemplo de Resposta:

OK: Anexo incluído com sucesso!

Notas:

A propriedade cNome só é considerada quando o e-mail é enviado no formato html. É muito útil quando uma imagem é anexada para ser usada no corpo da mensagem em html do e-mail.

Created with the Personal Edition of HelpNDoc: Easily create EBooks


EMAIL.Enviar

Comandos ›› Comandos do Objeto EMAIL ››

Depois de usar os comandos disponíveis para montar o e-mail, use o comando EMAIL.Enviar para enviar o e-mail. O ideal é aguardar a resposta OK, antes de enviar outros comandos ou iniciar um novo e-mail.

Exemplo de Resposta:

OK: E-mail enviado com sucesso!

Created with the Personal Edition of HelpNDoc: Easy CHM and documentation editor


Comandos do Objeto SEDEX

Comandos ››

Comandos aceitos pelo Objeto SEDEX

Created with the Personal Edition of HelpNDoc: Easily create HTML Help documents


SEDEX.Consultar

Comandos ›› Comandos do Objeto SEDEX ››

Retorna dados de uma Consulta ao WebService do Correios para calculo do valor de encomendas

SEDEX.Consultar(cDados)

Parâmetros:

cDados - path do arquivo ini com o nome do arquivo, contendo os titulos a serem incluídos ou conteúdo do arquivo ini.

Exemplo de arquivo .INI

[SEDEX]

Mensagem=

CepOrigem=18270170

CepDestino=18272230

Servico=0

Peso=1

Altura=5

Largura=15

Comprimento=16

Diametro=5

ValorDeclarado=10,00

Formato=0

AvisoRecebimento=0

MaoPropria=0

Servico

0 = '41106' - PAC

1 = '40010' - SEDEX

2 = '40215' - SEDEX10

3 = '40290' - SEDEXHOJE

4 = '81019' - eSEDEX

5 = '44105' - MALOTE

6 = '85480' - AEROGRAMA

7 = '10030' - CARTASIMPLES

8 = '10014' - CARTAREGISTRADA

9 = '16012' - CARTAOPOSTAL

10 = '20010' - IMPRESSO

11 = '14010' - MALADIRETA

12 = '40010' - SEDEXVarejo

13 = '40045' - SEDEXaCobrarVarejo

14 = '40215' - SEDEX10Varejo

15 = '40290' - SEDEXHojeVarejo

16 = '41106' - PACVarejo

Formato

0 = CaixaPacote

1 = RoloPrisma

2 = Envelope

MaoPropria

0 = Não

1 = Sim

AvisoRecebimento

0 = Não

1 = Sim

Exemplo de Resposta:

OK: [Consulta]

CodigoServico=41106

Valor=13,7

PrazoEntrega=3

ValorSemAdicionais=13,7

ValorMaoPropria=0

ValorAvisoRecebimento=0

ValorValorDeclarado=0

EntregaDomiciliar=S

EntregaSabado=N

Erro=0

MsgErro=

Created with the Personal Edition of HelpNDoc: Easily create EPub books


SEDEX.Rastrear

Comandos ›› Comandos do Objeto SEDEX ››

Retorna dados de uma Consulta ao WebService do Correios para rastreamento de encomendas

SEDEX.Rastrear(cCodigoRastreamento)

Parâmetros:

cCodigoRastreamento - Código de 13 caracteres fornecido pelo Correios no momento da postagem

Exemplo de Resposta:

SEDEX.rastrear("SA301355961BR")

OK: (A FAZER)

Created with the Personal Edition of HelpNDoc: Free PDF documentation generator


Comandos do Objeto NCM

Comandos ››

Comandos aceitos pelo Objeto NCM

Created with the Personal Edition of HelpNDoc: Full-featured Kindle eBooks generator


NCM.Validar

Comandos ›› Comandos do Objeto NCM ››

Retorna True se o NCM informado existir.

NCM.Validar(cNCM)

Parâmetros:

cNCM - Código do NCM a ser consultado

Exemplo de Resposta:

NCM.Validar("96131000")

OK: NCM Valido

Created with the Personal Edition of HelpNDoc: Generate Kindle eBooks with ease


NCM.DescricaoNCM

Comandos ›› Comandos do Objeto NCM ››

Retorna a Descrição de um determinado NCM

NCM.DescricaoNCM(cNCM)

Parâmetros:

cNCM - Código do NCM a ser consultado

Exemplo de Resposta:

NCM.DescricaoNCM("96131000")

OK: OUTS.ISQUEIROS BOLSO GÁS Ñ RECARREGÁVEIS

Created with the Personal Edition of HelpNDoc: Create iPhone web-based documentation


NCM.BaixarLista

Comandos ›› Comandos do Objeto NCM ››

Salva a lista de NCM no formato CSV, em um nome de arquivo especificado.

NCM.BaixarLista(cNomeArquivo)

Parâmetros:

cNomeArquivo - Nome do arquivo a ser criado com a Lista de NCMs baixados

Exemplo de Resposta:

NCM.BaixarLista("C:\TEMP\NCMs.csv")

OK:

Created with the Personal Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Comandos do Objeto NFE/NFCe

Comandos ››

Comandos aceitos pelo Objeto NFe e NFCe

Obs.: É recomendado chamar os comandos SetModeloDF e SetVersaoDF antes de executar qualquer comando de cancelamento, inutilização, eventos, etc, pois alguns estados possuem endereços diferentes para cada tipo de documento, então chamando esses comandos você garante que o componente será configurado para o endereço correto.

O comando SetModeloDF aceita os valores 55 e 65, sendo 55 - NFe e 65 NFC-e;

Created with the Personal Edition of HelpNDoc: Write EPub books for the iPad


NFE.StatusServico

Comandos ›› Comandos do Objeto NFE/NFCe ››

Verifica o Status do Serviço dos WebServices da Receita.

Exemplo de Resposta:

OK: Serviço em Operação

[STATUS]

Versao=1.07

TpAmb=2

VerAplic=SP_NFE_PL_005c

CStat=107

XMotivo=Serviço em Operação

CUF=35

DhRecbto=2009-03-25T08:44:20

TMed=1

ERRO: WebService Consulta Status serviço:

- Inativo ou Inoperante tente novamente.

- Synapse TCP/IP Socket error 11001: Host not found

Created with the Personal Edition of HelpNDoc: Easy EPub and documentation editor


NFE.ValidarNFe

Comandos ›› Comandos do Objeto NFE/NFCe ››

Valida arquivo da NFe. Arquivo deve estar assinado.

NFE.ValidarNFe( cArqXML )

Parâmetros

cArqXML - Caminho do arquivo a ser validado.

Exemplo:

NFE.VALIDARNFE("c:\35XXXXXXXXXXXXXXXX550010000000050000000058-nfe.xml")

Exemplo de Resposta:

OK:

ERRO: 1871 - Element '{http://www.portalfiscal.inf.br/nfe}NFe': Missing child element(s). Expected is ( {http://www.w3.org/2000/09/xmldsig#}Signature ).

Created with the Personal Edition of HelpNDoc: Free iPhone documentation generator


NFE.AssinarNFe

Comandos ›› Comandos do Objeto NFE/NFCe ››

Assina uma NFe. Arquivo assinado será salvo na pasta configurada na aba WebService na opção "Salvar Arquivos de Envio e Resposta".

NFE.AssinarNFe( cArqXML )

Parâmetros

cArqXML - Caminho do arquivo a ser assinado.

Exemplo:

NFE.ASSINARNFE("c:\35XXXXXXXXXXXXXXXX550010000000050000000058-nfe.xml")

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Generate EPub eBooks with ease


NFE.ConsultarNFe

Comandos ›› Comandos do Objeto NFE/NFCe ››

Consulta uma NFe.

NFE.ConsultarNFe( cArqXML )

Parâmetros

cArqXML - Caminho do arquivo a ser consultado.

Exemplo:

NFE.CONSULTARNFE("c:\35XXXXXXXXXXXXXXXX550010000000050000000058-nfe.xml")

Exemplo de Resposta:

OK: Autorizado o uso da NF-e

[CONSULTA]

Versao=1.07

TpAmb=2

VerAplic=SP_NFE_PL_005c

CStat=100

XMotivo=Autorizado o uso da NF-e

CUF=35

ChNFe=350XXXXXXXXXXXXXXXX550010000000220000000229

DhRecbto=2009-03-24T20:19:38

NProt=1350900073XXXXX

DigVal=OZl9uzQ+JVFPxNuqBJ/ex7TTxhc=

Created with the Personal Edition of HelpNDoc: Produce Kindle eBooks easily


NFE.CancelarNFe

Comandos ›› Comandos do Objeto NFE/NFCe ››

Cancela um NFe já autorizada.

NFe.CancelarNFe(cChaveNFe,cJustificativa,cCNPJ,nEvento)

Exemplo:

NFE.CANCELARNFE("35XXXXXXXXXXXXXXXX550010000000050000000058","Teste de Cancelamento,99999999000191")

Exemplo de Resposta:

OK: Cancelamento de NF-e homologado

[CANCELAMENTO]

Versao=1.07

TpAmb=2

VerAplic=SP_NFE_PL_005c

CStat=101

XMotivo=Cancelamento de NF-e homologado

CUF=35

ChNFe=350XXXXXXXXXXXXXXXXX550010000000220000000229

DhRecbto=2009-03-25T08:50:50

NProt=2009-03-25T08:50:50

tpEvento=

xEvento=

nSeqEvento=

CNPJDest=

emailDest=

XML=

ERRO: Informar uma Justificativa para cancelar a Nota Fiscal Eletronica

Created with the Personal Edition of HelpNDoc: Easy EPub and documentation editor


NFE.ImprimirDanfe

Comandos ›› Comandos do Objeto NFE/NFCe ››

Imprime a NFE de acordo com os parâmetros informados.

NFE.ImprimirDanfe(cArqXML,[cImpressora],[nNumCopias],[cProtocolo],[bMostrarPreview],[cMarcaDagua],[bViaConsumidor],[bSimplificado])

Created with the Personal Edition of HelpNDoc: Full-featured EPub generator


NFE.ImprimirDANFEPDF

Comandos ›› Comandos do Objeto NFE/NFCe ››

Cria um arquivo em PDF da NFE de acordo com os parâmetros informados.

NFe.ImprimirDANFEPDF(cArqXML,[cProtocolo],[cMarcaDaqgua],[bViaConsumidor],[bSimplificado])

Created with the Personal Edition of HelpNDoc: Easily create Help documents


NFE.ImprimirEvento

Comandos ›› Comandos do Objeto NFE/NFCe ››

Comando para Imprimir uma CCe.

NFe.ImprimirEvento(cArqXMLEvento,[cArqXMLNFe],[cImpressora],[nNumCopias],[bMostrarPreview])

o XML da NFe é opcional, caso seja informado será impresso os dados do Emitente e Destinatário, caso contrário será impresso apenas os dados disponíveis no XML do Evento.

Created with the Personal Edition of HelpNDoc: Easily create CHM Help documents


NFE.ImprimirEventoPDF

Comandos ›› Comandos do Objeto NFE/NFCe ››

Comando para gerar um PDF de uma CCe.

NFe.ImprimirEventoPDF(cArqXMLEvento,[cArqXMLNFe])

Created with the Personal Edition of HelpNDoc: iPhone web sites made easy


NFE.InutilizarNFe

Comandos ›› Comandos do Objeto NFE/NFCe ››

Inutiliza uma faixa de numeração de NFe.

NFE.InutilizarNFe( cCNPJ, cJustificativa, nAno, nModelo, nSerie, nNumInicial, nNumFinal)

Parâmetros

cCNPJ - CNPJ do contribuinte

cJustificativa - Justificativa para inutilização

nAno - Ano que foi inutilizado a numeração

nModelo - Modelo da Nota Fiscal

nSerie - Série da Nota Fiscal

nNumInicial - Número Inicial a ser inutilizado

nNumFinal - Número Final a ser inutilizado

Exemplo:

NFE.INUTILIZARNFE( "XXXXXXXXXXXXX", "Teste de inutilizacao", 08, 55, 1, 1, 4)

Exemplo de Resposta:

OK: Inutilização de número homologado

[INUTILIZACAO]

Versao=1.07

TpAmb=2

VerAplic=SP_NFE_PL_005c

CStat=102

XMotivo=Inutilização de número homologado

CUF=35

DhRecbto=2009-03-25T08:59:31

NProt=13508000XXXXXXX

ERRO: Rejeição: Uma NF-e da faixa já está inutilizada na Base de dados da SEFAZ

Created with the Personal Edition of HelpNDoc: Easily create EPub books


NFE.ImprimirInutilizacao

Comandos ›› Comandos do Objeto NFE/NFCe ››

Comando para Imprimir uma Inutilização.

NFe.ImprimirInutilizacao(cArqXMLInutilizacao,[cImpressora],[nNumCopias],[bMostrarPreview])

Impressão da Inutlização da Númeração de NF-e.

Created with the Personal Edition of HelpNDoc: Free Web Help generator


NFE.ImprimirInutilizacaoPDF

Comandos ›› Comandos do Objeto NFE/NFCe ››

Comando para gerar um PDF de uma Inutilização.

NFe.ImprimirEventoPDF(cArqXMLEvento)

Created with the Personal Edition of HelpNDoc: Free CHM Help documentation generator


NFE.ReciboNFe

Comandos ›› Comandos do Objeto NFE/NFCe ››

NFe.ReciboNFe(nRecibo)

Consulta status do lote enviado pelo número do recibo.

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


NFE.ConsultaCadastro

Comandos ›› Comandos do Objeto NFE/NFCe ››

Comando parar fazer consulta ao cadastro do contribuinte.

NFe.ConsultaCadastro(cUF,nDocumento,[nIE])

Parametros

cUF - Sigla do estado do documento a ser consultado

nDocumento - Número do documento a ser consultado

nIE - parâmetro opcional e caso seja passado 1 irá consultar pelo documento Inscrição Estadual, caso contrário irá consultar pelo CPF ou CNPJ.

Created with the Personal Edition of HelpNDoc: Full-featured Help generator


NFE.CriarNFe

Comandos ›› Comandos do Objeto NFE/NFCe ››

Cria XML da NFe baseado em um arquivo INI.

NFe.CriarNFe(cIniNFe,[bRetornaXML])

Parâmetros

cIniNFe - Texto no formato de arquivo INI com informações da NFe.

bRetornaXML - Coloque o valor 1 se quiser que o ACBrNFeMonitor retorne além do Path de onde o arquivo foi criado, o XML gerado. Por default não retorna o XML.

O conteúdo do parâmetro cIniNFe, deve possuir o seguinte formato:

[infNFe]

versao=3.10

[Identificacao]

cNF=

natOp=

indPag=

mod=

serie=

nNF=

dhEmi=

dhSaiEnt=

tpNF=

idDest=

tpImp=

tpEmis=

finNFe=

indFinal=

indPres=

procEmi=

verProc=

dhCont=

xJust=

[NFRefXXX]

Tipo=

refNFe=

cUF=

AAMM=

CNPJ=

mod=

Serie=

nNF=

CNPJCPF=

IE=

refCTe=

ModECF=

nECF=

nCOO=

[Emitente]

CNPJCPF=

xNome=

xFant=

IE=

IEST=

IM=

CNAE=

CRT=

xLgr=

nro=

xCpl=

xBairro=

cMun=

xMun=

UF=

CEP=

cPais=

xPais=

Fone=

cUF=

cMunFG=

[Avulsa]

CNPJ=

xOrgao=

matr=

xAgente=

fone=

UF=

nDAR=

dEmi=

vDAR=

repEmi=

dPag=

[Destinatario]

idEstrangeiro=

CNPJCPF=

xNome=

indIEDest=

IE=

ISUF=

Email=

xLgr=

nro=

xCpl=

xBairro=

cMun=

xMun=

UF=

CEP=

cPais=

xPais=

Fone=

[Retirada]

CNPJCPF=

xLgr=

nro=

xCpl=

xBairro=

cMun=

xMun=

UF=

[Entrega]

CNPJCPF=

xLgr=

nro=

xCpl=

xBairro=

cMun=

xMun=

UF=

[autXMLXXX]

CNPJCPF=

[ProdutoXXX]

cProd=

cEAN=

xProd=

NCM=

EXTIPI=

CFOP=

uCom=

qCom=

vUnCom=

vProd=

cEANTrib=

uTrib=

qTrib=

vUnTrib=

vFrete=

vSeg=

vDesc=

vOutro=

indTot=

xPed=

nItemPed=

nFCI=

nRECOPI=

pDevol=

vIPIDevol=

vTotTrib=

infAdProd=

[NVEXXXYYY]

NVE=

[DIXXXYYY]

nDi=

dDi=

xLocDesemb=

UFDesemb=

dDesemb=

tpViaTransp=

vAFRMM=

tpIntermedio=

CNPJ=

UFTerceiro=

cExportador=

[LADIXXXYYYKKK]

nAdicao=

nSeqAdi=

cFabricante=

vDescDI=

nDraw=

[detExportXXXYYY]

nDraw=

nRE=

chNFe=

qExport=

[impostoDevolXXX]

pDevol=

vIPIDevol=

[VeiculoXXX]

chassi=

tpOP=

cCor=

xCor=

pot=

Cilin=

pesoL=

pesoB=

nSerie=

tpComb=

nMotor=

CMT=

dist=

anoMod=

anoFab=

tpPint=

tpVeic=

espVeic=

VIN=

condVeic=

cMod=

cCorDENATRAN=

lota=

tpRest=

[MedicamentoXXXYYY]

nLote=

qLote=

dFab=

dVal=

vPMC=

[ArmaXXXYYY]

nSerie=

tpArma=

nCano=

descr=

[CombustivelXXX]

cProdANP=

pMixGN=

CODIF=

qTemp=

UFCons=

[CIDEXXX]

qBCprod=

vAliqProd=

vCIDE=

[ICMSCombXXX]

vBCICMS=

vICMS=

vBCICMSST=

vICMSST=

[ICMSInterXXX]

vBCICMSSTDest=

vICMSSTDest=

[ICMSConsXXX]

vBCICMSSTCons=

vICMSSTCons=

UFCons=

[ICMSXXX]

orig=

CST=

CSOSN=

modBC=

pRedBC=

vBC=

pICMS=

vICMS=

modBCST=

pMVAST=

pRedBCST=

vBCST=

pICMSST=

vICMSST=

UFST=

pBCOp=

vBCSTRet=

vICMSSTRet=

motDesICMS=

pCredSN=

vCredICMSSN=

vBCSTDest=

vICMSSTDest=

vICMSDeson=

vICMSOp=

pDif=

vICMSDif=

[IPIXXX]

CST=

clEnq=

CNPJProd=

cSelo=

qSelo=

cEnq=

vBC=

qUnid=

vUnid=

pIPI=

vIPI=

[IIXXX]

vBC=

vDespAdu=

vII=

vIOF=

[PISXXX]

CST=

vBC=

pPIS=

qBCProd=

vAliqProd=

vPIS=

[PISSTXXX]

vBC=

pPis=

qBCProd=

vAliqProd=

vPIS=

[COFINSXXX]

CST=

vBC=

pCOFINS=

qBCProd=

vAliqProd=

vCOFINS=

[COFINSSTXXX]

vBC=

pCOFINS=

qBCProd=

vAliqProd=

vCOFINS=

[ISSQNXXX]

vBC=

vAliq=

vISSQN=

cMunFG=

cListServ=

cSitTrib=

vDeducao=

vDeducao=

vOutro=

vDescIncond=

vDescCond=

vISSRet=

indISS=

cServico=

cMun=

cPais=

nProcesso=

indIncentivo=

[Total]

vBC=

vICMS=

vICMSDeson=

vBCST=

vST=

vProd=

vFrete=

vSeg=

vDesc=

vII=

vIPI=

vPIS=

vCOFINS=

vOutro=

vNF=

vTotTrib=

[ISSQNtot]

vServ=

vBC=

vISS=

vPIS=

vCOFINS=

dCompet=

vDeducao=

vOutro=

vDescIncond=

vDescCond=

vISSRet=

cRegTrib=

[retTrib]

vRetPIS=

vRetCOFINS=

vRetCSLL=

vBCIRRF=

vIRRF=

vBCRetPrev=

vRetPrev=

[Transportador]

modFrete=

CNPJCPF=

xNome=

IE=

xEnder=

xMun=

UF=

vServ=

vBCRet=

pICMSRet=

vICMSRet=

CFOP=

cMunFG=

Placa=

UFPlaca=

RNTC=

vagao=

balsa=

[ReboqueXXX]

placa=

UF=

RNTC=

[VolumeXXX]

qVol=

esp=

Marca=

nVol=

pesoL=

pesoB=

[LacreXXXYYY]

nLacre=

[Fatura]

nFat=

vOrig=

vDesc=

vLiq=

[DuplicataXXX]

nDup=

dVenc=

vDup=

[PAGXXX]

tpag=

vPag=

CNPJ=

tBand=

cAut=

[DadosAdicionais]

infAdFisco=

infCpl=

[InfAdicXXX]

xCampo=

xTexto=

[ObsFiscoXXX]

xCampo=

xTexto=

[procRefXXX]

nProc=

indProc=

[Exporta]

UFSaidaPais=

xLocExporta=

xLocDespacho=

[Compra]

xNEmp=

xPed=

xCont=

[cana]

safra=

ref=

qTotMes=

qTotAnt=

qTotGer=

vFor=

vTotDed=

vLiqFor=

[forDiaXXX]

dia=

qtde=

[deducXXX]

xDed=

vDed=

Observações

A maioria dos campos utiliza a nomenclatura do manual disponibilizado pelo SEFAZ apenas os grupos(o que está entre []) segue a nomenclatura interna do ACBrNFeMonitor. A literal XXX indica grupos que podem ocorrer mais de uma vez(produtos por exemplo) e quando existir YYY ou KKK indica grupos que são filhos de grupos com mais de uma ocorrência. Por exemplo, no caso da Declaração de Importação podemos ter 0-100 ocorrências e cada Declaração de Importação pode conter de 1-100 Adições, então temos o grupo [DI001] e após ele podemos ter [LADI001YYY] onde YYY pode ser de 001 a 100.

- Algumas grupos podem ser repetidos. Ex: Para incluir dois produtos, existirão uma chave Produto001 e Produto002 e assim sucessivamente. As chaves de imposto (ICMS,IPI,COFINS, etc) devem ter o memo número do produto, ou seja, o ICMS da chave Produto0002 deve ser ICMS002.

- Acentos podem causar problemas na criação do NFe. Ao tentar criar uma NFe, caso receba o erro "Unable to Parse" verifique se não existem caracteres acentuados nos campos.

Exemplo de Resposta:

OK: NFe criada em: C:\ACBrNFeMonitor\logs\35XXXXXXXXXXXXXXXX550010000000190000000193-nfe.xml

Created with the Personal Edition of HelpNDoc: Easy CHM and documentation editor


NFE.CriarEnviarNFe

Comandos ›› Comandos do Objeto NFE/NFCe ››

Cria o XML da NFe e já envia para o fisco.

NFe.CriarEnviarNFe(cIniNFe,nLote,[bImprimeDANFE],[bSincrono],[cImpressora],[bMostrarPreview],[nNumCopias])

Parâmetros:

cIniNFe - Texto no formato de arquivo INI com informações da NFe.

nImprimirDanfe - Coloque 1 se quiser que o DANFe seja impresso logo após a autorização - Parâmetro Opcional

bSincrono- Coloque 1 para indicar modo síncrono e 0 para modo assíncrono.

O conteúdo do parâmetro cIniNFe, deve possuir o seguinte formato:

[infNFe]

versao=3.10

[Identificacao]

cNF=

natOp=

indPag=

mod=

serie=

nNF=

dhEmi=

dhSaiEnt=

tpNF=

idDest=

tpImp=

tpEmis=

finNFe=

indFinal=

indPres=

procEmi=

verProc=

dhCont=

xJust=

[NFRefXXX]

Tipo=

refNFe=

cUF=

AAMM=

CNPJ=

mod=

Serie=

nNF=

CNPJCPF=

IE=

refCTe=

ModECF=

nECF=

nCOO=

[Emitente]

CNPJCPF=

xNome=

xFant=

IE=

IEST=

IM=

CNAE=

CRT=

xLgr=

nro=

xCpl=

xBairro=

cMun=

xMun=

UF=

CEP=

cPais=

xPais=

Fone=

cUF=

cMunFG=

[Avulsa]

CNPJ=

xOrgao=

matr=

xAgente=

fone=

UF=

nDAR=

dEmi=

vDAR=

repEmi=

dPag=

[Destinatario]

idEstrangeiro=

CNPJCPF=

xNome=

indIEDest=

IE=

ISUF=

Email=

xLgr=

nro=

xCpl=

xBairro=

cMun=

xMun=

UF=

CEP=

cPais=

xPais=

Fone=

[Retirada]

CNPJCPF=

xLgr=

nro=

xCpl=

xBairro=

cMun=

xMun=

UF=

[Entrega]

CNPJCPF=

xLgr=

nro=

xCpl=

xBairro=

cMun=

xMun=

UF=

[autXMLXXX]

CNPJCPF=

[ProdutoXXX]

cProd=

cEAN=

xProd=

NCM=

EXTIPI=

CFOP=

uCom=

qCom=

vUnCom=

vProd=

cEANTrib=

uTrib=

qTrib=

vUnTrib=

vFrete=

vSeg=

vDesc=

vOutro=

indTot=

xPed=

nItemPed=

nFCI=

nRECOPI=

pDevol=

vIPIDevol=

vTotTrib=

infAdProd=

[NVEXXXYYY]

NVE=

[DIXXXYYY]

nDi=

dDi=

xLocDesemb=

UFDesemb=

dDesemb=

tpViaTransp=

vAFRMM=

tpIntermedio=

CNPJ=

UFTerceiro=

cExportador=

[LADIXXXYYYKKK]

nAdicao=

nSeqAdi=

cFabricante=

vDescDI=

nDraw=

[detExportXXXYYY]

nDraw=

nRE=

chNFe=

qExport=

[impostoDevolXXX]

pDevol=

vIPIDevol=

[VeiculoXXX]

chassi=

tpOP=

cCor=

xCor=

pot=

Cilin=

pesoL=

pesoB=

nSerie=

tpComb=

nMotor=

CMT=

dist=

anoMod=

anoFab=

tpPint=

tpVeic=

espVeic=

VIN=

condVeic=

cMod=

cCorDENATRAN=

lota=

tpRest=

[MedicamentoXXXYYY]

nLote=

qLote=

dFab=

dVal=

vPMC=

[ArmaXXXYYY]

nSerie=

tpArma=

nCano=

descr=

[CombustivelXXX]

cProdANP=

pMixGN=

CODIF=

qTemp=

UFCons=

[CIDEXXX]

qBCprod=

vAliqProd=

vCIDE=

[ICMSCombXXX]

vBCICMS=

vICMS=

vBCICMSST=

vICMSST=

[ICMSInterXXX]

vBCICMSSTDest=

vICMSSTDest=

[ICMSConsXXX]

vBCICMSSTCons=

vICMSSTCons=

UFCons=

[ICMSXXX]

orig=

CST=

CSOSN=

modBC=

pRedBC=

vBC=

pICMS=

vICMS=

modBCST=

pMVAST=

pRedBCST=

vBCST=

pICMSST=

vICMSST=

UFST=

pBCOp=

vBCSTRet=

vICMSSTRet=

motDesICMS=

pCredSN=

vCredICMSSN=

vBCSTDest=

vICMSSTDest=

vICMSDeson=

vICMSOp=

pDif=

vICMSDif=

[IPIXXX]

CST=

clEnq=

CNPJProd=

cSelo=

qSelo=

cEnq=

vBC=

qUnid=

vUnid=

pIPI=

vIPI=

[IIXXX]

vBC=

vDespAdu=

vII=

vIOF=

[PISXXX]

CST=

vBC=

pPIS=

qBCProd=

vAliqProd=

vPIS=

[PISSTXXX]

vBC=

pPis=

qBCProd=

vAliqProd=

vPIS=

[COFINSXXX]

CST=

vBC=

pCOFINS=

qBCProd=

vAliqProd=

vCOFINS=

[COFINSSTXXX]

vBC=

pCOFINS=

qBCProd=

vAliqProd=

vCOFINS=

[ISSQNXXX]

vBC=

vAliq=

vISSQN=

cMunFG=

cListServ=

cSitTrib=

vDeducao=

vDeducao=

vOutro=

vDescIncond=

vDescCond=

vISSRet=

indISS=

cServico=

cMun=

cPais=

nProcesso=

indIncentivo=

[Total]

vBC=

vICMS=

vICMSDeson=

vBCST=

vST=

vProd=

vFrete=

vSeg=

vDesc=

vII=

vIPI=

vPIS=

vCOFINS=

vOutro=

vNF=

vTotTrib=

[ISSQNtot]

vServ=

vBC=

vISS=

vPIS=

vCOFINS=

dCompet=

vDeducao=

vOutro=

vDescIncond=

vDescCond=

vISSRet=

cRegTrib=

[retTrib]

vRetPIS=

vRetCOFINS=

vRetCSLL=

vBCIRRF=

vIRRF=

vBCRetPrev=

vRetPrev=

[Transportador]

modFrete=

CNPJCPF=

xNome=

IE=

xEnder=

xMun=

UF=

vServ=

vBCRet=

pICMSRet=

vICMSRet=

CFOP=

cMunFG=

Placa=

UFPlaca=

RNTC=

vagao=

balsa=

[ReboqueXXX]

placa=

UF=

RNTC=

[VolumeXXX]

qVol=

esp=

Marca=

nVol=

pesoL=

pesoB=

[LacreXXXYYY]

nLacre=

[Fatura]

nFat=

vOrig=

vDesc=

vLiq=

[DuplicataXXX]

nDup=

dVenc=

vDup=

[PAGXXX]

tpag=

vPag=

CNPJ=

tBand=

cAut=

[DadosAdicionais]

infAdFisco=

infCpl=

[InfAdicXXX]

xCampo=

xTexto=

[ObsFiscoXXX]

xCampo=

xTexto=

[procRefXXX]

nProc=

indProc=

[Exporta]

UFSaidaPais=

xLocExporta=

xLocDespacho=

[Compra]

xNEmp=

xPed=

xCont=

[cana]

safra=

ref=

qTotMes=

qTotAnt=

qTotGer=

vFor=

vTotDed=

vLiqFor=

[forDiaXXX]

dia=

qtde=

[deducXXX]

xDed=

vDed=

Observações

A maioria dos campos utiliza a nomenclatura do manual disponibilizado pelo SEFAZ apenas os grupos(o que está entre []) segue a nomenclatura interna do ACBrNFeMonitor. A literal XXX indica grupos que podem ocorrer mais de uma vez(produtos por exemplo) e quando existir YYY ou KKK indica grupos que são filhos de grupos com mais de uma ocorrência. Por exemplo, no caso da Declaração de Importação podemos ter 0-100 ocorrências e cada Declaração de Importação pode conter de 1-100 Adições, então temos o grupo [DI001] e após ele podemos ter [LADI001YYY] onde YYY pode ser de 001 a 100.

- Algumas grupos podem ser repetidos. Ex: Para incluir dois produtos, existirão uma chave Produto001 e Produto002 e assim sucessivamente. As chaves de imposto (ICMS,IPI,COFINS, etc) devem ter o memo número do produto, ou seja, o ICMS da chave Produto0002 deve ser ICMS002.

- Acentos podem causar problemas na criação do NFe. Ao tentar criar uma NFe, caso receba o erro "Unable to Parse" verifique se não existem caracteres acentuados nos campos.

Observações:

Será retornado uma chave NFE + o número da NFe enviada. O recebimento da reposta OK: Lote recebido com sucesso não significa que a nota foi autorizada, apenas que o lote foi recebido. Verifique os campos CStat e XMotivo da chave NFE para ter certeza que a nota foi autorizada

Created with the Personal Edition of HelpNDoc: Free help authoring tool


NFE.AdicionarNFe

Comandos ›› Comandos do Objeto NFE/NFCe ››

NFe.AdicionarNFe(cIniNFe,nLote)

Comando para envio de notas em lotes.

O Formato do parâmetro cIniNFe é o mesmo usado no comando Nfe.CriarNfe. Após adicionar as notas ao lote, deverá ser usado o comando NFe.EnviarLote(numLote).

O retorno será no mesmo formato do comando NFe.EnviarNFe com a diferença de que conterá várias chaves [NFEXXXX] onde XXXX é o número da nota que foi enviada.

Created with the Personal Edition of HelpNDoc: Write EPub books for the iPad


NFE.CriarNFeSefaz

Comandos ›› Comandos do Objeto NFE/NFCe ››

NFe.CriarNFeSEFAZ(cTXTSefaz,[bRetornaXML])

Comando para ser passado como parâmetro o caminho do arquivo criado no formato usado pelo emissor gratuíto de SP.

Created with the Personal Edition of HelpNDoc: Easily create iPhone documentation


NFE.CriarEnviarNFeSefaz

Comandos ›› Comandos do Objeto NFE/NFCe ››

NFe.CriarEnviarNFeSEFAZ(cTXTSefaz,nLote,[bImprimeDANFE],[bSincrono],[cImpressora],[bMostrarPreview],[nNumCopias])

Comando para ser passado como parâmetro o caminho do arquivo criado no formato usado pelo emissor gratuíto de SP.

Created with the Personal Edition of HelpNDoc: Easily create PDF Help documents


NFE.AdicionarNFeSefaz

Comandos ›› Comandos do Objeto NFE/NFCe ››

Comando para envio de notas em lotes, para ser passado como parâmetro o caminho do arquivo criado no formato usado pelo emissor gratuíto de SP

NFe.AdicionarNFeSEFAZ(cTXTSefaz,nLote)

Created with the Personal Edition of HelpNDoc: Easily create CHM Help documents


NFE.EnviarLoteNFe

Comandos ›› Comandos do Objeto NFE/NFCe ››

NFe.EnviarLoteNFe(nLote,[bImprimir],[cImpressora],[bSincrono],[bMostrarPreview],[nNumCopias])

Parâmetro:

Comando para envio de notas em lotes.

Created with the Personal Edition of HelpNDoc: Full-featured Kindle eBooks generator


NFE.EnviarNFe

Comandos ›› Comandos do Objeto NFE/NFCe ››

Envia NFe.

NFe.EnviarNFe(cArqXML,nLote,[bAssina],[bImprime],[cImpressora],[bSincrono])

Parâmetros

cArqXML -Caminho do arquivo a ser enviado.

nLote - Número do Lote

bAssina - Coloque 0 se não quiser que o componente assine o arquivo. - Parâmetro Opcional

nImprime - Coloque 1 se quiser que o DANFe seja impresso logo após a autorização - Parâmetro Opcional

bSincrono- Coloque 1 para indicar modo síncrono e 0 para modo assíncrono.

Exemplo:

NFE.ENVIARNFE("c:\35XXXXXXXXXXXXXXXX550010000000050000000058-nfe.xml",1,1,1,1)

Exemplo de Resposta:

OK: Lote recebido com sucesso

[ENVIO]

Versao=1.10

TpAmb=2

VerAplic=SP_NFE_PL_005c

CStat=103

XMotivo=Lote recebido com sucesso

CUF=35

NRec=35000000XXXXXXX

DhRecbto=2009-03-25T09:25:04

TMed=1

Lote processado

[RETORNO]

Versao=1.10

TpAmb=2

VerAplic=SP_NFE_PL_005c

NRec=35000000XXXXXXX

CStat=104

XMotivo=Lote processado

CUF=35

[NFE28]

Versao=1.07

Id=

TpAmb=2

VerAplic=SP_NFE_PL_005c

CStat=100

XMotivo=Autorizado o uso da NF-e

CUF=35

ChNFe=350XXXXXXXXXXXXXXXXX550010000000280000000281

DhRecbto=2009-03-25T09:25:04

NProt=13509000XXXXXXX

DigVal=UNTpscTtknjN5UOBUHa9PZPHJnE=

ERRO: Rejeição: Falha no Schema XML da NFe

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


NFE.EnviarEvento

Comandos ›› Comandos do Objeto NFE/NFCe ››

NFe.EnviarEvento(cIniEvento)

Comando para enviar uma CCE

Created with the Personal Edition of HelpNDoc: Full-featured Kindle eBooks generator


NFE.ConsultaNFeDest

Comandos ›› Comandos do Objeto NFE/NFCe ››

NFe.ConsultaNFeDest(cCNPJ,nIndicadorNFe,nIndicadorEmissor,nUltNSU)

Comando para enviar eventos referente a Manifestação do Destinatário.

Created with the Personal Edition of HelpNDoc: Easily create HTML Help documents


NFE.DownloadNFe

Comandos ›› Comandos do Objeto NFE/NFCe ››

NFe.DownloadNFe(cCNPJ,cChaves)

Comando que permite baixar NFE (xml).

Created with the Personal Edition of HelpNDoc: Easily create EPub books


NFE.EnviarEmail

Comandos ›› Comandos do Objeto NFE/NFCe ››

Envia uma NFe por email. Além do XML é possível enviar o DANFe em formato PDF. O Assunto do email que será enviado e a mensagem deste email, deverá ser configurado no ACBrNFeMonitor

NFe.EnviarEmailEvento(cEmailDestino,cArqXMLEvento,[cArqXMLNFe],cEnviaPDF,[cAssunto],[cEmailsCopias],[cAnexos])

Parâmetros:

cEnviaPDF - indica se deverá ser enviado PDF junto ao Arquivo XML da NFe no email. Deverá ser passado 1 para enviar e 0 para não enviar o PDF.

cAssunto - parâmetro opcional para mudar o assunto cadastrado no ACBrNFeMonitor.

cEmailsCopias - parâmetro opcional que poderá conter diversos emails separados por ; para enviar cópia do email enviado ao Email de Destino.

Exemplo de Resposta:

OK: Email enviado com sucesso

Created with the Personal Edition of HelpNDoc: Easily create Help documents


NFE.SetCertificado

Comandos ›› Comandos do Objeto NFE/NFCe ››

Comando para informar o certificado.

NFe.SetCertificado(cCertificado,cSenha)

Versão OpenSSL

NFe.SetCertificado(cCertificado)

Versão CAPICOM

Created with the Personal Edition of HelpNDoc: Write eBooks for the Kindle


NFE.SetAmbiente

Comandos ›› Comandos do Objeto NFE/NFCe ››

Comando para informar o tipo de ambiente

NFe.SetAmbiente(nNumAmbiente)

Parâmetros

nNumAmbiente - pode ser passado o valor 1 para Ambiente de Produção ou 2 para Ambiente de Homologação

Created with the Personal Edition of HelpNDoc: Free help authoring tool


NFE.SetFormaEmissao

Comandos ›› Comandos do Objeto NFE/NFCe ››

Comando para definir a forma de emissão.

NFe.SetFormaEmissao(nFormaEmissao)

Parâmetros:

nFormaEmissao - pode ser passado os seguintes valores:

1 para Normal, 2 para FS, 3 para SCAN, 4 para DPEC e 5 para FS-DA

Created with the Personal Edition of HelpNDoc: Easily create CHM Help documents


NFE.SetVersaoDF

Comandos ›› Comandos do Objeto NFE/NFCe ››

NFe.SetVersaoDF(nVersao)

Muda a versão do documento que será usado no ACBrNFeMonitor, aceitas os seguintes valores: 2.00 - 3.00 - 3.10.

A versão 3.00 funciona apenas para NFC-e para empresas que participam dos projetos pilotos em alguns estados;

Created with the Personal Edition of HelpNDoc: Easy EPub and documentation editor


NFE.SetModeloDF

Comandos ›› Comandos do Objeto NFE/NFCe ››

NFe.SetModeloDF(nModeloDF)

Muda o tipo de documento que será criado. Aceita os valores 55 e 65, sendo 55 - NFe e 65 NFC-e;

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


NFE.SetToken

Comandos ›› Comandos do Objeto NFE/NFCe ››

NFe.SetToken

Configura o Código de Segurança do Contribuinte(antigo Token).

Created with the Personal Edition of HelpNDoc: Free help authoring tool


NFE.SetIDToken

Comandos ›› Comandos do Objeto NFE/NFCe ››

NFe.SetIDToken

Configura o Código de Identificação do CSC (cIdToken) que será usado na geração do QR-Code;

Created with the Personal Edition of HelpNDoc: Free HTML Help documentation generator


NFE.SetCSC

Comandos ›› Comandos do Objeto NFE/NFCe ››

NFe.SetCSC(cCSC,[cIdCSC])

Configura o Código de Segurança do Contribuinte

Created with the Personal Edition of HelpNDoc: Write EPub books for the iPad


NFE.SetIdCSC

Comandos ›› Comandos do Objeto NFE/NFCe ››

NFe.SetIdCSC(cIdCSC,[cCSC])

Configura o Código de Identificação do CSC (cIdToken) que será usado na geração do QR-Code;

Created with the Personal Edition of HelpNDoc: News and information about help authoring tools and software


NFE.LerNFe

Comandos ›› Comandos do Objeto NFE/NFCe ››

NFe.LerNFe(cArqXML)

Parâmetro:

cArqXML - Deverá ser passado o caminho do arquivo XML da NFe e o monitor irá responder um arquivo no formato INI com os dados da NFE lida.

Created with the Personal Edition of HelpNDoc: Full-featured EBook editor


NFE.NFetoTXT

Comandos ›› Comandos do Objeto NFE/NFCe ››

NFE.NFetoTXT(cArqXML,[cNomeArqTXT]).

Este comando irá converter um arquivo XML em um arquivo TXT no formato aceito pelo emissor de SP.

Created with the Personal Edition of HelpNDoc: Easy EPub and documentation editor


NFE.SaveToFile

Comandos ›› Comandos do Objeto NFE/NFCe ››

NFe.SaveToFile(cNomeArq,cConteudoArquivo),

Util para quem usa comunicação via TCP/IP e precisa salvar um arquivo no terminal

Created with the Personal Edition of HelpNDoc: Free EPub and documentation generator


NFE.LoadFromFile

Comandos ›› Comandos do Objeto NFE/NFCe ››

NFe.LoadfromFile(cNomeArq,nSegundos)

Util para quem usa comunicação via TCP/IP e precisa ler um arquivo no terminal como por exemplo ler o arquivo XML da NFe para salvar em sua base de dados.

Created with the Personal Edition of HelpNDoc: Write eBooks for the Kindle


NFE.FileExists

Comandos ›› Comandos do Objeto NFE/NFCe ››

NFe.FileExists(cNomeArq)

Verifica se o arquivo passado através do parâmetro cNomeArq existe na máquina em que o ACBrNFeMonitor está instalado.

Útil para quem utiliza comunicação via Sockets e deseja verificar a existência de um arquivo na máquina que está instalado o ACBrNFeMonitor sem precisar mapear a unidade de rede.

Created with the Personal Edition of HelpNDoc: Free help authoring tool


NFE.CertificadoDataVencimento

Comandos ›› Comandos do Objeto NFE/NFCe ››

NFe.CertificadoDataVencimento

Retorna a data de vencimento do certificado configurado no ACBrNFeMonitor(funciona apenas na versão CAPICOM).

Created with the Personal Edition of HelpNDoc: iPhone web sites made easy


NFE.CNPJCertificado

Comandos ›› Comandos do Objeto NFE/NFCe ››

NFe.CNPJCertificado

Retorna o CNPJ do certificado digiral configurado.

Created with the Personal Edition of HelpNDoc: Free Kindle producer


NFE.GerarChave

Comandos ›› Comandos do Objeto NFE/NFCe ››

NFe.GerarChave(codigoUF,codigoNumerico,modelo,serie,numero,tpemi,emissao,CNPJ)

Comando para gerar a chave da NFE.

Created with the Personal Edition of HelpNDoc: Full-featured EPub generator


NFE.GetPathNFe

Comandos ›› Comandos do Objeto NFE/NFCe ››

NFe.GetPathNFe

Retorna o diretório onde será salvo o xml.

Created with the Personal Edition of HelpNDoc: Easily create Help documents


NFE.GetPathCCE

Comandos ›› Comandos do Objeto NFE/NFCe ››

NFe.GetPathCCE

Retorna o diretório onde será salvo o xml.

Created with the Personal Edition of HelpNDoc: News and information about help authoring tools and software


NFE.GetPathCan

Comandos ›› Comandos do Objeto NFE/NFCe ››

NFe.GetPathCan

Retorna o diretório onde será salvo o xml.

Created with the Personal Edition of HelpNDoc: What is a Help Authoring tool?


NFE.GetPathEvento

Comandos ›› Comandos do Objeto NFE/NFCe ››

NFe.GetPathEvento

Retorna o diretório onde será salvo o xml.

Created with the Personal Edition of HelpNDoc: Write EPub books for the iPad


NFE.ImprimirRelatorio(cTexto)

Comandos ›› Comandos do Objeto NFE/NFCe ››

NFe.ImprimirRelatorio(cTexto)

Created with the Personal Edition of HelpNDoc: What is a Help Authoring tool?


NFE.Restaurar

Comandos ›› Comandos do Objeto NFE/NFCe ››

Comando para restaurar o ACBrMonitorPlus.

Created with the Personal Edition of HelpNDoc: Easily create EBooks


NFE.Ocultar

Comandos ›› Comandos do Objeto NFE/NFCe ››

Comando para ocultar o ACBrMonitorPlus.

Created with the Personal Edition of HelpNDoc: Free Kindle producer


NFE.EncerrarMonitor

Comandos ›› Comandos do Objeto NFE/NFCe ››

Comando apra encerrar o ACBrMonitorPlus.

Created with the Personal Edition of HelpNDoc: Easily create EBooks


NFE.Ativo

Comandos ›› Comandos do Objeto NFE/NFCe ››

Caso o ACBrNFeMonitor esteja executando na máquina, útil para verificar na entrada do sistema se o ACBrNFeMonitor está em execução.

Created with the Personal Edition of HelpNDoc: Write eBooks for the Kindle


NFE.Versao

Comandos ›› Comandos do Objeto NFE/NFCe ››

Retorna a versãon do ACBrMonitorPlus.

Created with the Personal Edition of HelpNDoc: Free HTML Help documentation generator


NFE.VersaoNome

Comandos ›› Comandos do Objeto NFE/NFCe ››

Retorna o tipo do certificado.

Created with the Personal Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


NFE.exit - bye - fim

Comandos ›› Comandos do Objeto NFE/NFCe ››

NFE. exit - bye - fim.

Desconectam o ACBrMonitorPlus quando usado via TCP/IP.

Created with the Personal Edition of HelpNDoc: Free help authoring tool


Comandos do Objeto SAT

Comandos ››

Created with the Personal Edition of HelpNDoc: Full-featured Help generator


SAT.Ativar

Comandos ›› Comandos do Objeto SAT ››

SAT.Ativar(CNPJ,cUF)

Comando para ativar o SAT

Exemplo:

SAT.Ativar("11111111111111",35)

Exemplo de resposta:

OK: 196351|040003|Ativado corretamente SAT Ativado com Sucesso|||

Created with the Personal Edition of HelpNDoc: Easily create CHM Help documents


SAT.Inicializar

Comandos ›› Comandos do Objeto SAT ››

Comando para inicializar o SAT

Exemplo de resposta:

OK: SAT inicializado

Created with the Personal Edition of HelpNDoc: Free EBook and documentation generator


SAT.Desinicializar

Comandos ›› Comandos do Objeto SAT ››

Comando para desinicializar o SAT.

Exemplo de resposta:

OK: SAT desinicializado

Created with the Personal Edition of HelpNDoc: Free EBook and documentation generator


SAT.AssociarAssinatura

Comandos ›› Comandos do Objeto SAT ››

SAT.AssociarAssinatura(CNPJ,Assinatura)

Comando responsável por associar assinatura ao equipamento.

Exemplo:

SAT.AssociarAssinatura("1111111111111111111111111111","12345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678904444")

Exemplo de Resposta:

OK: 222430|13000|Assinatuda do AC Registrada||

Created with the Personal Edition of HelpNDoc: iPhone web sites made easy


SAT.Bloquear

Comandos ›› Comandos do Objeto SAT ››

Comando para bloquear o SAT.

Exemplo de Resposta

OK: 919392|16098|16000|Equipamento SAT bloqueado com sucesso.||

Created with the Personal Edition of HelpNDoc: Easily create Help documents


SAT.Desbloquear

Comandos ›› Comandos do Objeto SAT ››

Comando para desbloquear o SAT

OK: 919392|16098|17000|Equipamento SAT desbloqueado com sucesso..||

Created with the Personal Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


SAT.TrocarCodigoAtivacao

Comandos ›› Comandos do Objeto SAT ››

Comando responsável por trocar o código de ativação.

SAT.TrocarCodigoAtivacao(codigoDeAtivacaoOuEmergencia,opcao,novoCodigo)

Exemplo:

SAT.TrocarCodigoAtivacao(12345678,1,22222222)

Exemplo de resposta:

OK: 745146|18000|Codigo de ativacao alterado com sucesso||

Created with the Personal Edition of HelpNDoc: Produce electronic books easily


SAT.ConsultarSAT

Comandos ›› Comandos do Objeto SAT ››

Comando que retorna o status do SAT.

Exemplo de resposta:

OK: 871712|08000|SAT em operacao||

Created with the Personal Edition of HelpNDoc: Free EPub producer


SAT.ConsultarStatusOperacional

Comandos ›› Comandos do Objeto SAT ››

Comando que retorna o status do SAT.

Exemplo de resposta:

[Resposta]

Mensagem=065377|10000|Resposta com Sucesso|||900003116|DHCP|000.000.000.000|b8:24:1a:00:02:39|000.000.000.000|000.000.000.000|192.168.092.001|192.168.092.001|NAO_CONECTADO|ALTO|1048576 Kbytes|254724 Kbytes|20150819083758|01.00.02|0.06|35150853485215000106599000031160001247549846|35150853485215000106599000031160001121550012|35150853485215000106599000031160001247549846|20150819074331|20150819074351|20150716|20200716|0

Status=1

Valor=

[StatusSAT]

NSERIE=900003116

LAN_MAC=b8:24:1a:00:02:39

STATUS_LAN=NAO_CONECTADO

NIVEL_BATERIA=ALTO

MT_TOTAL=1048576 Kbytes

MT_USADA=254724 Kbytes

DH_ATUAL=19/08/2015 08:37:58

VER_SB=01.00.02

VER_LAYOUT=0.06

ULTIMO_CFe=35150853485215000106599000031160001247549846

LISTA_INICIAL=35150853485215000106599000031160001121550012

LISTA_FINAL=35150853485215000106599000031160001247549846

DH_CFe=19/08/2015 07:43:31

DH_ULTIMA=19/08/2015 07:43:51

CERT_EMISSAO=16/07/2015

CERT_VENCIMENTO=16/07/2020

ESTADO_OPERACAO=DESBLOQUEADO

Created with the Personal Edition of HelpNDoc: Write EPub books for the iPad


SAT.ConsultarNumeroSessao

Comandos ›› Comandos do Objeto SAT ››

SAT.ConsultarNumeroSessao(NumeroDeSessao)

Comando para efetuar a consulta pelo numero da sessão.

Exemplo:

SAT.ConsultarNumeroSessao(92238)

Exemplo de resposta:

Resposta:092238|06000|0000|Emitido com sucesso + conteudo notas.|||

Created with the Personal Edition of HelpNDoc: Free help authoring environment


SAT.AtualizaSoftware

Comandos ›› Comandos do Objeto SAT ››

Comando responsável por atualizar o software do aparelho SAT.

Exemplo de resposta:

OK: 183854|14000|Software Atualizado com Sucesso.||

Created with the Personal Edition of HelpNDoc: Full-featured EBook editor


SAT.ComunicarCertificadoICPBRASIL

Comandos ›› Comandos do Objeto SAT ››

Comando responsável por comunicar o certificado.

OK: 026668|05000|Certificado transmitido com Sucesso||

Created with the Personal Edition of HelpNDoc: Easily create iPhone documentation


SAT.ExtrairLogs

Comandos ›› Comandos do Objeto SAT ››

Comando responsável por extrair logs no caminho especificado.

SAT.ExtrairLogs(CaminhoArquivo)

Exemplo:

SAT.ExtrairLogs(C:\acbr\log.txt)

Exemplo de resposta:

NumeroSessao: 307889 - Resposta:307889|15000|Transferencia completa|||

Created with the Personal Edition of HelpNDoc: Easily create CHM Help documents


SAT.CriarCFe

Comandos ›› Comandos do Objeto SAT ››

Cria o XML a partir do arquivo ini informado no parâmetro: ArqINI.

SAT.CriarCFe(ArqINI)

Exemplo:

SAT.CriarCFe(C:\acbr\venda.ini)

Exemplo do arquivo ini:

[infCFe]

versao=0.05

[Identificacao]

CNPJ=11111111111111

signAC=12345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678904444

numeroCaixa=1

[Emitente]

CNPJ=11111111111111

IE=111111111111

IM=

indRatISSQN=S

[Destinatario]

CNPJCPF=11100011100

xNome=João

[Entrega]

xLgr=Rua Cel. Aureliano de Camargo

nro=973

xCpl=

xBairro=Centro

xMun=Tatui

UF=SP

[Produto001]

cProd=1189

infAdProd=Teste de Produto

cEAN=

xProd=OVO VERMELHO

NCM=04072100

CFOP=5102

uCom=DZ

Combustivel=0

qCom=510

vUnCom=2,70

indRegra=A

vDesc=0

vOutro=0

vItem12741=137,00

[ObsFiscoDet001001]

xCampoDet=Teste

xTextoDet=Texto Teste

[ICMS001]

Orig=0

CST=40

[PIS001]

CST=01

[COFINS001]

CST=01

[Total]

vCFeLei12741=137,00

[DescAcrEntr]

vDescSubtot=7,00

[Pagto001]

cMP=01

vMP=1400

[DadosAdicionais]

infCpl=Teste emissao CFe/SAT

[ObsFisco001]

xCampo=ObsFisco 1

xTexto=Teste ObsFisco 1")

Exemplo de Resposta:

OK: [CFE]

nCFe=0

Arquivo=C:\acbr\Enviado\201508\001-000000-satcfe.xml

XML=<?xml version="1.0" encoding="UTF-8"?><CFe><infCFe versaoDadosEnt="0.06"><ide><signAC/><numeroCaixa>001</numeroCaixa></ide><emit><IE/><indRatISSQN>S</indRatISSQN></emit><dest></dest><total><vCFeLei12741>0.00</vCFeLei12741></total><pgto></pgto></infCFe></CFe>

Created with the Personal Edition of HelpNDoc: News and information about help authoring tools and software


SAT.CriarEnviarCFe

Comandos ›› Comandos do Objeto SAT ››

Cria o XML de acordo com os dados do arquivo INI e envia o CFe.

SAT.CriarEnviarCFe(ArqINI)

Exemplo:

SAT.CriarCFe(C:\acbr\venda.ini)

Exemplo do arquivo ini:

[infCFe]

versao=0.05

[Identificacao]

CNPJ=11111111111111

signAC=12345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678904444

numeroCaixa=1

[Emitente]

CNPJ=11111111111111

IE=111111111111

IM=

indRatISSQN=S

[Destinatario]

CNPJCPF=11100011100

xNome=João

[Entrega]

xLgr=Rua Cel. Aureliano de Camargo

nro=973

xCpl=

xBairro=Centro

xMun=Tatui

UF=SP

[Produto001]

cProd=1189

infAdProd=Teste de Produto

cEAN=

xProd=OVO VERMELHO

NCM=04072100

CFOP=5102

uCom=DZ

Combustivel=0

qCom=510

vUnCom=2,70

indRegra=A

vDesc=0

vOutro=0

vItem12741=137,00

[ObsFiscoDet001001]

xCampoDet=Teste

xTextoDet=Texto Teste

[ICMS001]

Orig=0

CST=40

[PIS001]

CST=01

[COFINS001]

CST=01

[Total]

vCFeLei12741=137,00

[DescAcrEntr]

vDescSubtot=7,00

[Pagto001]

cMP=01

vMP=1400

[DadosAdicionais]

infCpl=Teste emissao CFe/SAT

[ObsFisco001]

xCampo=ObsFisco 1

xTexto=Teste ObsFisco 1

Exemplo de Resposta:

OK: [ENVIO]

Resultado=684153|06010|1999|'Emitido com sucesso + conteúdo notas.||

Created with the Personal Edition of HelpNDoc: Free EPub producer


SAT.EnviarCFe

Comandos ›› Comandos do Objeto SAT ››

Envia o XML informado no Parâmetro ArqXML.

SAT.EnviarCFe(ArqXML)

Exemplo:

SAT.EnviarCFe(C:\acbr\201508\001-000000-satcfe.xml)

Exemplo de resposta:

Resultado=684153|06010|1999|'Emitido com sucesso + conteúdo notas.||

Created with the Personal Edition of HelpNDoc: Easily create HTML Help documents


SAT.CancelarCFe

Comandos ›› Comandos do Objeto SAT ››

Comando responsável pelo cancelamento do CFe.

SAT.CancelarCFe(ArqXMLVenda)

Exemplo:

SAT.CancelarCFe("C:\acbr201508\AD35151082373077000171599000053040000018279130.xml")

Exemplo de Resposta:

OK: [CANCELAMENTO]

Resultado=247725|07000|0000|Cupom cancelado com sucesso + conteúdo CF-eSAT cancelado.||

Created with the Personal Edition of HelpNDoc: Write EPub books for the iPad


SAT.ImprimirExtratoVenda

Comandos ›› Comandos do Objeto SAT ››

Comando responsável por imprimir o comprovante do CFe.

SAT.ImprimirExtratoVenda(ArqXMLVenda)

Exemplo:

SAT.ImprimirExtratoVenda("C:\acbr\201508\AD35150808723218000186599000039710000092846780.xml")

Created with the Personal Edition of HelpNDoc: Easily create EPub books


SAT.ImprimirExtratoResumido

Comandos ›› Comandos do Objeto SAT ››

Comando responsável por imprimir o comprovante do CFe de forma resumida.

SAT.ImprimirExtratoResumido(ArqXMLVenda)

Exemplo:

SAT.ImprimirExtratoResumido("C:\acbr\AD35150808723218000186599000039710000092846780.xml")

Created with the Personal Edition of HelpNDoc: Free help authoring tool


SAT.ImprimirExtratoCancelamento

Comandos ›› Comandos do Objeto SAT ››

Comando responsável por imprimir o comprovante de cancelamento do CFe.

SAT.ImprimirExtratoCancelamento(ArqXMLVenda, ArqXMLCancelamento)

Exemplo:

SAT.ImprimirExtratoCancelamento("AD35151082373077000171599000053040000018279130.xml", "ADC35151082373077000171599000053040000021291200.xml")

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


SAT.TesteFimAFim

Comandos ›› Comandos do Objeto SAT ››

Comando responsável por testar a comunicação e funcionamento através de uma venda teste.

SAT.TesteFimAFim(ArqXMLVenda)

Exemplo de resposta:

OK: [TESTEFIMAFIM]

Resultado=511856|09098|0000|SAT em processamento. Tente novamente.||

numeroSessao=511856

codigoDeRetorno=9098

RetornoStr=511856|09098|0000|SAT em processamento. Tente novamente.||

XML=<?xml version="1.0" encoding="UTF-8"?><CFe><infCFe versaoDadosEnt="0.06"><ide><signAC/><numeroCaixa>001</numeroCaixa></ide><emit><IE/><indRatISSQN>S</indRatISSQN></emit><dest></dest><total><vCFeLei12741>0.00</vCFeLei12741></total><pgto></pgto></infCFe></CFe>

Created with the Personal Edition of HelpNDoc: Easily create Web Help sites


Comandos do Objeto ESCPOS

Comandos ››

Comandos aceitos pelo objeto ESCPOS.

Created with the Personal Edition of HelpNDoc: Full-featured EBook editor


PORTA

Comandos ›› Comandos do Objeto ESCPOS ››

Comandos para ler e alterar a porta.

Created with the Personal Edition of HelpNDoc: What is a Help Authoring tool?


ESCPOS.Porta

Comandos ›› Comandos do Objeto ESCPOS ›› PORTA ››

Comando: ESCPOS.porta

Comando para ler a porta utilizada para a comunicação.

Exemplo:

ESCPOS.porta

Exemplo de resposta:

OK: \\localhost\Dascom

Created with the Personal Edition of HelpNDoc: Free help authoring tool


ESCPOS.SetPorta

Comandos ›› Comandos do Objeto ESCPOS ›› PORTA ››

Comando: ESCPOS.setporta

Altera a porta de comunicação com a impressora.

Exemplo:

ESCPOS.setporta("COM4")

Exemplo de resposta:

OK:

Nota:

A impressora não pode estar ativa para a utilização desse comando.

Created with the Personal Edition of HelpNDoc: Full-featured Documentation generator


COLUNAS

Comandos ›› Comandos do Objeto ESCPOS ››

Comandos de colunas.

Created with the Personal Edition of HelpNDoc: Easy EPub and documentation editor


ESCPOS.Colunas

Comandos ›› Comandos do Objeto ESCPOS ›› COLUNAS ››

Columas: ESCPOS.colunas

Retorna a quantidade de colunas que a impressora está configurada.

Exemplo:

ESCPOS.colunas

Exemplo de respostas:

OK:48

Created with the Personal Edition of HelpNDoc: Generate EPub eBooks with ease


ESCPOS.SetColunasFonteNormal

Comandos ›› Comandos do Objeto ESCPOS ›› COLUNAS ››

Comando: ESCPOS.setcolunasfontenormal

Altera a quantidade impressa de colunas na impressora.

Exemplo:

ESCPOS.setcolunasfontenormal(64)

Exemplo de resposta:

OK:

Created with the Personal Edition of HelpNDoc: Easily create EBooks


ESCPOS.ColunasFonteExpandida

Comandos ›› Comandos do Objeto ESCPOS ›› COLUNAS ››

Comando: ESCPOS.colunasfonteexpandida

Retorna quantidade de colunas com a fonte expandida.

Exemplo:

ESCPOS.colunasfonteexpandida

Exemplo de resposta:

OK:24

Created with the Personal Edition of HelpNDoc: Free EPub producer


ESCPOS.ColunasFonteCondensada

Comandos ›› Comandos do Objeto ESCPOS ›› COLUNAS ››

Comando: ESCPOS.colunasfontecondensada

Retorna a quantidade de colunas com a letra condensada

Exemplo:

ESCPOS.colunasfontecondensada

Exemplo de resposta

OK:64

Created with the Personal Edition of HelpNDoc: News and information about help authoring tools and software


ESCPOS.ColunasFonteNormal

Comandos ›› Comandos do Objeto ESCPOS ›› COLUNAS ››

Comando: ESCPOS.colunasfontenormal

Retorna a quantidade de colunas com a fonte normal.

Exemplo:

ESCPOS.colunasfontenormal

Exemplo de resposta:

OK:48

Created with the Personal Edition of HelpNDoc: What is a Help Authoring tool?


ESCPOS.Ativar

Comandos ›› Comandos do Objeto ESCPOS ››

Comando: ESCPOS.ativar

Ativa a comunicação com a Impressora.

Exemplo de resposta:

OK:

Created with the Personal Edition of HelpNDoc: Free HTML Help documentation generator


ESCPOS.Desativar

Comandos ›› Comandos do Objeto ESCPOS ››

Comando: ESCPOS.desativar

Desativa a comunicação com a Impressora.

Exemplo de Resposta:

OK:

Created with the Personal Edition of HelpNDoc: Full-featured multi-format Help generator


ESCPOS.Ativo

Comandos ›› Comandos do Objeto ESCPOS ››

Comando: ESCPOS.ativo

Retorna "True" se a comunicação com a Impressora estiver ativa.

Exemplo de Resposta:

OK: True

Created with the Personal Edition of HelpNDoc: Easily create EBooks


ESCPOS.Imprimir

Comandos ›› Comandos do Objeto ESCPOS ››

Comando: ESCPOS.imprimir(nParametro).

Parâmetros:

nParametro- comandos em tags, que deseja imprimir.

Exemplos:

ESCPOS.imprimir("</zera></linha_dupla>FONTE NORMAL: 48 Colunas</lf>....+....1....+....2....+....3....+....4....+...</lf><e>EXPANDIDO: 24 Colunas</lf>....+....1....+....2....</lf></e><c>CONDENSADO: 64 Colunas</lf>....+....1....+....2....+....3....+....4....+....5....+....6....</lf></pular_linhas></corte_total>")

Exemplo de resposta:

OK:

Imprimir QRCode:

ESCPOS.imprimir("</zera></linha_dupla></lf><qrcode>http://projetoacbr.com.br</qrcode></lf></ce><qrcode>http://www.projetoacbr.com.br/forum/index.php?/page/SAC/sobre_o_sac.html</qrcode></lf></ad><qrcode>http://www.projetoacbr.com.br/forum/index.php?/page/SAC/questoes_importantes.html</qrcode></pular_linhas></corte_total>")

Exemplo de resposta:

OK:

Imprimir Código de Barras:

ESCPOS.imprimir("</zera></ce></linha_dupla></lf>EAN 8: 1234567</lf><ean8>1234567</ean8></pular_linhas></corte_total>")

Exemplo de resposta:

OK:

Imprimir Logotipo:

ESCPOS.imprimir("</zera></ce>Logo: - FatorX: 1 - FatorY: 1</logo></pular_linhas></corte_total>")

Exemplo de resposta:

OK:

Created with the Personal Edition of HelpNDoc: Free help authoring environment


ESCPOS.ImprimirLinha

Comandos ›› Comandos do Objeto ESCPOS ››

Comando: ESCPOS.imprimirlinha(nParamentro).

Comando para imprimir linha a linha o desejado.

Parâmetros:

nParametro- comandos em tags, que deseja imprimir.

Exemplos:

ESCPOS.imprimirlinha("</zera>")

ESCPOS.imprimirlinha("</linha_dupla>")

ESCPOS.imprimirlinha("TEXTO NORMAL")

ESCPOS.imprimirlinha("</fn></ce>ALINHADO NO CENTRO 1 2 3 TESTANDO")

ESCPOS.imprimirlinha("<n>FONTE NEGRITO</N>")

ESCPOS.imprimirlinha("<e>FONTE EXPANDIDA</e>")

ESCPOS.imprimirlinha("<c>FONTE CONDENSADA</e>")

ESCPOS.imprimirlinha("<in>FONTE INVERTIDA</in>")

ESCPOS.imprimirlinha("<S>FONTE SUBLINHADA</s>")

ESCPOS.imprimirlinha("<i>FONTE ITALICO</i>")

ESCPOS.imprimirlinha("</pular_linhas>")

ESCPOS.imprimirlinha("</corte_total>")

Exemplo de resposta:

OK:

Created with the Personal Edition of HelpNDoc: Full-featured EBook editor


ESCPOS.ImprimirCmd

Comandos ›› Comandos do Objeto ESCPOS ››

Comando: ESCPOS.imprimircmd(nParamentro).

Comando para imprimir os comandos sem "traduzi-los".

Parâmetros:

nParamentro- o que deseja imprimir.

Exemplo:

ESCPOS.imprimircmd("</zera><CE>*** TESTE DE TAGS INVÁLIDAS ***</CE><ce> <>tags inválidas no texto">">><<</CE><AD><da><ec></</A Direita</ad></corte_total>")

Exemplos de respostas:

OK:

Created with the Personal Edition of HelpNDoc: Full-featured Help generator


ESCPOS.ImprimirTags

Comandos ›› Comandos do Objeto ESCPOS ››

Comando: ESCPOS.imprimirtags.

Retorna as TAGS e suas descrições que são aceitas.

Exemplo:

ESCPOS.imprimirtags

Exemplo de resposta:

OK:

Saida da Impressão:

<n> - Liga Negrito

</n> - Desliga Negrito

<s> - Liga Sublinhado

</s> - Desliga Sublinhado

<c> - Liga Condensado

</c> - Desliga Condensado

<i> - Liga Italico

</i> - Desliga Italico

</fn> - Fonte Normal

</fa> - Liga Fonte Tipo A (normal)

</fb> - Liga Fonte Tipo B (condensada)

<in> - Liga Fonte Invertida (Fundo Preto)

</in> - Desliga Fonte Invertida

</ae> - Liga Alinhamento a Esquerda

</ce> - Liga Alinhamento ao Centro

</ad> - Liga Alinhamento a Direita

</linha_simples> - Imprime Linha Simples

</linha_dupla> - Imprime Linha Dupla

</pular_linhas> - Pula N Linhas de acordo com propriedade do componente

</logo> - Imprime Logotipo já gravado na Impressora (use utilitário do fabricante)

</corte_parcial> - Efetua Corte Parcial no Papel (não disponivel em alguns modelos)

</corte_total> - Efetua Corte Total no papel

</abre_gaveta> - Aciona a abertura da Gaveta de Dinheiro

</beep> - Emite um Beep na Impressora (não disponivel em alguns modelos)

</zera> - Reseta as configurações de Fonte Alinhamento.<LF>Ajusta Página de Código e Espaço entre Linhas

</lf> - Pula para a própxima linha

</cr> - Retorna para o Inicio da Linha

<ad> - Bloco - Texto Alinhado a Direita

<ae> - Bloco - Texto Alinhado a Esquerda

<ce> - Bloco - Texto Centralizado

<ean8> - Bloco - Cod.Barras EAN8 - 7 numeros e 1 dig.verificador

<ean13> - Bloco - Cod.Barras EAN13 - 12 numeros e 1 dig.verificador

<std> - Bloco - Cod.Barras "Standard 2 of 5" - apenas números, tamanho livre

<inter> - Bloco - Cod.Barras "Interleaved 2 of 5" - apenas números, tamanho PAR

<code11> - Bloco - Cod.Barras Code11 - apenas números, tamanho livre

<code39> - Bloco - Cod.Barras Code39 - Aceita: 0..9,A..Z, ,$,%,*,+,-,.,/, tamanho livre

<code93> - Bloco - Cod.Barras Code93 - Aceita: 0..9,A..Z,-,., ,$,/,+,%, tamanho livre

<code128> - Bloco - Cod.Barras Code128 - Todos os caracteres ASCII, tamanho livre

<upca> - Bloco - Cod.Barras UPCA - 11 numeros e 1 dig.verificador

<codabar> - Bloco - Cod.Barras CodaBar - Aceita: 0..9,A..D,a..d,$,+,-,.,/,:, tamanho livre

<msi> - Bloco - Cod.Barra MSI - Apenas números, 1 dígito verificador

<code128a> - Bloco - Cod.Barras Code128 - Subtipo A

<code128b> - Bloco - Cod.Barras Code128 - Subtipo B (padrão) = <code128>

<code128c> - Bloco - Cod.Barras Code128 - Subtipo C (informar valores em BCD)

<qrcode> - Bloco - Imprime QRCode de acordo com "ConfigQRCode"

<ignorar_tags> - Bloco - Ignora todas as Tags contidas no Bloco

Created with the Personal Edition of HelpNDoc: iPhone web sites made easy


ESCPOS.LerStatusImpressora

Comandos ›› Comandos do Objeto ESCPOS ››

Comando: ESCPOS.lerstatusimpressora

Retorna o Status da impressora.

Exemplo:

ESCPOS.lerstatusimpressora

Exemplos de respostas:

OK: stNaoSerial,

Respotas esperadas:

stErro, stNaoSerial, stPoucoPapel, stSemPapel, stGavetaAberta, stImprimindo, stOffLine, stTampaAberta.

Created with the Personal Edition of HelpNDoc: Free Web Help generator


ESCPOS.LerInfoImpressora

Comandos ›› Comandos do Objeto ESCPOS ››

Comando: ESCPOS.lerinfoimpressora

Retorna as informações da impressora, disponível apenas para Porta Serial.

Exemplo:

ESCPOS.lerinfoimpressora

Exemplo de resposta:

ERRO: Leitura de Informações só disponivel em Portas Seriais

Created with the Personal Edition of HelpNDoc: Free Web Help generator


ESCPOS.Modelo

Comandos ›› Comandos do Objeto ESCPOS ››

Comando: ESCPOS.modelo

Retorna o Modelo da impressora.

Exemplo:

ESCPOS.modelo

Exemplo de resposta:

OK: ppEscPosEpson

Possíveis respostas:

ppTexto, ppEscPosEpson, ppEscBematech, ppEscDaruma.

Created with the Personal Edition of HelpNDoc: Full-featured multi-format Help generator


ESCPOS.PaginaDeCodigo

Comandos ›› Comandos do Objeto ESCPOS ››

Comando: ESCPOS.paginadecodigo

Retorna a página de código configurada.

Exemplo:

ESCPOS.paginadecodigo

Exemplo de resposta:

OK: pc850

Possíveis respostas:

pcNone, pc437, pc850, pc852, pc860, pcUTF8, pc1252.

Created with the Personal Edition of HelpNDoc: Easily create EBooks


ESCPOS.LinhasEntreCupons

Comandos ›› Comandos do Objeto ESCPOS ››

Comando: ESCPOS.linhasentrecupons

Retorna a quantidade de linhas entre um cupom e outro

Exemplo:

ESCPOS.linhasentrecupons

Exemplo de resposta:

OK: 3

Created with the Personal Edition of HelpNDoc: Easily create HTML Help documents


ESCPOS.CortaPapel

Comandos ›› Comandos do Objeto ESCPOS ››

Comando: ESCPOS.cortapapel

Retorna se está configurada para corta o papel automático ou não

Exemplo:

ESCPOS.cortapapel

Exemplo de resposta:

OK: False

Created with the Personal Edition of HelpNDoc: Free CHM Help documentation generator


Outras Informações

Created with the Personal Edition of HelpNDoc: Write eBooks for the Kindle


Como usar o SVN

Outras Informações ››

O que é SVN ?

Uma alternativa para ter sempre a ultima versão do projeto (a de desenvolvimento), é fazer download via SVN.

O projeto ACBr passou a usar um sistema de controle de versão chamado SVN a partir do dia 13/03/2009. Os sistemas de controle de versão visam simplificar a colaboração entre equipes e ainda controlar o histórico de atualizações dos arquivos. O SVN guarda todas as alterações em cada arquivo como uma versão numerada e sempre que necessário podemos comparar ou até mesmo voltar para uma versão anterior, sem deixar de ter a versão mais atual guardada do repositório (servidor do SVN).

Este sistema é disponibilizado pelo Sourceforge para o projeto permite o acesso somente de leitura para qualquer usuário e um acesso com permissão de escrita (também conhecida como "commiter"). As contas de commiter serão dadas pelo mérito, portanto é um processo natural. Não há a necessidade de pedir por este tipo de conta, se você têm contribuido para o projeto e a equipe de desenvolvedores sente que você já compreendeu as metodologias e processos envolvidos, uma conta de commiter será oferecida a você.

Para baixar os fontes do SVN, use a seguinte linha:

https://acbr.svn.sourceforge.net/svnroot/acbr/trunk2

Opcionalmente, você pode usar a linha https://acbr.svn.sourceforge.net/svnroot/acbr/ e baixar as pastas tags e branches. Na pasta tags, serão mantidas versões anteriores do projeto, e na pasta branches, versões em desenvolvimento ainda não estáveis.

SVN no Windows (Tortoise)

No Windows, o melhor aplicativo a ser usado é o TortoiseSVN (http://tortoisesvn.net/downloads), pois ele se integra com o Windows Explorer.

Se você escolheu a língua portuguesa, quando falamos em "commit", entenda "gravar"; quando falamos em "update", entenda "atualizar" e quando falamos em "checkout" entenda "obter módulo".

  • Baixe o TortoiseSVN (http://tortoisesvn.net/downloads)
  • Depois de Instalado, crie um diretório para o baixar o ACBr
  • Usando o Windows Explorer, clique com o botão direto sobre o diretório e escolha: SVN Checkout
  • Em URL of repository digite:
    https://acbr.svn.sourceforge.net/svnroot/acbr/trunk2
  • Basta clicar em OK e o Tortoise irá criar a Estrutura de diretórios do ACBr atualizado exatamente como utilizado pelos desenvolvedores
  • Nas próximas vezes, quando desejar atualizar os Fontes, basta clicar com o Botão direito no diretório e usar: SVN Atualizar.
    (Nesse caso somente os fontes modificados ou novos serão baixados)

Created with the Personal Edition of HelpNDoc: Free PDF documentation generator


Como efetuar doações

Outras Informações ››

Agradecemos o seu seu interesse em efetuar doações ao Projeto ACBr.

Sua doação motivará a equipe de desenvolvimento do ACBrMonitor a continuar e aprimorar este trabalho

Para efetuar doações para o Projeto ACBr por favor acesse o seguinte endereço:

http://acbr.sourceforge.net/drupal/?q=node/14

Created with the Personal Edition of HelpNDoc: Free CHM Help documentation generator


Como ajudar no projeto

Outras Informações ››

Se você possui experiência em Automação comercial e deseja ajudar, junte-se a nós... ficaremos muito contente com a sua ajuda.

Testando os Componentes:

Fizemos o possível para eliminar os bugs mais óbvios... mas em ambientes diferente bugs novos podem aparecer. Por favor nós envie-nos um e-mail com os seus testes. Mesmo que tudo dê certo ainda sim gostaríamos da sua opinião...

Divulgando o ACBr:

Quanto maior o uso da biblioteca mais usuários podem ajudar. Se a biblioteca for bem conhecida e utilizada os Fabricantes de equipamentos de Automação Comercial terão maior interesse em ajudar no desenvolvimento.

Desenvolvendo Componentes:

Alguns componentes como o ACBrECF deverão ser implementados para vários modelos de equipamento. Se o equipamento que você deseja não consta na relação de Equipamentos a compatíveis você pode estudar os Fontes e tentar implementar uma nova Classe para o seu Equipamento (Por favor, entre em contato antes)

Emprestando Equipamentos:

Nem sempre temos acesso aos Equipamentos para testes e melhorias. Se você é um fabricante ou possui um equipamento disponível para empréstimo, entre em contato Em breve estarei relacionando os equipamentos que necessitam de testes...

Efetuando Doações:

Atualmente a Biblioteca é desenvolvida no tempo livre disponível dos Desenvolvedores.... Doações podem motivar os desenvolvedores a destinar mais tempo para o andamento do projeto.... pois é... até mesmo os programadores precisam comer.... ;-)

Created with the Personal Edition of HelpNDoc: Generate Kindle eBooks with ease


ACBrMonitor com Emulador de ECF

Outras Informações ››

Caso você não possua um ECF para testar o ACBrMonitor, você pode usar um emulador de ECF e um emulador de porta seriais.

Baixe o emulador de sua preferência (Bematech, Epson, FiscNet, Sweda, etc...) e depois baixe o programa com0com no seguinte endereço: http://com0com.sourceforge.net/

Extrai o conteúdo do arquivo baixado e execute o programa setup.exe

Apenas pressione Avançar (Next) nas telas de instalação.

Após o programa ser instalado, a tela de novo Hardware do Windows irá abrir, deixe a opção de detecção automática e pressione Avançar (Next) novamente.

Feito isto, será criado um par de portas virtuais com o nome de CNCA0 e CNCB0.

Para alterar o nome das portas execute o Programa de Prompt do Setup Command Prompt que será criado na pasta com0com no menu iniciar e digite:

change CNCA0 PortName=COM2

change CNCB0 PortName=COM3

Configure o ACBrMonitor para uma das portas criada e o emulador para a outra porta.

Created with the Personal Edition of HelpNDoc: News and information about help authoring tools and software


Como compilar o ACBrMonitor

Outras Informações ››

A partir da versão 0.9.0, o ACBrMonitor é compilado através do Lazarus/FPC .

Todas as ferramentas utilizadas para compilar o ACBrMonitor e gerar seus instaladores são de código aberto, e podem ser obtidas gratuitamente na Internet, conforme instruções abaixo:

  1. Clique aqui, e Baixe o Lazarus (Escolha a combinação atual de WIN32 e FPC 2.5.1)
  2. Instale o Lazarus,
  3. Clique aqui e aprenda como Baixar os fontes do ACBr pelo SVN
  4. Instale o ACBr no Lazarus, seguindo as instruções do arquivo LEIA-ME.TXT do ACBr
  5. Abra o projeto ACBrMonitor.lpi em: ACBr\Projetos\ACBrMonitor\Lazarus....
  6. clique em Run -> Build All.
    (aqui você já tem o ACBrMonitor.exe, e se desejar, basta copia-lo para a máquina destino, substituindo o antigo... Para gerar o instalador vamos adiante... )
  7. Abra o projeto do ACBrMonitorConsole.lpi, clique em Run -> Build All
  8. Abra o ECFTeste.lpi em: \ACBr\Exemplos\ACBrECF\Lazarus, e Compile com Run -> Build All
  9. Copie o ECFTeste.exe que acabou de ser gerado, para pasta do ACBrMonitor em: ACBr\Projetos\ACBrMonitor\Lazarus
  10. Pronto, temos todos os binários compilados, basta agora gerar o instalador. No Windows, baixe e instale o InnoSetup ., para Linux baixe e instale o InstallJammer
  11. No InnoSetup, abra o Script de instalação ACBrMonitor.iss... Clique em Compile, o instalador será gerado na sub-pasta: Output
    No InstallJammer, abra o Projeto de instalação InstallJammer\ACBrMonitor\ACBrMonitor.mpi... Clique em Build Install, o instalador será gerado na sub-pasta: InstallJammer\ACBrMonitor\output

Created with the Personal Edition of HelpNDoc: Free Kindle producer


Nota Fiscal Paulista. Como Gerar o arquivo RFD

Outras Informações ››

Basta acionar a opção RFD, na aba RFD, e preencher as outras abas com os Dados do ECF, do Contribuinte e da Sw.House.

Lembre-se que vc deve usar sempre a mesma chave Privada em todos os clientes. Gere tb a chave publica, e grave-as em um local seguro. Se o fisco solicitar você precisa entregar a chave Publica. Eu achei mais prático copiar um arquivo swh.ini padrão, após a instalação do ACBrMonitor (esse arquivo mantem todos os dados da Sw.House, inclusive a chave).

Para mais informações acesse http://www.forumweb.com.br/foruns/index.php?showtopic=65522

Created with the Personal Edition of HelpNDoc: News and information about help authoring tools and software


Como usar o ACBrMonitorConsole no Linux

Outras Informações ››

O ACBrMonitorConsole, é muito útil para aplicações que trabalham apenas em modo Texto no Linux (não precisa do Servido X)...

Com ele você pode conectar a um servidor SSH e controlar um ECF (ou outro equipamento) na estação local.

Carregue-o com:

/opt/ACBrMonitor/ACBrMonitorConsole > /dev/null &

ssh IP_do_seu_servidor

.....

Onde:

> /dev/null - Desvia as saidas de tela do ACBrMonitorConsole para /dev/null, ou seja, ignora as mensagens do ACBrMonitorConsole.

Também seria possível desviar as mensagens para um arquivo texto e criar um Log..

& - Faz o ACBrMonitorConsole rodar em segundo plano

Created with the Personal Edition of HelpNDoc: Produce Kindle eBooks easily


Seja Assinante do ACBrSAC

Created with the Personal Edition of HelpNDoc: Write eBooks for the Kindle


Sobre o SAC

Seja Assinante do ACBrSAC ››

O SAC - Suporte ACBr Comercial é uma modalidade disponibilizada pela DJSystem para todos os desenvolvedores que utilizam e/ou querem utilizar o Projeto ACBr em seus aplicativos e necessitam de um suporte especializado.

Quais as vantagens de utilizar o SAC ?

Acesso a fórum privativo;

Resposta em até 1 dia útil;

Disponibilização do ACBrMonitor/ACBrNFeMonitor compilados semanalmente;

Contribuir para que o projeto cresça de maneira sustentável;

Programadores dedicados exclusivamente à prestação de suporte;

Maior credibilidade ao Projeto ACBr.

Planos para contratação do SAC

R$ 120,00 por mês*

Mais informações

Created with the Personal Edition of HelpNDoc: Easy CHM and documentation editor


Questões importantes

Seja Assinante do ACBrSAC ››

Questões Importantes

O ACBr terá seu código fechado ?

Não. O ACBr nunca terá seu código fechado. A própria licença usada nos fontes do projeto (LGPL) impediria isso. A DJSystem, empresa que é a principal mantenedora do Projeto ACBr, está apenas oferecendo um novo serviço, que é o SAC, ou Suporte ACBr Comercial, a contratação do serviço é opcional.

O acesso aos fontes do projeto ACBr será modificado ?

Não. O Projeto ACBr continuará hospedado no site SourceForge.com, e nada será modificado na maneira atual de se obter acesso aos fontes.

Quais os tipos de suporte que o SAC oferece ?

Todas as dúvidas de usuários do SAC devem ser postadas no Fórum privativo. Não há suporte por acesso remoto, e-mail, telefone, MSN ou Skype.

O Fórum será fechado ?

Não. O fórum atual sempre continuará aberto e gratuito. Porém o SAC oferece acesso a um novo fórum, de conteúdo fechado, e com garantia de resposta em até 1 dia útil. Os funcionários da DJSystem que estão envolvidos diretamente no Projeto ACBr, continuarão ativos nos dois fóruns.

Por que o SAC foi criado ?

Tivemos várias motivações:

-Atender a solicitação de diversas empresas, que nos procuraram em busca de um suporte especializado dos componentes ACBr.

-Trazer maior credibilidade ao Projeto ACBr

-Profissionalizar o Projeto ACBr, que de acordo com a renda obtida, poderá contratar desenvolvedores dedicados, ajudando o ACBr a crescer cada vez mais.

Sou obrigado a contratar o SAC para usar o Projeto ACBr ?

De maneira alguma. O Projeto ACBr é Código Aberto, todos podem baixá-lo e utilizá-lo livremente. O SAC visa atender aqueles desejam um suporte ágil e especializado sobre os produtos do Projeto, ou ainda se você deseja contribuir financeiramente com o contínuo desenvolvimento do Projeto.

Se aderir ao SAC, tenho direito a solicitar desenvolvimento específico ?

Não. Ser membro do SAC não dá o direito de solicitar o desenvolvimento de rotinas ou componentes específicos. A correção de erros sempre será a prioridade, mas antes é fundamental averiguar se o problema está realmente nos fontes do ACBr. Os usuários do SAC tem um peso maior nas decisões de quais componentes devem ser desenvolvidos ou melhorados

Que tipo de perguntas posso fazer no fórum do SAC ?

Apenas perguntas técnicas sobre os componentes serão respondidas no fórum exclusivo as demais perguntas serão movidas para o fórum aberto. Perguntas sobre legislação, instalação de certificados digitais, preenchimento de NFe, parte contábil ou financeira ou qualquer outro assunto fora do escopo técnico do componente não será respondido.

O que ocorrerá quando eu atingir o limite de Perguntas no mês ?

Você poderá adquirir pacotes de perguntas adicionais.

As perguntas não utilizadas acumulam para o próximo mês ?

Não. As perguntas deverão ser utilizadas no mês e não acumulam para o próximo mês.

Sou desenvolvedor ativo do ACBr, o que eu ganho com o SAC ?

Todos os desenvolvedores com direito de gravação nos fontes do ACBr já são usuários do SAC, possuindo acesso pleno ao fórum exclusivo. Conforme a demanda de usuários do SAC, a DJSystem precisará contratar consultores ou programadores para tarefas específicas e os atuais desenvolvedores envolvidos no projeto ACBr são candidatos naturais para esta tarefa.

O Projeto continuará recebendo doações ?

Sim. O sucesso das doações foi o que mais motivou a DJSystem a investir profissionalmente no Projeto ACBr. Se você desejar, pode continuar a contribuir financeiramente com o projeto através das doações.

O Projeto continuará aceitando ajuda nos códigos fontes ?

Certamente que sim. Todo projeto de Código Aberto precisa da ajuda da comunidade de usuários para crescer com qualidade. Essa é uma das principais vantagens do modelo de Código Aberto, todos podem contribuir para a melhoria do código. A analise das contribuições continuará da mesma maneira que é feita hoje, ou seja, através de qualquer desenvolvedor que tenha direito de gravação no nosso repositório de fontes, mesmo que ele não seja diretamente envolvido com o SAC.

O SAC tem como principal finalidade contribuir para o crescimento do Projeto ACBr

Created with the Personal Edition of HelpNDoc: What is a Help Authoring tool?


Onde posso assinar ?

Seja Assinante do ACBrSAC ››

O cadastro para assinatura do ACBrSAC pode ser feito no link Assinar...

Created with the Personal Edition of HelpNDoc: Full-featured Help generator